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      Flash este o aplicatie prin care se pot crea si dezvolta elemente multimedia (audio, video), continut text, efecte grafice, animatii si chiar jocuri; folosite cel mai mult in pagini web, de asemenea, diferite interfete si aplicatii facute cu Flash sunt utilizate si pentru PDA-uri si telefoane mobile (de exemplu Flash Player).
Aceasta tehnologie a fost initial dezvoltata de Macromedia si se numea "Macromedia Flash", i-a fost schimbata denumirea in "Adobe Flash" dupa ce a fost preluata de Adobe odata cu achizitionarea companiei Macromedia (in 2005).
Adobe Flash combina si uneste in acelasi program elemente de grafica vectoriala si programare web (ActionScript), ceea ce-l face util atat pentru designeri cat si dezvoltatorii web.
O gama larga din efectele create cu Flash pot fi facute si cu JavaScript, dar in cazul JavaScript apare adesea probleme cauzate de incompatibilitatea dintre navigatoarele web. Lucru ce nu se produce in cazul continutului Flash, care necesita doar instalarea unui Flash Player ce va interpreta si afisa documentul Flash dupa cum a fost creat, indiferent daca browser-ul este Internet Explorer, Mozilla Firefox, Opera, Safari, si altele.
Flash poate lucra si cu surse externe, precum documente XML, script-uri JavaScript, PHP si baze de date MySQL. Datorita acestor capabilitati, tehnologia Flash capata din ce in ce mai mult teren in domeniul site-urilor si a dezvoltarii Web.

Principalele ferestre de lucru in Adobe Flash CS5

Acest curs de Flash prezinta si are ca aplicatie de lucru ultima versiune de Adobe Flash, aparuta in 2010, si anume "Adobe Flash CS5" (care e asemanatoare cu "Adobe Flash CS4").
Daca nu ati mai utilizat Adobe Flash sau ati lucrat cu versiuni mai vechi, e bine ca mai intai sa va familiarizati cu principalele ferestre de lucru, care sunt prezentate mai jos, cu explicatii in 

- Fereastra de deschidere
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- Aceasta e fereastra ce apare la poornirea aplicatiei Adobe Flash CS5. De aici se poate incepe deschiderea unei ferestre de lucru pentru a crea un document nou, sau deschiderea unui document Flash ce a fost salvat ori se afla in limbraria de Template a programului, precum si legaturi catre documentatie online a site-ului oficial.

- Pentru crearea unui document nou Flash se alege de obicei ActionScript 3.0
- Celelalte optiuni din coloana Create New sunt pentru proiecte Flash speciale, ce au ca tinta diferite sisteme.
- Cu Adobe AIR 2.0 se pot crea aplicatii pt. desktop (pt. Mac, Windows, si Linux).
- Cu iPhone OS, aplicatii pentru iPhone, iTouch, si dispozitive iPad.
- Flash Lite 4 este pentru crearea de continut Flash ce foloseste un Flash Player pt. sisteme cu mai putina memorie si putere.
- De asemenea pot fi create fisiere ce contin doar cod ActionScript si altele mai complicate, pentru avansati.
- Fereastra de lucru
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- Aceasta e fereastra principala de lucru, cu meniurile si instrumentele pentru crearea, modificarea si salvarea documentelor flash.
Simpla animatie Flash, Save, Export

Pentru inceput, pentru a demonstra cat de usor este lucrul in Adobe Flash, mai ales pentru elementele simple, iata cat de simplu poate fi creata o animatie Flash, in doar cateva miscari.
Efectuati pasii urmatori:

1. Deschideti aplicatia Adobe Flash si dati click pe ActionScript 3.0, de la coloana Create New a paginii de start.
  - Daca pagina de start nu e vizibila initial, dati click pe meniul File -> New... (sau Ctrl+N) si alegeti ActionScript 3.0, apoi OK.
2. Dati click pe dreptunghiul din bara cu instrumente pentru desen (sau apasati tasta R). Se observa ca dreptunghiul din bara instrumentelor de desen devine activ, acum mouse-ul va putea desena dreptunghi-uri (sau patrate) pe suprafata de lucru.
3. In partea stanga a zonei de lucru trasati un patrat de dimensiuni medii.
4. In panoul Timeline, ce contine un sir cu mai multe celule (cadre), selectati cadrul 25 (vedeti imaginea "Select cadru"), apoi, dati click pe meniul Insert -> Timeline si Blank keyframe (sau apasati tasta F7). Va apare o scena goala (alba).
  - Panoul Timeline ar trebui sa fie vizibil sub scena alba, daca nu apare, dati click pe meniul Window -> Timeline.
Select cadru
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5. Apasati tasta O, ceea ce va face cursorul sa poata desena fguri ovale, cercuri; si desenati un cerc de dimensiuni medii in partea dreapta a scenei.
6. Dati click pe punctul de sub numarul 1 din panoul Timeline, ceea ce va reintoarce la cadrul 1 (unde incepe animatia).
  - Acel punct reprezinta un indiciu ca exista continut in acel cadru.
7. Click meniul Insert si alegeti Shape Tween (vedeti imaginea "Insert Shape Tween"). Acum animatia e creata.
8. Pentru a vedea animatia, click pe meniul Control si Play (sau apasati tasta Enter).

Insert Shape Tween
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- Pentru a vedea rezultatul obtinut, click pe imaginea de mai jos:
Exemplu animatie Flash
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Salvarea / Deschidere / Export continut Flash

Un fisier Flash se numeste in general document. Documentele Flash sunt salvate (meniul File -> Save, sau Ctrl+S) cu extensia ".fla".
Fisierele ".fla" contin toate informatiile necesare pentru ca respectivul document Flash sa poata fi deschis si modificat cu programul Adobe Flash.

- De exemplu, pentru a salva animatia facuta si prezentata mai sus, apasati Ctrl+S (sau meniul File -> Save), apoi, in fereastra care apare alegeti directorul in care sa fie salvat documentul, dati-i un nume sugestiv (ca mai tarziu sa stiti despre ce e vorba), de exemplu "prima_animatie.fla" si apasati Save. Documentul creat si elementele din el sunt salvate.

Astfel, oricand se pot efectua modiificari, adaugari la aceasta animatie prin deschiderea documentului ".fla" salvat, cu aplicatia Adobe Flash, apasand Ctrl+O (sau din meniul File -> Open).

Pentru a adauga intr-o pagina Web continutul Flash creat intr-un document (.fla), trebuie ca acesta sa fie Exportat cu extensia ".swf", din meniul File -> Export siExport Movie. Prin aceasta se va obine un fisier cu extensia ".swf" ce contine animatia, efectele sau ce a fost creat in respectivul document ".fla", si care sunt recunoscute si afisate de Flash Player-ul instalat in browser.
Continutul fisierului ".swf" poate fi inclus intr-o pagina web folosind urmatorul cod (X)HTML:

<object type="application/x-shockwave-flash" data="nume_fisier.swf" width="400" height="500">
  <param name="src" value="nume_fisier.swf" />
  <param name="bgcolor" value="#e8e8fe" />
</object>

- "nume_fisier.swf" e calea si numele fisierului SWF.
- "width" si "height" stabilesc lungimea, respectiv inaltimea, suprafetei in care va fi afisat continutul Flash in pagina.
- value="#e8e8fe" defineste culoarea de fundal a suprafetei in care e adaugat continutul Flash.

- De exemplu, pentru a include intr-o pagina HTML animatia creata mai sus, intai trebuie exportata ca fisier SWF (click pe meniul File -> Export si Export Movie), in fereastra care apare alegeti directorul in care sa fie salvat fisierul si dati un nume (de ex. "prima_animatie.swf") si apasati Save.
In pagina HTML se adauga urmatorul cod:
<object type="application/x-shockwave-flash" data="prima_animatie.swf" width="400" height="500">
  <param name="src" value="prima_animatie.swf" />
  <param name="bgcolor" value="#e8e8fe" />
</object>

- Daca directorul in care se afla pagina HTML e diferit de cel in care se gaseste fisierul SWF, la "prima_animatie.swf" trebuie adaugata si calea catre acel director.


In afara de formatul initial de salvare (Flash CS5 Document (*.fla)), documentul Flash poate fi salvat (de la File -> Save sau File -> Save As) ca:
                - Flash CS4 Document (*.fla) - Util daca acel document trebuie ulterior deschis si prelucrat cu versiunea Adobe Flash CS4
                - Flash CS5 Uncompressed Document (*.xfl) - Acest format va crea un director cu un fisier ".xfl" si alte tipuri de fisiere (JPG, XML, DAT) ce vor contine informatii despre acel document Flash, care pot fi folosite si in alte programe, precum Adobe InDesign si Adobe After Effects.
- Documentul Flash poate fi salvat si ca Template, de la meniul File -> Save as Template. Acesta va putea fi apoi deschis si folosit din libraria cu Template-uri, de la meniul File -> New, iar in fereastra care apare se alege categoria "Templates".

Pe langa optiunea de export ca fisier ".swf", exista inca o modalitate de export des utilizata, si anume Export Image. Cu aceasta se poate crea o imagine a scenei curente de lucru (cu toate desenele din cadrul ei), salvata in fisiere cu format: bmp, jpg, jpeg, gif sau png. Pentru aceasta, se alege meniul File -> Export -> Export Image, iar in fereastra care apare se poate alege directorul si tipul (extensia) fisierului cu imaginea salvata.

Scena, panouri si instrumente de lucru in Flash

In acest tutorial vor fi prezentate scena si principalele panouri de lucru, cu instrumentele lor.

Pozitia Panourilor de lucru, precum Timeline, cel cu unelte de desen, sau cu proprietati, poate fi modificata prin tragerea lor cu mouse-ul sau din meniulWindow -> Workspace si alegand una din optiunile ce apar (Animator, Classic, si altele).

1. Scena de lucru

Scena este zona, sau suprafata de lucru, reprezentata prin dreptunghiul mare si alb din centru. In acesta se creaza si se adauga text, imagini, desene si orice elementele care vor fi vazute de utilizator. Elementele care sunt create in afara dreptunghiului alb nu vor fi vizibile in continutul Flash redat de Flash Player.
Scena este precum o panza pe care pictorul picteaza, i-se poate defini dimensiunile (lungime, inaltime) si culoarea.
Initial, scena are dimensiunile 550x400 pixeli; acestea, precum si culoarea de fundal se vad si pot fi setate din panoul cu Proprietati(vedeti imaginea de mai jos).

- Scena de lucru
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- Zoom-ul nu modifica dimensiunile scenei sau elementelor din ea, ci doar mareste sau micsoreaza vizualizarea lor.
- Pe langa dimensiuni si culoare de fundal, un alt element important ce apare la proprietatile scenei este FPS (Frame Per Second), acesta defineste numarul de cadre pe secunda, ce vor fi rulate in cazul animatiilor. Un cadru reprezinta o celula (casuta) alba din linia de cadre din panoul Timeline.
Ca sa puteti pozitiona elementele in scena de lucru cu precizie exacta, se poate afisa in latura de sus si stanga o rigla cu unitatea de masura definita in document (de obicei pixeli), din meniul View -> Ruler, si de asemenea se poate imparti scena intr-o grila ce poate ajuta mult la pozitionare, din meniul View -> Grid -> Show Grid(vedeti imaginea de jos).
- Scena cu rigla si grila
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- Liniile grilei nu vor fi vizibile in continutul final Flash.
- Dimensiunile celulei grilei pot fi modificate din: View -> Grid -> Edit Grid

Pentru a lucra cu alte modificari ce pot fi aplicate in legatura cu Scena, dati click pe meniul Window -> Other Panels -> Scene, va apare un mic panou ca in imaginea urmatoare:
- Panou de lucru prntru scene
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- De aici se poate adauga o noua scena, prin click pe iconita ce indica "Add Scene" (in stanga jos a panoului), langa aceasta se afla un buton pentru a dubla scena curenta, iar urmatorul pentru stergerea scenei curente.
- Numele scenei poate fi modificat prin dublu click pe ea, in acel panou.
Daca sunt mai multe Scene in document, se poate trece de la una la alta prin click pe iconita ce indica "Edit Scene" (din partea dreapta-sus a Scenei de lucru, dupa cum se vede in imaginea de sus).

2. Panoul cu instrumente pentru grafica si desen

In panoul vertical ce apare de obicei in marginea din dreapta (sau stanga) sunt instrumentele pentru grafica si desen: creion, linie, pensula, figuri geometrice, culori, si altele (vedeti imaginea de mai jos).
- Instrumente pentru desen
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- Instrumentele pentru selectare sunt folosite pentru a selecta diferite elemente create in scena de lucru, dupa care li-se pot modifica proprietatile, forma, aspectul, se pot grupa, si alte modificari ce se aplica doar obiectelor selectate.
- Instrumentele pentru desen si modificare sunt folosite pentru a crea diferite desene si text grafic cu o ampla paleta de culori.
- Instrumentele de vizualizare sunt doua. Manuta ca sa fie mutata scena, iar lupa pentru a mari vizualizarea.
- Instrumentele pentru setare culori se folosesc pt. definirea culorii liniei exterioare si a fundalului desenelor sau suprafetei de text.
- Zona cu optiuni cuprinde modificatori specifici pentru anumite instrumente, cum ar fi, modul de desen al creionului, forma radierei sau distorsionarea unui element selectat. De ex., cand se ta click pe lupa, in zona de optiuni apare optiunea de a alege lupa pt. marit "+" sau micsorat "-".

Observati ca unele instrumente au un mic triunghi in partea de jos-dreapta, acesta indica faptul ca in acel buton se mai afla si alte unelte. Daca dati click pe acel buton, apoi, inca o data click pe el vor apare si acele unelte, ce fac parte din aceeasi categorie.
Cand pozitionati mouse-ul pe fiecare instrument, apare denumirea lui si o litera in paranteza. De exemplu, la dreptunghi apare "Rectangle Tool (R)", la creion "Pencil Tool (Y)". Litera din paranteze reprezinta tasta ce poate fi apasata pentru a activa instrumentul respectiv, la fel ca si cum s-ar da click pe el. Astfel, pentru a trece in modul de desenare dreptunghi, se poate apasa tasta "R".
Ca sa invatati mai bine ce fac aceste instrumente, incercati singuri pe fiecare si vedeti ce obtineti.
De exemplu, desenati un drepunghi, modificati-i culorile, selectati-l, jucati-va cu proprietatile lui. Apoi un cerc si cateva linii de desen.
Cand selectati cu "Free Transform Tool (Q)" observati si uneltele ce apar in zona cu optiuni.

3. Panoul Timeline

Timeline este un panou mai special, poate mai dificil de inteles la inceput, drept care se invata mai bine prin practica si diferite exersari.
Pe scurt, Timeline se ocupa cu animatia si stratificarea elementelor in scena de lucru, prin ceea ce se numeste "Layer" (Strat).
Un aspect important ce trebuie avut in vedere in lucrul cu Timeline, si in general cu animatiile, este FPS-ul (Frame Per Second), care initial e definit 24 (la proprietatile cu dimensiunile Scenei). Acesta indica numarul de cadre folosite pentru o secunda de animatie. Astfel, pentru 2 secunde de animatie se folosesc 48 cadre (in general, se creaza elementele din primul si ultimul cadru si legatura dintre ele)
Punctul negru ce apare in josul unei celule (cadru) indica faptul ca exista elemente create in acel cadru.
Prin click dreapta pe un cadru apar functiile ce pot fi efectuate in acea linie de cadre, precum: Insert Frame (va adauga un cadru dupa cel curent), Remove Frame (va sterge cadrul curent), Clear Frame (va sterge continutul din el), Copy Frame, Action (O functie importanta, deschide fereastra pt. adaugare cod ActionScript), si alte functii ce pot fi invatate daca testati sa vedeti ce fac.
Layers

In panoul Timeline pot fi adaugate mai multe linii cu Cadre, ce se numesc Layers (Straturi), acestea se folosesc pentru a crea elemente si animatii care sa fie suprapuse. Astfel, pot fi create mai multe efecte animate in acelasi timp, sau desene si imagini care se suprapun (peste cele din Straturile de dedesubt, din acelasi cadru). Se pot crea si edita obiecte dintr-un Layer fara a afecta ce se afla in celelalte Layers.
Initial, documentul are un singur Layer. Se poate crea un Strat nou prin una din urmatoarele moduri:
      - Clik dreapta pe Stratul existent si apoi Insert Layer, ori din meniul Insert -> Timeline -> Layer, sau din iconita din stanga-jos a panoului Timeline, ce indica "New Layer". Va fi adaugat un Layer nou imediat deasupra celui curent, selectat.
Numele Straturilor apare in partea stanga a panoului Timeline (poate fi modificat prin dublu-click pe nume sau click dreapta si apoi Properties...), vedeti imaginea de jos.
- Panoul Timeline
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La Stratul care este activ, apare un mic creion in dreptul numelui acelui Layer.
Stergerea unui strat se poate face tot din meniul ce apare cand se da click dreapta pe numele acelui Strat, de la optiunea Delete Layer.
In dreptul numelui Stratului apar si alte mici puncte, prin apasarea lor se poate Ascunde (sau Arata) Stratul respectiv in documentul Flash (elementele din el vor dispare din scena), sau se poate Bloca (sau Debloca) acel Layer.
Pentru a copia un Layer, se procedeaza astfel:
      - Click pe Stratul ce va fi copiat, apoi click meniul Edit -> Timeline -> Copy Frames (sau Ctrl+Alt+C), apoi click pe stratul in care va fi facuta copierea (poate fi creat unul nou inainte), apoi click meniul Edit -> Timeline -> Paste Frames (sau Ctrl+Alt+P).
4. Panoul Library

Library este un panou destul de util in crearea continutului Flash, de obicei este situat langa "PROPERTIES". In el sunt stocate obiectele ce au fost convertite inSymbols sau imagini sau alte resurse ce au fost introduse cu Import (din meniul File).
- La ce este util Library? In acest panou fiind stocate toate obiectele "Symbol" si cele Importate in documentul Flash, daca se doreste recrearea /reutilizarea unia din aceste elemente in alt cadru, poate fi pur si simplu luat din Library prin "tragere" cu mouse-ul, economisind timp. La fel, obiectele create in Scena de lucru pot fi adaugate in Library prin tragerea lor cu mouse-ul in acest panou, in zona unde este lista cu numele celor stocate.
Daca un obiect a fost adaugat in Library si apoi este sters din Scena de lucru, el ramane inca in Library si poate fi reutilizat.
O alta particulartate a elementelor adaugate in acest panou este mostenirea modificarilor. Daca un element este editat din Library (prin click dreapta pe numele lui in acest panou si apoi Edit), modificarile facute vor fi transmise tuturor copiilor ce au fost facute din el in Scena.

Se recomanda adaugarea in Library a oricarui desen, obiect, grup care va trebui sa fie folosit mai mult de doua ori in documentul Flash. Astfel, cand acel element trebuie adaugat si in alt loc se trage pur si simplu din Library.
- Acel element ar putea fi adaugat si in alt loc prin copiere din prima locatie, cu "Copy - Paste", dar aceasta metoda creste semnificativ marimea fisierului Flash, pe cand, prin folosirea si adaugarea obiectului preluat din Panoul Library, va fi ca si cum e folosit doar intr-un loc, si nu mai mareste fisierul Flash.

- Panoul Library
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5. Panoul Proprietati

In Panoul Proprietati (Properties) este locul in care sunt aratate si pot fi modificate proprietatile elementului curent, selectat. Pentru a afisa proprietatile unui element (text, desen, scena, si altele), pur si simplu se da click pe el, in modul Select. Aceste proprietati ce apar in panoul "Properties" difera de la un tip de obiect la altul, in functie de specificatiile fiecaruia. De ex. daca se da click pe suprafata alba a scenei, apar proprietatile ei: dimensiuni, culoare fundal, FPS. Daca se da click pe un text, apar alte propritati specifice textului: font, marime, stil, culoare, si altele (vedeti imaginea de jos). In cazul desenelor (linii, figuri geometrice) sunt alte Proprietati. Totusi, sunt cateva proprietati comune majoritatii elementelor, acestea ar fi: distanta pe orizontala si verticala ('X' si 'Y') a obiectului fata de coltul stanga-sus a scenei, lungimea si inaltimea obiectului ('W' si 'H')

- Panoul Proprietati Text
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Desenare cu Merge Drawing si Object Drawing

In acest tutorial vor fi prezentate modurile de desen: Merge Drawing (desenare cu lipire) si Object Drawing (desenare tip obiect).

In geneal, inainte de a incepe desenarea si crearea de elemente intr-un document Flash Nou, mai intai trebuie setate proprietatile documentului, a scenei de lucru, si anume: lungimea, latimea si culoarea pentru fundal; in functie de proiectul ce trebuie creat.

1. Merge Drawing

Initial, instrumentele de desen sunt in modul "Merge Drawing". Desenele care sunt facute prin acest mod se mai numesc si "forme" (Shape). Cand acestea se suprapun, de fapt nu vor fi suprapuse ci lipite. Desenul care a fost "suprapus" peste altul, ii va afecta aceluia forma /conturul, parte de dedesubt (ascunsa) a aceluia va fi stearsa. Daca este indepartat, acela va ramane cu forma afectata de a celui care a fost lipit peste el.
Daca inainte de a fi indepartat vreunul din desenele lipite, acestea sunt selectate impreuna, vor ramane lipite, obtinandu-se un singur desen cu forma data de marginile celor doua.
- Ca sa intelegeti mai bine, testati exemplu urmator:

1. Deschideti aplicatia Adobe Flash si dati click pe ActionScript 3.0, de la coloana Create New a paginii de start, pentru a crea un document nou.
2. Alegeti desenarea unui dreptunghi (click pe dreptunghiul din bara cu instrumente pentru desen, sau apasati tasta R).
3. Desenati in scena alba un dreptunghi.
4. Alegeti desenarea unui cerc (click inca o data pe dreptunghiul din bara cu instrumente, cand acesta e deja activat si alegeti figura Oval Tool, sau apasati tasta O).
5. Desenati un cerc undeva pe scena alba, mai departat de dreptunghi.
6. Alegeti "Selection Tool" (sageata neagra din bara de instrumente desen, sau tasta V).
7. Selectati tot cercul si apoi trageti-l putin peste dreptunghi.
8. Dati click pe dreptunghi si departati-l de cerc.
  - Observati ca partea din dreptunghi peste care a fost cercul e stearsa.
9. Mutati dreptunghiul putin peste cerc.
10. Selectati ambele desene, impreuna, dati click pe suprafata alba pentru a le deselecta si apoi incercati sa mutati doar cercul sau dreptunghiul.
  - Observati ca au ramas lipite si se muta cu totul, devenind o singura forma..
11. Acum selectati doar o portiune din aceasta forma si din panoul Proprietati dati click pe culoare ce defineste fundalul (se va deschide o paleta de culori pt. fundal) si alegeti alta culoare.
  - Veti vedea ca s-a modificat doar culoarea din suprafata selectata.
- Vedeti pasii acestui exemplu si in cadrul ce se deschide daca dati click pe imaginea urmatoare.
- Exemplu Merge Drawing
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- Aceasta metoda este utila in a obtine o varietate de noi forme (dupa imaginatia fiecaruia) cu doar cateva figuri geometrice.
2. Object Drawing

Obiectele desenate cu modul "Object Drawing" nu afecteaza alte desene daca sunt suprapuse.
Pentru a activa modul de desen "Object Drawing", dupa ce se alege unealta pt. desen (sa apara activata in bara de instrumente desen), se activeaza butonulObject Drawing din Zona cu Optiuni a barei de instrumente pt. desen (sfera din partea de jos, dupa cum puteti vedea in imaginea urmatoare), sau apasati tasta 'J'.

- Activare mod Object Drawing
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- Daca optiunea "Object Drawing" din Zona de Optiuni e deja activa inseamna ca unealta de desen respectiva e deja in acest mod de lucru, iar prin dezactivarea acelui buton (click iar pe el) se trece in modul "Merge Drawing".
Ca sa intelegeti mai bine cum e si ce face acest mod de desen, testati singuri pasii urmatori:
1. Dupa ce deschideti un document nou Flash, alegeti pentru desen unealta dreptunghi.
2. Daca in Zona de Optiuni a barei cu instrumente desen nu e activat butonul "Object Drawing" (sfera de jos), apasati pe el, sau tasta 'J' pt. a-l activa.
3. Desenati in scena alba doua dreptunghiuri, mai departate unul de celalalt.
4. Alegeti "Selection Tool" si trageti unul din dreptunghiuri peste o portiune din suprafata celuilalt.
5. Acum indepartati unul din dreptunghiurile suprapuse.
  - Se observa ca amandoua au ramas neafectate.
6. Incercati sa selectati cu "Free Transform Tool" (in bara de instrumente sub butonul "Subselection Tool", sau tasta 'Q') doar o portiune din suprafata unuia din dreptunghiuri.
  - Se observa ca va fi selectat tot dreptunghiul.
"Free Transform Tool" permite modificarea si rotirea formei selectate.
- Vedeti pasii acestui exemplu si in cadrul ce se deschide daca dati click pe imaginea urmatoare.
- Exemplu Object Drawing
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- Pentru a edita un desen "Object Drawing" ca si cum ar fi facut cu "Merge Drawing", se da dublu-click pe el cu "Selection Tool (V)".

- Pentru a transforma un desen facut cu modul de lucru "Object Drawing" in desen tip "Merge Drawing", se selecteaza acel desen, apoi din meniul Modify se alegeBrek Apart.
- Se pot combina in aceeasi scena desene facute cu "Object Drawing" si "Merge Drawing", nu se vor afecta intre ele, dar daca se suprapun, cele cu "Merge Drawing" vor fi mereu dedesubt. Pentru a putea fi pozitionate deasupra, trebuie desenate pe un alt Layer (Strat) din Timeline.
- Cand se selecteaza cu "Selection Tool" o portiune din desenele facute cu modul "Merge Drawing", va fi selctata exact acea portiune, pe cand, daca este selectata o zona dintr-un desen facut cu modul "Object Drawing", va fi selectat intreg obiect-ul (desenul).
- Desenele create prin "Merge Drawing", mai ales in cazul animatiilor, pastreaza dimensiunea fisierului cu documentul Flash mai mica si animatia mai rapida decat in cazul folosirii "Object Mode".
- Pentru a transforma un desen facut cu "Merge Drawing" intr-un desen "Object Drawing", se selecteaza acel desen, apoi click meniul Modify -> Combine Objects -> Union.

Dreptunghi, Oval, Poligon - Stea

Aceste 3 instrumente pentru desenat forme geometrice: Dreptunghi (Rectangle Tool (R)), Oval (Oval Tool (O)) si Poligon (PolyStar Tool) se afla pe bara de instrumente desen, toate la butonul "Rectangle" (vedeti imaginea urmatoare). Sunt folosite pentru a desena rapid simple figuri geometrice.

- Instrumente pt. figuri geometrice
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- Pentru a selecta unul din instrumentele "ascunse" in butonul Rectangle Tool, se da click pe buton si apoi inca o data click pe el.
- Sunt usor de folosit, dupa ce e ales unul din aceste instrumente, se da click pe scena si se trage mouse-ul, creandu-se astfel forma geometrica respectiva.
Sunt cate 2 tipuri de unelte pentru dreptunghi si oval: Standard si cele cu Primitive (dupa cum se observa in imaginea de sus).
1. -Instrumentele Standard au cele doua optiuni principale de desen: "Merge Drawing" si "Object Drawing", ce pot fi schimbate din zona de optiuni a barei de instrumente desen. Pentru mai multe detalii vedeti tutorialul Desenare cu Merge si Object Drawing. Initial sunt in modul "Merge Drawing".
- Figurile dessenate cu uneltele Standard au doua zone principale ce pot fi selectate si modificate separat sau impreuna: linia de margine si interiorul formei (numit in general "umplere")
2. - Instrumentele cu Primitive ("Rectangle Primitive Tool" si "Oval Primitive Tool") au un singur mod de desen, ca cel "Object Drawing", Linia de margine si Umplerea sunt unite intr-un singur element, ne putand fi selectate separat.
Se pot desena forme fara linie sau umplere prin alegerea butonului fara culoare -> [image: image18.jpg]


, situat in dreapta-sus la panoul de culori Stroke Color (pt. Linie) si Fill Color (pt. umplere).

- Linie si umplere

[image: image19.jpg]& = L

umplere

N Linie Fara linie Fara umplere





1. Dreptunghi si Oval

Cu "Rectangle Tool" se pot desena dreptunghiuri si patrate, iar cu "Oval Tool" se pot desena forme ovale sau cercuri. Dupa ce este selectata unealta "Rectangle Tool" sau "Oval Tool" se da click pe scena, si cu mouse-ul apasat se trage pana se formeaza forma dorita. La inceput poate fi aproximativa, deoarece proprietatile: dimensiune, culoare, linia bordurii; pot fi modificate si dupa desenare, din panoul Properties.
In imaginea urmatoare gasiti explicatii despre proprietatile ce pot fi setate.

- Proprietati pentru Dreptunghi si Oval
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- Toate aceste proprietati pot fi setate imediat dupa ce a fost ales instrumentul Dreptunghi sau Oval.
Proprietatile de la "Rectangle Option" si "Oval Option" din panoul Properties nu mai pot fi modificate dupa ce figura a fost desenata cu instrumente Standard si reselectata (exceptie fac cele desenate cu Primitive, care permite setarea acestora si dupa desenare).
Pentru a crea mai usor un patrat sau cerc, se tine apasata tasta Shift in timp ce este trasata forma.
- Se pot seta figuri (dreptunghi sau oval) cu dimensiuni specifice daca, dupa ce a fost ales instrumentul respectiv, se tine apasata tasta Alt si se da click, va apre o mica fereastra in care pot fi setate dimensiunile.

2. Poligon - Stea (PolyStar)

Unealta Polystar este folosita pentru desenat poligoane si stele, triunghiuri sau figuri geometrice cu un numar de laturi ce poate fi setat la alegere (maxim 32).
- Acest instrument este denumit "PolyStar" deoarece cu el se pot desena poligoane si stele.
- Ca si celelalte unelte pt. desen, si PolyStar are cele 2 optiuni principale: "Merge drawing" si "Object Drawing".
Numarul de laturi se defineste din panoul Properties, de la butonul Options (in "Tool Setings"), dupa cum puteti vedea in imaginea urmatoare.

- Setari PolyStar
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Dupa ce se alege acest instrument, "PolyStar", in Panoul Properties se da click pe butonul "Options", apoi, in fereastra ce apare se definesc: la Style forma desenului (Polygon sau Star), la Number of Sides (numarul de laturi), iar daca e ales "Star", la Star point Size se defineste forma razelor stelei (un nr. intre 0 si 1), cu cat numarul e mai mic, cu atat razele sunt mai ascutite. Dupa ce se da "OK", se traseaza forma ca si la dreptunghi (sau oval), prin click si tragere cu mouse-ul.
- Vedeti exemplu in imaginea de mai jos.
- Exemplu PolyStar
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- Restul proprietatilor: culoare, umplere, linie, grosime; se stabilesc ca si la celelalte figuri geometrice, din panoul Properties.
Dupa ce a fost desenat poligonul, sau stea, setarile pentru laturi si "Star point Size" nu mai pot fi modificate de la Proprietati.

Linie si Text

Linia si textul sunt printre cele mai comune instrumente folosite in continuturile simple Flash.

1. Linia

Instrumentul pentru linie se gaseste in bara de instrumente pentru desen, butonul cu o linie oblica ("Line Tool (N)"). Acesta deseneaza linii drepte in orice directie este tras mouse-ul.
- Unealta pentru desenat cu "linia" are de asemenea cele doua moduri de desen prezentate in tutorialul precedend: Merge Drawing siObject Drawing.
Sunt o multime de proprietati ce pot fi aplicate liniei, prin panoul Properties, si anume: lungimea, pozitionarea in scena, grosimea liniei (0-200 pixeli), stilul (continua, punctata, liniata, si altele), culoare, stilul capatului liniei si tipul formei de unire cu alta linie (vedeti imaginea de mai jos). Deosebirile date de modificarea acestor doua proprietati din urma sunt vizibile cand linia este mult ingrosata.

- Proprietati pentru linie
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- Modificari mai avansate a formei liniei se pot face din panoul Properties, de la butonul "Edit stroke style", ce se afla in dreapta listei de optiuni "Style" (e aratat si-n imaginnea de sus).
Daca se tine apasat Shift in timp ce se traseaza linia, se pot desena mai usor linii perfect verticale, orizontale sau la 45 de grade.

2. Creare Text

Pentru a crea Text in documentul Flash, se da click pe butonul "Text Tool (T)" (cel cu litera 'T' mare pe el) din bara de instrumente desen (sau direct tasta 'T'), apoi se da click pe scena, va apare cursorul specific scrierii textului, si puteti scrie de la tastatura. Pentru a trece pe un rand nou, se apasa Enter.
Un alt mod de a incepe scrierea textului exte prin tragerea mouse-ului, cu Text Tool activat, formandu-se astfel un chenar in care va fi incadrat textul scris.
Zona /suprafata ce contine textul poate fi oricand mutata si redimensionata daca este selectata cu Selection Tool.

- Creare Text
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- Pentru a modifica un text care a fost scris anterior (de exemplu si mutat), se activeaza /apasa Text Tool si se da click pe textul ce trebuie modificat, apoi se poate sterge, scrie, etc.
- Pentru a imparti un text in literele care-l compun, separand individual fiecare litera (de exemplu pt. diferite efecte animate), se selecteaza cadrul acelui text si se alege meniul Modify -> Break Apart
In Adobe Flash exista doua tipuri de text: TLF (Text Layout Framework) si Clasic. Optiunile din panoul Properties, prin care pot fi setate si modificate proprietatile textului, se schimba in functie de tipul de text ales.

1. TLF are mai multe optiuni si proprietati avansate, si in acelasi timp este usor de manipulat /modificat si creat grafic, oferind mai mult control (vedeti in imaginea de jos prezentate cateva proprietati din Panoul Peroperties).
- TLF este indicat cand se doreste crearea de text animat sau 3D sau cu aspect grafic artistic.
- TLF are 3 tipuri: Read Only (textul apare normal, doar pt. citire), Selectable (utilizatorul va putea selecta si copia textul respectiv) si Editable (utilizatorul va putea modifica acel text, de exemplu poate fi folosit in casute-text).
Deoarece panoul cu proprietati pt. text TLF este prea lung pt. a fi afisat intr-o singura imagine, l-am impartit in 3, dar in Adobe Flash sunt toate acestea intr-un singur panou.

- Proprietati text TLF

Set 1
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Set 2
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Set 3
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Rotirea 3D a textului se poate face cu instrumentul 3D Rotation Tool (W) (situat in bara de instrumente pt. desen).


2. Textul Clasic are proprietatile obisnuite: marime, culoare, aliniere, font, stil, spatiu dintre linii, si altele, ce pot fi setate din panoul Properties (vedeti imaginea de mai jos).
- Textul Clasic e de 3 tipuri: Static Text (text ce e afisat normal), Dynamic Text (text ce poate fi modificat /actualizat cu ActionScript) si Input Text (acesta poate fi modificat de utilizator, de ex., folosit in casute-text).
- Proprietati pentru text clasic
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TLF este tipul de text ce va fi folosit cat mai mult in viitor, in aplicatiile FLASH, de aceea este indicat sa incepeti cu invatarea si folosirea acestuia.
- Spre deosebire de textul clasic, textul TLF creaza fisiere SWF de dimensiuni mai mari.

Ca sa invatati ce fac si cum se folosesc proprietatile textului, din panoul Properties, incercati sa le testati singuri. Intai alegeti "Text Tool", scrieti cateva randuri, apoi selectati cu "Selection Tool" cadrul acelui text, mutati-l (prin tragere cu mouse-ul), modificati-i marimea si testati diferite proprietati, cum ar fi: scimbarea fontului, marimii, culorii, a spatiului dintre litere, adaugati culoare de fundal si diferite efecte din "Color Efect" si "Filters".
Ca un mic exemplu, vedeti si prezentarea urmatoare (asteptati sa se incarce).
- Utilizare cateva proprietati pt. text
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- Observati cum se modifica textul si cadrul in care se afla, dupa aplicarea fiecarei proprietati.
Pensula si Radiera

Lectie in care sunt prezentate modul de utilizare si proprietatile uneltelor Pensula si Radiera.

1. Pensula

Pensula este un instrument de desen mai special, in Adobe Flash are mai multe moduri cu efecte diferite.
- Pensula are de asemenea cele doua optiuni principale de desen: Merge Drawing si Object Drawing.
Unealta pentru desen cu pensula se gaseste in bara de instrumente desen, butonul ce are desenat o pensula ("Brush Tool (B)"). Cand e aleasa pensula, in zona de optiuni a barei cu instrumente desen apare un buton "Brush Mode" in care se gasesc modurile de desen pt. pensula (vedeti imaginea urmatoare).

- Moduri pt. pensula
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- Aceste optiuni de moduri ale pensulei pot restrictiona zona afectata de desenul pensulei asupra formelor, selectarilor si suprafetelor goale din desene.
· Paint Normal - Pensula deseneaza normal, peste orice.

· Paint Fills - Deseneaza doar in interiorul suprafetelor altor desene (facute cu "Merge Drawing") si zonele libere ale scenei, fara a picta peste linia de margine a formelor.

· Paint Behind - Deseneaza doar in zonele goale ale scenei, fara a picta peste formele si liniile existente.

· Paint Selection - Picteaza doar in suprafata selectata, fara a afecta alte zone sau scena.

· Paint Inside - Picteaza doar in interiorul suprafetei de unde s-a inceput in acel moment desenarea cu pensula, ignorand alte suprafete, linii sau zona scenei.

- Ca sa intelegeti mai bine, vedeti imaginea de mai jos si incercati sa testati singuri.
- Mod desen cu pensula
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Tot din zona de optiuni a barei de instrumente desen, sub "Brush Mode", se poate selecta marimea /grosimea pensulei, de la butonul "Brush Size", forma pensulei de la "Brush Shape", iar culoarea pensulei de la zona de culori "Fill Color" (vedeti imaginea de mai jos).
- Culoare, marime si forma pensula
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Spray

La butonul din bara de instrumente unde poate fi selectata pensula se mai afla un instrument pt. desen, si anume Spray ("Spray Brush Tool (B)"). Dupa ce selectati pensula, mai dati o data click pe acel buton, va apare sa puteti alege Pensula sau Spray, dupa cum se vede in imaginea de jos.
Spray-ul imprastie mici particule colorate pe scena si desenele din ea, avand culoarea ce e setata in "Fill Color", si cu o suprafata de pulverizare ce poate fi setata din panoul Properties (vedeti in imaginea urmatoare)

- Setari Spray
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2. Radiera (Eraser)

Radiera (Eraser) are acelasi rol ca si radiera de la scoala, pt. desenele pe hartie; aceasta sterge din desenele create in documentul Flash: linii, forme, figuri, geometrice; indiferent daca sunt facute in "Object Drawing" sau "Merge Drawing".
Radiera se afla in bara de instrumente desen, butonul "Eraser Tool (E)" (cu o radiera desenat pe el), nu are proprietati specifice in panoul Properties, dar are o serie de moduri (asemanatoare cu cele ale pensulei), ce pot fi alese din zona cu optiuni a barei de desen (vedeti imaginea urmatoare).

- Radiera ( Eraser )
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- In zona de optiuni sunt 3 butoane pt. radiera:
· Eraser Mode - Aici sunt modurile de lucru ale radierei prin care se poate restrictiona zona de stergere.

· Faucet - Cu aceasta optiune activata mouse-ul se transforma intr-un robinet si se poate sterge direct o umplere sau linie, daca se da click exact pe ea.

· Eraser Shape - De aici se poate alege marimea si forma radierei (rotunda sau patrata).

- Initial Radiera este in modul "Erase Normal", acesta sterge orice linie, umplere sau forma; pe locul unde este dat click sau tras mouse-ul cu radiera. Mai sunt alte 4 moduri, care au urmatoarele efecte:
· Erase Fills - Sterge doar din portiunile ce sunt umpleri in obiectul sau forma desenata, lasand intacte liniile.

· Erase Lineas - Sterge doar din linii, lasand intacta umplerea.

· Erase Selected Fills - Sterge doar din ce e umplere in portiune selectata, lasand intacte liniile sau umplerea din afara selectiei.

· Erase Inside - Sterge doar din umplerea care se afla in cadrul unde a inceput stergerea. De exemplu, daca stergerea incepe in afara unui dreptunghi, nu va avecta interiorul sau liniile acestuia, daca stergere incepe in interiorul oricarei forme, nu va afecta nimic dincolo de liniile ce o delimiteaza (nici alte linii din interior, doar ce e umplere).

- Ca sa intelegeti mai bine cum functioneaza radiera si modurile ei, vedeti imaginea urmatoare.
- Utilizare Radiera
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Cand se trage mouse-ul cu Radiera pt. stergere in alte moduri decat cel Normal, desi apare ca se sterge tot pe acea urma, dupa eliberarea click-ului va fi sters doar ce e specific modului ales.
- Radiera functioneaza doar pt. desene ce pot fi editate; nu are efect asupra grupurilor, textului sau simboluri. Acelea pot fi sterse prin Selectare si apoi tasta Del (Delete).

Despre Selectari

Selectarea este una din cele mai utilizate si importante operatiuni pentru manipularea, modificarea si organizarea continutului intr-un document Flash. Prin selectare se pot alege suprafete din desene, linii, obiecte intregi, care apoi pot fi sterse, copiate, mutate, grupate, modificate proprietati, etc.
Desenele in scena, fie linii, figuri geometrice sau forme neregulate pot fi facute in doua tipuri diferite: "Merge Drawing" si "Object Drawing" (vedeti tutorialul: Desenare cu Merge si Object Drawing); acestea influenteaza modul in care poate fi selectat desenul respectiv. Selectarile facute desenelor cu Object Drawing va selecta intreg obiectul /desenul, pe cand, in cazul desenelor facute cu Merge Drawing pot fi selectate doar anumite portiuni din desen, sau tot desenul, dupa preferinta.
In acest tutorial se va face referire in general la forme de desen facute cu "Merge Drawing".
In Adobe Flash exista 4 tipuri de instrumente pentru selectare: Selection Tool (V), Subselection Tool (A), Free Transform Tool (Q) siLasoo Tool (L); toate aflate in bara de instrumente pentru desen (vedeti in imaginea urmatoare). Litera din paranteze reprezinta tasta de la tastatura prin care poate fi activat mai rapid respectivul instrument.
- Instrumente Selectare
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1. Selection Tool

Selection Tool este unealta cea mai des folosita pentru selectari.
Un desen, chiar si simplu, poate avea mai multe elemente ce pot fi selectate. De exemplu, un simplu dreptunghi desenat e compus din 4 segmente de linie ce imprejmuesc conturul formei, si "umplerea" (acest termen face referire la suprafata din interior, a carei culoare se seteaza din "Fill Color"). Fiecare din aceste 5 parti poate fi selectata separat cu Selection Tool, in grup, sau toate la un loc.
Orice linie care intersecteaza alta linie, sau forma, le imparte in elemente distincte ce pot si selectate separat.

Tehnici de selectare

Important: aceste metode sunt aplicabile in special desenelor cu Merge Drawing. (vedeti si imaginea de la "Exemple Selectari"
- Selectarea simpla se face, dupa ce a fost ales acest instrument (Selection Tool), fie prin click pe linia, umplerea, sau obiectul (in cazul "Object Drawing") ce trebuie selectat, fie prin trasarea cu acesta (prin tragere cu mouseul) a unui dreptunghi (sau patrat) de selectare care sa cuprinda suprafata ce se doreste selectata.
- Pentru a selecta mai multe elemente, se tine apasata tasta Shift si se selecteaza (prin click sau trasare) pe rand elementele dorite.
- Pentru a selecta mai multe linii conectate, se da dublu-click pe una din ele.
- Daca se da dublu click pe o "umplere", va fi selectata toata acea umplere impreuna cu liniile care o ating.
- Exemple Selectari
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Pentru a sterge un obiect, o forma sau linie selecta se apasa tasta Del (Delete).
Pentru a copia ceva ce e selectat, se apasa Ctrl+C si apoi Ctrl+V
Cu Selection tool se poate modifica si forma unei suprafete sau linii, pentru aceasta trebuie observat aspectul mouse-ului pe care-l ia in apropierea liniei sau colturilor. Important: Desenul respectiv trebuie sa nu fie selectat.
- Cand langa sageata mouse-ului apare un arc de cerc (in apropierea liniilor /marginilor), indica posibilitatea curbarii formei sau liniei respective. In acel loc se tine apasat click si se muta mouse-ul, se va observa un contur ce indica curbarea, dupa eliberarea click-ului, umplerea sau /si linia vor capata forma pe care o indica curbarea in acel moment.
- Cand langa sageata apare un unghi drept (in apropierea colturilor), indica posibilitatea extinderii /mutarii coltului respectiv, prin tragerea lui cu sageata mouse-ului, ceea ce va modifica si forma desenului respectiv.
Se poate intelege mai bine din imaginea urmatoare.
- Modificare forma cu Selection Tool
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2. Subselection Tool si Free Transform Tool

Subselection Tool si Free Transform Tool sunt similare deoarece ambele fac selectari ce pot fi folosite pentru modificarea formei suprafetei /desenului selectat.
Diferenta principala dintre aceste doua unelte de selectare este faptul ca "Subselection Tool" permite crearea unei modificari a formei prin tragerea punctului de legatura, pe cand, cu "Free Transform Tool" se fac modificari prin tragerea unei laturi (prin punctul din mijlocul ei) sau prin tragerea colturilor. In plus, cu "Free Transform Tool" se poate efectua si rotirea formei selectate.
Cu Subselection Tool se selecteaza prin click pe marginea formei sau prin trasare cu mouseul a unui chenar de selectie asupra unei zone din desenul ce trebuie selectat. Acest instrument va selecta intodeauna intreaga forma a desenului (umplere si linii), impreuna cu ce este conectat la ea, facand niste puncte de legatura speciale pe colturi si curbe, pentru editarea conturului acelei formei (dupa cum se vede in imaginea de mai jos).
Selectarea cu Free Transform Tool se face la fel ca si cu "Selection Tool": prin click pe linia sau umplerea ce trebuie selectata, dublu-click sau incadrarea intr-un chenar de selectie a suprafetei ce trebuie selectata. Pe liniile de margine a zonei selectate vor apare niste puncte prin care se poate modifica suprafata acelei forme (vedeti imaginea urmatoare)

- Selectare cu Subselection si Free Transform
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- "Subselection Tool" nu are optiuni aditionale, dar "Free Transform Tool" are 4 optiuni ce pot fi alese (dupa ce a fost facuta selectarea) din Zona cu Optiuni a barei de instrumente desen: "Rotate and Skew", "Scale", "Distort" si "Envelope".
- In prezentarea urmatoare puteti vedea cateva exemple de lucru cu "Subselection Tool" si "Free Transform Tool":
- Exemple cu Subselection si Free Transform
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Pentru a transforma colturile in curbe rotunjite, se selecteaza forma cu Subselection, se tine apasata tasta Alt, apoi se tine apasat si click pe punctul din coltul respectiv, cu aceste apasari se muta mouse-ul, formandu-se rotunjirea dupa amplitudinea miscarii mouse-ului (Exemplu aratat si in prezentarea de mai sus).

3. Lasso Tool

Lasso Tool e de obicei folosit cand se doreste selectarea unei forme care e prea aproape de o alta forma ce nu trebuie selectata sau atunci cand se doreste selectarea unei forme mai complexe, neordonate.
Acest instrument permite desenarea unui contur de selectare in jurul formei, selectand orice e cuprins in conturul desenat.
Lasoo Tool are doua moduri de selectare, cel normal, denumit "Magic Wand", care este cel initial, si un mod denumit "Polygon Mode". Aceste moduri pot fi alese din zona de optiuni a barei de instrumente desen, dupa ce a fost selectat Lasso Tool (vedeti in imaginea de jos).
- "Magic Wand" permite desenarea libera a conturului pentru selectare, dupa cum este tras mouse-ul.
- "Polygon Mode" defineste zona de selectie printr-o serie de segmente liniare. Selectarea in "Polygon Mode" se face in felul urmator: dupa ce se alege acest mod din zona de optiuni, se da click pe locul unde se doreste sa inceapa zona de selectie, se muta mouse-ul, se da iar click, si tot asa se muta si se da click pana se formeaza conturul de selectie dorit, apoi, pentru completarea selectarii se da dublu-click.

Flash uneste automat punctul de unde incepe selectarea Lasso Tool cu punctul final.

- Selectare cu Lasso Tool
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- Cu tasta Shift apasata in timp ce se fac selectarile, pot fi selectate mai multe forme, separate, in acelasi timp, cu orice tip de selectie.
- Pentru a deselecta un obiect, sau mai multe, selectate; se da click pe un loc gol de pe scena de lucru.

Creion si Stilou

Creionul (Pencil Tool) si Stiloul (Pen Tool) sunt doua unelte de desen ce ofera libertate deplina in manipularea liniei de desen. Stiloul este totusi mai tehnic si complex decat creionul.
- Ambele unelte pot fi folosite in cele 2 moduri principale: Merge Drawing si Object Drawing.

1. Creion

Unealta pentru creion se gaseste in bara de instrumente pentru desen, butonul ce are desenat un creion ("Pencil Tool (Y)"). Cu acesta se deseneaza liber, ca si cu un creion pe hartie, desigur, cu optiuni specifice: "Straighten" (indreptat), "Smooth" (netezit) si "Ink" (desenare normala). Aceste optiuni pot fi alese din zona de optiuni a barei cu unelte de desen (vedeti imaginea urmatoare).

- Optiuni creion
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- In functie de optiunea aleasa, Flash face anumite corectari desenului.
· Modul Straighten - Transforma linia desenata cu creionul intr-o serie de segmente liniare-drepte, si curbele in colturi ascutite.

· Modul Smooth - Corecteaza linia desenata de creion, facand curbele mai rotunjite.

· Modul Ink - Lasa linia desenata cat mai aproape de forma trasata de mouse, rotunjind putin curbele.

Pentru a modifica nivelul de corectare a curbelor facut de Flash asupra unui desen cu creionul, realizat in modul Straighten, selectati desenul si dati click pe meniul Modify -> Shape -> Advanced Straighten, adaugati o valoare intre 0-100 si dati OK.
Iar pentru modul Smooth, selectati desenul creat cu acest mod si dati click pe meniul Modify -> Shape -> Advanced Smooth si modificati valorile din fereastra care apare.
- Un alt mod de a optimiza formele in modul Smooth, reducand numarul de curbe ce definesc forma, se realizeaza din meniul Modify -> Shape -> Optimize, adaugati o valoare intre 0-100 si dati OK.

- Din panoul Properties se pot seta creionului diferite proprietati (la fel ca si pentru linie): lungimea, pozitionarea in scena, grosimea liniei de desen (0-200 pixeli), stilul (continua, punctata, liniata, si altele), culoare, stilul capatului liniei si tipul formei de unire cu alta linie.
Incercati sa descoperiti singuri rezultatul dat de modificarea acestor proprietati. Alegeti instrumentul Creion (rapid, prin apasarea tastei 'Y'), desenati ceva apoi cu Selection Tool selectati ce ati desenat si din panoul Properties testati efectul acelor proprietati: modificati numerele de la "Position and Size", culoarea liniei de la "Fill and Stroke", grosimea de la "Stroke" si tipul liniei de la "Style".
- Vedeti ca exemplu prezentarea de mai jos.
- Utilizare creion
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2. Stilou (Pen Tool)

Pen Tool (unealta Stilou) e un instrument de desen mai complex, folosit pentru obtinerea de curbe perfecte, desene si linii ce necesita mai mult control si precizie, facand o desenare vectoriala. Se gaseste in bara de instrumente desen, butonul cu o penita pe el (Pen Tool (P))
- Petru a desena linii cu Stiloul, sau segmente de linii unite, care sa alcatuiasca o anumita forma, selectati unealta Silou (rapid cu tasta 'P') si dati click pe suprafata scenei, fiecare click va crea puncte de legatura; intre fiecare punct trasandu-se cate o linie dreapta. Cu cat se da mai multe click-uri, cu atat se creaza mai multe segmente de linie, iar cand se doreste finalizarea desenarii, la ultimul punct se da dublu-click, sau se apasa tasta Esc (Escape).
- Daca dupa crearea unui punct se tine apasat click si se trage mouse-ul, intre penultimul punct si acela se va forma un arc de cerc cu raza si forma curburii in functie de tragerea mouse-ului.
- Daca se da click intre 2 segmente de legatura (pe o linie sau curba), in acel loc se va forma un alt punct de legatura.

In timpul desenarii, cand cursorul mouse-ului ajunge peste punctul care inchide o bucla sau o serie de segmente de linii, apare in dreptul cursorului-stilou un mic cerculet.
Pentru a vedea cu un pas (punct) inainte desenul obtinut in timp ce se lucreaza cu Stiloul, de exemplu linia sau curba obtinuta dupa cum se misca mouse-ul, alegeti meniul Edit -> Preferences, in fereastra care apare alegeti Drawing si bifati casuta din dreptul textului Show pen preview. - Pentru a ajusta o curba dupa ce deja a fost facuta, click Subselection Tool, apoi click pe un punct adiacent curbei respective, vor apare punctele de control ale curbei prin care poate fi modificata forma ei, prin mutarea unuia cu Subselection Tool.
- Forma si linii din desenul creat cu Pen Tool pot fi usor modificate prin punctele de legatura, cu Subselection Tool.

- Exemple cu Pen Tool

[image: image44.jpg]



- Ca si la creion, proprietatile liniei /curbelor trasate cu Pen Tool: culoare, grosime, stil; pot fi modificate din panoul Properties.

- La butonul "Pen Tool" de pe bara de instrumente mai sunt inca 3 unelte pentru lucru cu Stiloul:
· Add Anchor Point Tool (=) - Adauga puncte de legatura in locatiile dorite, inclusiv pe desene ce nu au fost facute cu Pen Tool.

· Delete Anchor Point Tool (-) - Sterge punctele de legatura, inclusiv de pe desene ce nu au fost facute cu Pen Tool, cand sunt selectate cu Subselection.

· Convert Anchor Point Tool (C) - Converteste si foloseste un punct de legatura dintre linii ca punct de creare o curba, si invers, transforma punctul de pe o curba in punct de legatura a doua linii (punct de colt).

Pentru linii si forme geometrice simple e indicat folosirea celorlalte instrumente specifice, Linie, Dreptunghi, PolyStar.

Calimara si Pipeta (Paint bucket, Ink bottle)

Aceste doua unelte, Calimara (Paint Bucket Tool, Ink Bottle Tool) si Pipeta (Eyedropper Tool) din bara cu instrumente desen se folosesc pentru setarea si schimbarea culorilor desenelor facute in documentul Flash.
- La butonul cu "Paint Bucket Tool" se mai afla un instrument, Ink Bottle Tool (dupa cum se observa in imaginea de mai jos). Acesta poate fi "descoperit" dupa cum se procedeaza pt. instrumentele sau optiunile "ascunse" intr-un buton, si anume tinand click cu mouse-ul pe acel buton.

- Locatia uneltelor Paint Bucket, Ink Bottle si Eyedropper
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1. Calimara - Paint Bucket si Ink Bottle

Paint Bucket si Ink Bottle se gasesc in acelasi buton pe bara cu instrumente pentru desen. Cu aceste unelte se pot seta /modifica culorile umplerilor si respectiv liniilor.
- "Paint Bucket" se foloseste pt. culoarea umplerii, utilizand culoarea care este setata in paleta de culori Fill Color din bara cu instrumente desen.
- "Ink Bottle" este se foloseste pt. culoarea liniilor utilizand culoarea care este setata in paleta de culori Stroke Color din bara cu instrumente desen (poate modifica si stilul si grosimea liniilor).

Modul de utilizare e simplu:

· 1. Se selecteaza umplerea (umplerile) sau linia (liniile) pentru care se doreste modificarea culorii.

· 2. In cazul umplerilor se alege "Paint Bucket" iar in cazul liniilor "Ink Bottle"; mouse-ul va capata aspectul unei calimare.

· 3a. Daca pentru umplere se doreste modificarea culorii ei cu cea care e deja setata in "Fill Color" (sau pt. linii cu cea din "Stroke Color"), se da click pe desenul selectat.

· 3b. Daca se doreste alegerea altor culori; cu desenul selectat si unealta "Paint Bucket" (sau "Ink Buttle") activata, se da click pe paleta de culori pentru umplere (sau linie) si se alege culoarea dorita; cand aceasta e aleasa se modifica automat si culoarea din desenele selectate, fara a mai fi necesar click pe ele.

- Cu "Paint Bucket" se pot adauga culori si formelor /obiectelor care nu au o culoare la umplere, prin selectarea acestora si apoi click cu "Paint Bucket" pe ele (cu o culoare setata in "Fill Color").
- Similar, cu "Ink Bottle" se pot adauga linii de contur formelor /obiectelor care nu au linie pe margine.
Pentru a da aceeasi culoare mai multor umpleri (sau linii) in acelasi timp, cu tasta Shift apasata se selecteaza aceste desene si apoi se aplica "Paint Bucket" (sau "Ink Bottle") unuia din ele .
- Culoarea umplerii sau liniei poate fi schimbata si fara utilizarea uneltei Calimara, prin selectarea lor si apoi alegerea direct a culorii din panoul de culori specific fiecaruias.

In continuare puteti vedea um mic exemplu de utilizare a acestor doua unelte.
- Utilizare calimara
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- Daca o forma fara culoare la umplere are un mic spatiu / deschizatura in linia conturului, unealta "Paint Bucket" nu va functiona in modul normal. Totusi, acest instrument are o oiptiune cu diferite moduri cu ajutorul carora pot fi ignorate anumite goluri in linia exterioara. Aceste moduri pot fi alese de la optiunea Gap Sizece apare in zona de optiuni a barei cu unelte de desen, cand "Paint Bucket" e activat (dupa cum se vede in imaginea urmatoare).
- Optiunea Gap Size
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- "Don't Close Gaps" este modul initial si necesita linia exterioara complet inchisa, fara vreo deschizatura. Celelate moduri permit goluri mici (Close Small Gaps), medii (Close Medium Gaps) si putin mai mari (Close Large Gaps).
- Totusi, chiar si in modul "Close Large Gaps", pot fi ignorate goluri de 1-2 pixeli.
Cu Ink Bottle se pot seta /modifica si proprietatile liniei: stil si grosime, prin modificarea acestora din panoul Properties dupa ce este activat acest instrument. Cand se va aplica liniilor culoarea aleasa, vor fi aplicate si celelalte proprietati.

2. Pipeta - Eyedropper

Pipeta (Eyedropoper) permite selectarea si preluarea culorii unei umpleri sau linii, precum si stilul si grosimea liniei, dupa care pot fi transferate altei forme.
Acest instrument detecteaza daca este selectata o umplere sau linie (langa pipeta mouse-ului apare o pensula cand e deasupra unei umpleri si un creion cand e deasupra unei linii), iar dupa ce se apasa click, in functie de elementul peste care s-a dat click, este activat "Paint Bucket" in cazul umplerii sau "Ink Bottle" in cazul liniei, cu atributele copiate din acel element (vedeti imaginea de mai jos). Apoi se pot transfera usor, prin click, altei forme.

- Utilizare Pipeta - Eyedropper
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- Se recunoaste utilitatea Pipetei mai ales cand se doreste preluarea directa si transferarea unei anume culori (dintr-o imagine sau desen mai vechi) mai greu de setata din panoul de culori.
Deco Tool

Deco Tool permite adaugarea de efecte decorative si desene complexe scenei sau obiectelor si formelor. Intr-un fel este similar cu "Poaint Bucket" si "Spray Brush".
In proprietatile lui, acest instrument contine o serie de efecte si elemente decorative predefinite, prin combinarea carora se pot obtine desene artistice complexe.
Dupa ce este ales "Deco Tool", din panoul Properties pot fi alese, de la optiunea Drawing Effect, o serie de efecte, precum: Vine Fill, Grid Fill, 3D Brush, Flower Brush, Symmetry Brush, Tree Brush, si altele (vedeti in imaginea de mai jos); fiecare cu proprietati si optiuni proprii (la Advanced Options), prin care se pot obtine combinatii de efecte destul de complexe.

- Panou proprietati Deco Tool
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Ca sa intelegeti mai bine ce se poate face cu acest instrument, incercati urmatorul exemplu:
1. Deschideti un document Flash nou, cu scena alba, si alegeti instrumentul pentru desen dreptunghi (Rectangle Tool).
2. Desenati pe scena un dreptunghi (cu o culoare de fundal cat mai deschisa).
3. Alegeti instrumentul Deco Tool (rapid, cu tasta 'U').
4. Dati click in interiorul dreptunghiului desenat. Umplerea acestuia va incepe sa fie acoperita cu un desen decorativ care e setat initial inDrawing Effect, daca nu a fost schimbat, este Vine Fill.
  - Desenul "Vine Fill" va acoperi toata suprafata dreptunghiului, dar poate fi oricand oprit daca se mai apasa o data click pe dreptunghi.
5. Apasati click si pe scena alba (in afara dreptunghiului), scena va incepe sa fie decorata cu efectul din Deco Tool (tot "Vine Fill"). Apoi, pentru a opri extinderea desenului decorativ, dati inca o data click pe scena.

- Similar puteti testa si cu "Grid Fill", ce e un alt efect care poate fi ales din optiunile de la "Drawing Effect". "Grid Fill" creaza un efect repetitiv ca si "Vine Fill", dar cu patratele ce pot fi colorate, si mai uniform decat "Vine Fill".
- In prezentarea urmatoare puteti vedea acest exemplu, precum si altele cu Deco Tool.
- Exemple cu Deco Tool
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 Cel mai bun mod de a invata despre Deco Tool este sa creati un document nou si sa experimentati efectele din "Drawing Effect", modificand si proprietatile lor (care apar pt. fiecare la "Advanced Options"). 

Snap to Objects si Snap Align

Aceste optiuni: Snap to Objects si Snap Align sunt 2 proprietati ajutatoare in trasarea, lipirea si alinierea desenelor si obiectelor in scena de lucru Flash.

1. Snap to Objects

Optiunea Snap to Objects poate fi activata din meniul View -> Snapping -> Snap to Objects, sau din Zona cu Optiuni a barei cu instrumente desen, de la butonul ce are desenat un magnet (vedeti in imaginea urmatoare).

- Activare Snap to Objects
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- Cand "Snap to Objects" este activat, acesta ajuta la indicarea momentului cand o linie trasata cu "Line Tool" este perfect orizontala sau verticala, sau cand se deseneaza un patrat ori cerc perfect rotund, precum si momentul cand in timpul desenarii unei linii sau forme geometrice, aceasta ajunge la punctul de unire (lipire) cu alta linie sau forma. Indicarea se face prin aparitia in acel moment a unui cerculet negru langa cursorul mouse-ului (dupa cum este aratat in imaginea de mai jos).
- Utilitate Snap to Objects
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- Aceasta optiune activata chiar forteaza putin lipirea liniei sau figurii care e desenata, cand trasarea acesteia ajunge in apropierea altei linii sau forme; astfel, ajuta la conectarea acestora (nu doar se ating, ci devin unite). Dar cand se doreste desenarea a doua linii sau obiecte apropiate, este indicat sa se dezactiveze "Snap to Objects".
Toleranta "Snap" de unire poate fi modificata din meniul Edit -> Preferences, in fereastra care apare se alege categooria Drawing, apoi, in dreapta, la Connect lines se poate seta una din optiunile: "Must be close", "Normal" sau "Can be distant".
- Snap to Objects nu functioneaza cu instrumentele: Creion, Pensula si Radiera.

2. Snap Align

Optiunea Snap Align ajuta la alinierea desenelor, formelor si obiectelor in scena, unele fata de altele.
Pentru a activa aceasta optiune, se da click pe meniul View -> Snapping -> Snap Align.
Cand "Snap Align" e activat iar marginea un obiect din scena, in timp ce e mutat cu mouse-ul, ajunge aliniata vertical sau orizontal cu marginea altui obiect, linie sau forma, apare o linie punctata ce indica si arata alinierea acelor elemente (dupa cum se observa in imaginea urmatoare).

- Indicare Snap Align
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Sensibilitatea de aliniere a proprietatii "Snap Align" poate fi setata /modificata din meniul View -> Snapping -> Edit Snapping. In fereastra ce apare (aratata in imaginea de mai jos) poate fi setata distanta dintre obiecte (sau fata de marginea scenei) de la care va fi aratata linia punctata ce indica alinierea (optiune utila atunci cand se doreste alinierea desenelor intre ele la o anumita distanta fixa).

- Setari Snap Align
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- Daca sunt bifate optiunile "Horizontal center alignment" si "Vertical center alignment", va fi indicat cu linia punctata si momentul cand centrul obiectului mutat ajunge aliniat cu centrul altui desen din scena.
Culori in Adobe Flash - Definire si Salvare

Fiecare document Flash are o paleta cu 216 culori standard, ce acopera aproximativ intreg spectrul de culori mai des folosite, plus optiuni pentru transparentizarea culorii si cateva combinatii predefinite (vedeti in imaginea de mai jos).
Paleta de culori din Flash se foloseste pentru doua grupe principale de elemente, una reprezinta liniile si marginile formelor si deschide /foloseste paleta de culori de la butonul Stroke Color; cealalta reprezinta interiorul formelor (umplerea), pensula si culoarea textului, acestea folosesc paleta de culori deschisa de la butonul Fill Color.

- Panou cu paleta de Culori
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Flash permite definirea si folosirea de alte culori noi, create in documentul curent, prin scrierea directa a codului culorii, in format Hexadecimal ( trei perechi de numere de la 0 la 9 si litere de la A la F) adaugare transparenta (la Alpha) sau editarea valorii RGB (Red -rosu, Green -verde, Blue -albastru), HSL (Hue -nuanta, Saturation -saturatie, Luminosity -luminozitate) in alta paleta pentru editare culori (vedeti indicatii in imaginea urmatoare).
- Definire alte culori
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- Pentru transparenta se da click pe numarul de la Alpha si se adauga o valoare intre 0 si 100 (cu cat mai mica cu atat mai transpaenta).
- Pentru folosirea unei culori care e cunoscuta dupa codul ei Hexadecimal, se da click pe codul care incepe cu "#" (in stanga-sus) si se scrie valoarea Hexadecimala.
- Pentru folosirea de culori obtinute prin editarea valorilor RGB si HSL se executa urmatorii pasi:
1. Se deschide Paleta de culori de la "Fill Color" sau "Stroke Color".

2. Se da click pe Cercul de culori (butonul ca un cerc colorat, din coltul dreapta-sus) si se deschide o fereastra Color, pt. editare culori (dupa cum se vede in imaginea de sus).

3. In fereastra "Color" se da initial click pe un patratel de la "Custom Colors" (unde va fi retinuta culoarea) apoi se alege o culoare de baza, de la "Basic Colors" sau prin click cu mouseul pe spectrul de culori din dreapta.

4. In casutele "Red", "Green", "Blue", "Hue", "Sat" si "Lum" se editeaza culoarea aleasa, modificand valorile casutelor RGB cu numere intre 0 si 255 iar pt. HSL intre 0-240, pana se obtine culoarea dorita.

5. Dupa ce s-a creat culoarea, aratata la "ColorSolid", se apasa butonul Add to Custom Colors. Acea culoare va fi adaugata in patratelul ales de la "Custom Colors". Pot fi adaugate pana la 16 culori.

6. Se alege o culoare adaugata la "Custom Colors" si se apasa OK. Acum, in imaginea butonului "Fill Color" sau "Stroke Color", care a deschis initial Paleta de Culori, va apare si va fi folosita acea culoare.

Culorile adaugate la "Custom Colors" pot fi redefinite si folosite atata timp cat aplicatia Adobe Flash ramane deschisa. La inchiderea ei vor fi sterse acele culori.

Salvare culori in paleta de culori

De asemene, pot fi create culori noi care sa fie salvate si adaugate alaturi de cele 216, astfel, acea culoare ramane permanent in paleta de culori si poate fi folosita oricand.
Pentru a adauga o culoare noua in paleta de culori, se executa urmatorii pasi:

1. Se da click pe meniul Window -> Color, se va deschide un panou Color cu optiuni pentru crearea culorilor, utilizand: HSL, RGB, Alpha si cod Hexadecimal (vedeti imaginea de mai jos).

- Panou Color - Adauga culori in paleta
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2. Din spectrul de culori sau de la unul din butoanele "Stroke Color" si "Fill Color" ale panoului Color se alege o culoare apropiata de cea care se doreste.

3. De la valorile optiunilor H, S, B (Hue, Saturation, Brightness) respectiv R, G, B (Red, Green, Blue) si A ((Alpha)) se ajusteaza culoarea pana se obtine nuanta dorita, sau se poate specifica /ajusta culoarea si cu forma Hexadecimala (in casuta cu diez '#' langa ea).

4. Se da click pe meniul Options al panoului (situat in coltul dreapta-sus) si de acolo pe Add Swatch. Culoarea setata e adaugata direct in Paleta de Culori, sub cele 216, langa optiunile pentru Gradient si poate fi folosita in document.
- Dar daca se inchide aplicatia Adobe Flash, culoarea nu ramane salvata in paleta, pentru aceasta mai trebuie facuti urmatorii doi pasi.
Daca e aleasa optiunea Bitmap fill din lista de optiuni (unde e "Solid color") se poate adauga /importa o poza /imagine care sa fie folosita ca si culoare.

5. Pentru ca noua culoare sa ramana salvata in Paleta de Culori si dupa inchiderea programului Adobe Flash, se da click pe meniul Window -> Swatches, apare un panou Swatches cu paleta de culori (vedeti imaginea urmatoare).

- Panou Swatches - Salveaza, sterge culori
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6. Se da click pe meniul Options al panoului "Swatches" (situat in coltul dreapta-sus) si de acolo pe Save as Default. Acum paleta de culori curenta (asa cum arata in panoul Swatches) este salvata si culoarea /culorile noi adaugate vor fi in paleta si la urmatoarea deschidere a programului Adobe Flash.


Dupa cum se vede in imaginea de mai sus, "Swatches" mai are si alte optiuni in meniu. Iata ce fac cateva din ele:
· Delete Swatch - Sterge culoarea aleasa din panou.

· Add Colors - Adauga o gama de culori recunoscuta in alt fisier, in general de tip imagine sau ".clr".

· Replace Colors - Inlocuieste culorile din panou cu altele, preluate dintr-o gama de culori recunoscuta in alt fisier, in general de tip imagine sau ".clr".

· Load Default Colors - Daca au fost facute modificari in paleta, si nu au fost salvate, reface culorile asa cum erau la ultima salvare (Default).

· Save Colors - Salveaza paleta de culori curenta intr-un fisier special (cu extensia ".clr"), care apoi poate fi oricand incarcat cu "Add Colors" sau "Replace Colors".

· Save as Default - Salveaza paleta de culori curenta ca Default, astfel ramane si dupa inchiderea aplicatiei Adobe Flash.

· Clear Colors - Sterge toate culorile, ramane doar alb si negru.

· Web 216 - Reface paleta cu cele 216 culori initiale.

Utilizare Gradient

Gradient este un efect creat cu doua sau mai multe culori, trecandu-se treptat de la una la cealalta in diferite combinatii.
In acest tutorial e prezentat modul de folosire si editare a efectelor de culori Gradient, precum si utilizarea instrumentului "Gradient Transform Tool".

1. Utilizare si editare Gradient

In Adobe Flash se folosesc pentu utilizarea efectului "Gradient" optiunile aflate in paleta de culori (situate in partea de jos, sub cele 216 culori, vedeti imaginea de mai jos).
Sunt valabile doua tipuri de gradient:

· liniar - Format din linii paralele de culori.

· radial - Culorile radiaza dintr-un punct focalizat.

- Optiuni Gradient
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- Pentru a folosi efectul de culori "Gradient", se da click pe "Fill Color" sau "Stroke Color" (din bara cu instrumente pt. desen), iar din paleta de culori se alege una din optiunile "Gradient". Modelul ales va apare in imaginea butonului prin care a fost deschisa paleta de culori. Apoi poate fi folosit ca orice alta culoare, pentru desene cu pensula, linii si umpleri (ca in exemplu din imaginea de sus).

Dupa ce a fost ales gradient-ul dorit, pentru a putea fi personalizat cu alte culori si combinatii, acesta trebuie editat.
Ambele modele (liniar si radial) pot fi editate, se pot crea combinatii noi, schimbandu-se culorile, nuanta, numarul si pozitia lor in "Gradient".

- Editare Gradient
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- Editarea culorilor Gradient se face din Panoul Color, care poate fi deschis din meniul Window -> Color (prezentat in imaginea de deasupra).
- In acest panou se poate alege din lista de optiuni tipul "Linear gradient" sau "Radial Gradient".
- In zona in care se defineste gradient-ul (in partea de jos a panoului) se pot adauga si alte culori, prin click pe acea zona (pot fi adaugate pana la 16 culori).
- Fiecare culoare din zona cu straturile ce formeaza gradient-ul poate fi modificata cu proprietatile HSB, RGB, A (Alpha) si mutata in Gradient, pe lungimea acelei zone.
- In timp ce culorile sunt editate, modificarile apar atat in butonul "Fill Color" sau "Stroke Color", in care a fost selectat efectul Gradient ce este editat, cat si in vreun desen care e selectat in Scena (puteti vedea in prezentarea de mai jos "Exemplu editare Gradient").
- Pentru a adauga in paleta de culori efectul Gradient creat, se da click pe Add Swatches, situat in meniul cu optiuni din coltul dreapta-sus al Panoului Color.
Culorile care sunt adaugate in zona de definire a efectului Gradient (prin click) pot fi sterse /anulate prin tragerea lor cu mouse-ul in afara panoului (sau Ctrl+click pe acea culoare).


Iata o prezentare Flash cu exemplu de utilizare si editare Gradient.
- Utilizare si Editare Gradient
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2. Utilizare instrument Gradient Transform

Gradient Transform este un instrument de selectare ce se gaseste in acelasi buton cu "Free Transform Tool" din Bara cu unelte desen (vedeti imaginea de jos).
"Gradient Transform Tool" se foloseste pentru transformarea /modificarea efectului de colorare Gradient dintr-un desen, ajustand marimea, rotatia, lungimea sau centrul culorii Gradient.
- Dupa ce se alege acest instrument, prin tinere putin click apasat pe butonul "Free Transform Tool" si apoi click pe Gradient Transform Tool (sau rapid, tasta 'F'), se da click pe obiectul care foloseste o culoare cu efect Gradient.
- La forma /culoarea astfel selectata va apare cateva mici butoane specifice, acestea se folosesc pt. transformarea acelui Gradient. Prin tragerea lor cu mouse-ul se modifica marimea gradientului, rotatia si pozitia lui in forma ce o coloreaza (vedeti explicatii si in imaginea urmatoare).

- Gradient Transform
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- Modelul "Radial" are doua butoane in plus: unul sub forma unui cerculet cu o sageata in el (folosit pentru modificarea ratei de trecere de la o culoare la alta), celalalt, situat in centru, are forma unui triunghi (folosit pentru indicare /mutare focalizare).
Ca sa invatati cum se foloseste unealta "Gradient Transform", vedeti si incercati singuri exemplul din prezentarea de mai jos.
- Utilizare Gradient Transform Tool
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Unealta Gradient Transform poate fi utilizata si pentru transformarea culorilor din formele ce au culori "Bitmap fill" (care foloseste o imagine ca si culoare).

Grupare elemente in Flash

Termenul de element se refera la orice tip de desen, forma, linie, obiect, text si imagine din scena. Acestea pot fi grupate impreuna, devenind ca un singur obiect.

Creare grupuri

Cu cat complexitatea si multitudinea desenelor in scena creste cu atat acestea pot interactiona mai mult intre ele, prin pozitionarea apropiata, lipire sau suprapuneri ori alte modificari ce pot afecta si alte desene, complicand lucrul.
Pentru a reduce interactiunea elementelor din scena, acestea se pot grupa, formand mai multe un singur obiect, un Grup de elemente ca intr-o "cutie" in care sunt protejate de interactiunea altor desene, pot fi mutate cu totul si, cand e necesar, modificate intr-un cadru separat /"deasupra" celorlalte elemente din scena.
Gruparea se face simplu, in doi pasi:

1. Se selecteaza (cu Selection Tool sau oricare instrument de selectare) obiectele, liniile, formele, textele, etc. care se doresc sa fie grupate.

2. Se da click pe meniul Modify -> Group (mai rapid, Ctrl+G).

- Acum elementele selectate sunt grupate intr-un singur obiect. Efectul si diferenta se vede cand se incearca mutarea sau selectarea unuia dintre ele, vor fi mutate si selectate toate odata, pastrand intre ele pozitia pe care o aveau cand s-a efectuat gruparea (vedeti exemplu in prezentarea de mai jos).
- Elementele grupate sunt protejate de lipirea cu alte desene, modificarea culorilor sau a altor proprietati in timp ce se lucreaza la alte desene in scena respectiva.
- Daca se doreste totusi efectuarea anumitor modificari unuia sau mai multor elemente din Grup, se da dublu-click pe el (sau click dreapta si se alege "Edit Selected"). Astfel, se intra in acel Grup si elementele pot fi sterse, mutate si editate separat. Ca rezultat, langa numele scenei (in partea stanga-sus) va apare si numele "Group" (vedeti punctul 4 din prezentarea de mai jos), acesta indica faptul ca s-a intrat in grupul respectiv si acela este mediul curent de lucru. Aici, orice schimbari, adaugari desene, etc., vor fi facute in acel mediu de lucru vor apartine acelui Grup, fara a afecta restul obiectelor din scena.
- Dupa ce au fost facute modificarile dorite, pentru a iesi din "editarea grupului", se da click pe numele scenei, sau dublu-click pe un loc liber din scena (numele "Group" va dispare de langa cel al Scenei).
- Un alt avantaj al gruparii e faptul ca obiectul format prin gruparea mai multor elemente (de exemplu o casa) poate fi copiat in alta Scena, Layer, Strat (cu Copy [ Ctrl+C ] si Paste [ Ctrl+V ]), cu totul, asa cum e grupul creat, fara a mai fi nevoie de a face din nou fiecare forma si a le aseza; obtinandu-se tot un Grup, identic.
O modificare ce se poate efectua intregului grup in Scena, adesea folosita in cazul unei copii, este rotirea si modificarea dimensiunilor, in general ceea ce se poate face cu "Free Transform Tool", cand Grupul e selectat cu acel instrument (aratata la punctul 5 din exemplu prezentat mai sus).

Pentru a anula o grupare (degrupa), e la fel de simplu:

1. Se selecteaza grupul respectiv (click cu Selection Tool pe un element din el).

2. Se da click pe meniul Modify -> Ungroup (mai rapid, Ctrl+Shift+G, ori Ctrl+B [Folosit si pt. Break Apart]).

- Acum gruparea a fost anulata, elementele sunt fiecare individuale in scena; pot fi separate, create alte grupuri, etc..
- Exemplu Grupare
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Suprapunere, Aliniere si Rotire

Elementele pot fi aranjate si pozitionate in Scena unul langa celalalt, aliniate, rotite sau suprapuse (unul peste altul).
In tutorialul din aceasta lectie sunt prezentate optiunile folosite pentru diferite moduri de aranjare a elementelor in raport cu alte obiecte sau cu Scena.

1. Aranjare - Suprapunere

Partea mai dificila in aranjarea desenelor apare la suprapunerea lor unul peste altul, existand anumite reguli de ordine in suprapunerea formelor si obiectelor:

1. Desenele facute cu "Object Drawing" sunt mereu plasate peste (deasupra) celor desenate cu "Merge Drawing", in acelasi Layer (Strat).

2. Cand este desenat un obiect, acesta e plasat in fata ultimului.

3. Grupurile (formate din mai multe elemente adaugate intr-un Grup) apar deasupra formelor si obiectelor din acelasi Layer.

4. Fiecare nou Grup format va apare peste anteriorul.

- Flash permite schimbarea acestor ordini de aranjare prin optiunea Arrange, ce se afla in meniul Modify, aceasta apare si in meniul ce se deschide cand se da click-dreapta peste un element din Scena. Cu aceasta functie, obiectele pot fi plasate in fata sau in spatele altora.
Arrange are 4 comenzi:
· Bring to Front - Aduce obiectul selecat in fata tuturor celorlalte.

· Bring Forward - Plaseaza obiectul selectat un nivel in fata.

· Send Backward - Muta obiectul selectat un nivel in spate.

· Send to Back - Duce obiectul selectat in spatele tuturor celorlalte.

- Pentru a invata ce fac concret comenzile de mai sus, vedeti imaginea de jos si testati singuri urmatorul exemplu:
1. Se deseneaza 3 obiecte (cu "Object Drawing"), un cerc, un dreptunghi si un trinughi, putin suprapuse (dreptunghiul fiind intre cerc si triunghi)
2. Ca sa fie plasat cercul peste dreptunghi, se selecteaza cercul si din meniul Modify -> Arrange se alege Bring Forward (acum cercul a trecut un nivel in fata si e la mijloc).
3. Dupa aceasta modificare, dreptunghiul e dedesubt, pentru a-l aduce deasupra de tot (peste celelalte), se selecteaza dreptunghiul si din meniul Modify -> Arrange se alege Bring to Front (acum triunghiul e la mijloc).
4. Se selecteaza cercul si triunghiul (fara dreptunghi) si se adauga impreuna intr-un Grup (din meniul Modify -> Group (sau Ctrl+G)). Se observa ca dupa ce a fost format grupul, acesta e plasat automat deasupra dreptunghiului (inainte el era in fata).
5. Pentru a duce Grupul in spate de tot, se selecteaza si apoi din meniul Modify -> Arrange se alege Send to Back.

- Exemplu cu Arrange
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Formele facute cu "Merge Drawing" nu pot fi aduse cu optiunea "Arrange" in fata obiectelor desenate cu "Object Drawing". Pentru a apare in fata obiectelor, trebuie desenate pe alt Layer superior.

2. Aliniere

Adobe Fash are un panou special pentru alinierea obiectelor in scena. Acesta poate fi deschis din meniul Window -> Align (sau Ctrl+K).
Panoul Align contine mai multe grupuri de butoane pentru alinierea si dimensionarea obiectelor intre ele, in raport cu marginile sau centrul lor, precum si alinierea obiectului (obiectelor) in raport cu marginile si centrul scenei (vedeti imaginea urmatoare).

- Panou Align
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- Ca sa intelegeti ce fac butoanele din Panoul Align, incercati urmatorul exemplu:
1. Desenati un dreptunghi in scena si selectati-l.
2. Deschideti Panoul Align (din meniul Window -> Align, sau "Ctrl+K") si bifati optiunea Align to stage.
3. Testati efectul butoanelor de la Align, Space si Match size.
4. Stergeti dreptunghiul (cu tasta "Del") si desenati altre trei figuri geometrice, asezate aleator.
5. Selectati cele trei figuri desenate, deschideti Panoul Align si debifati optiunea Align to stage.
6. Testati efectul butoanelor, intai de la Distribute, apoi Align, Space si la urma Match size.

- Vedeti acest exemplu si in prezentarea urmatoare.
- Utilizare Panou Align
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- Panoul Align poate fi folosit si cu grupuri de elemente.
3. Rotire

Rotirea obiectelor, liniilor si formelor in sensul direct sau invers orelor de ceas se face rapid cu instrumentul Free Transform Tool (situat in Bara cu instrumente pt. desen).
- Se selecteaza cu "Free Transform" obiectul ce trbuie rotit, apoi cu mouse-ul in unul din colturile cadrului de selectare (cand cursorul mouse-ului ia aspectul unei sageti in forma de cerc) se tine apasat si se roteste obiectul (dupa cum se vede in imaginea urmatoare).

- Rotire cu Free Transform
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Rotirea cu Free Transform este mai putin precisa. Daca se doreste o rotire exacta de 90 de grade, se poate face din meniul Modify -> Transform -> Rotate 90o CW(sau Rotate 90o CCW, invers orelor de ceas).
- O rotire exacta cu un anumit numar de grade se poate face din Panoul Transform, care se deschide din meniul Window -> Transform (sau "Ctrl+T").
- Se selecteaza obiectul (obiectele) ce trebuie rotit, se deschide "Panoul Transform" si se adauga numarul de grade pt. rotatie imediat sub Rotation (buton ce trebuie sa fie bifat, vedeti in imaginea urmatare).
- Rotation in Panoul Transform
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- Rotatia din acest panou se face in sensul orelor de ceas.

Un alt tip de rotatie ete cel in oglinda. Aceasta se face din meniul Modify -> Transform -> Flip Vertical (sau Flip Horizontal). Cu aceste doua optiuni, obiectul, Grupul, pot fi rotite vertical sau orizontal obtinandu-se imaginea acestora in oglinda.

Creare, Utilizare Symbols si Instante

Symbols (Simboluri) sunt elemente, de obicei grafice, care pot fi reutilizate si atunci cand sunt create sunt automat adaugate in panoul Library.
Orice este creat in Flash si plasat in scena (precum: forme, obiecte, text, imagini, grupuri, animatii sau alte symbols) poate fi convertit inSymbol si stocat in Library.
Elementele Symbols sunt strans legate de acest panou, din Library ele pot fi reeditate si adaugate in scena.
- Pot fi create trei tipuri de Symbols: Movie Clip, Button si Graphic; fiecare avand proprietati specifice si "Timeline" propriu.

· Graphic - De obicei folosit pentru desene, imagini si grafica statica; dar poate fi folosit si pt. efecte animate.

· Button - Se foloseste pentru butoane, avand proprietati specifice necesare butoanelor.

· Movie Clip - este in general indicat pentru animatii si in cazuri cand nu sunteti siguri ce tip de Symbol sa fie creat.

- Pentru a crea un Symbol, se selecteaza obiectul sau elementele ce trebuie convertite, se da click pe meniul Modify -> Convert to Symbol(sau tasta F8), iar in fereastra care apare (prezentata in imaginea afisata putin mai jos) se poate da un nume si se alege unul din tipurile de Symbol prezentate mai sus, apoi se da OK.

Un element Symbol preluat din Library si adaugat in scena se numeste Instanta (Instance) a acelui Symbol. Prin adaugare din acelasi Symbol, din Library, a mai multor obiecte in Scena, se creaza de fapt mai multe Instante ale acelui Symbol.
- Fiecare Instanta este ca o copie sau reflexie a originalului (Simbolul din Library, numit si "parinte"), astfel, daca se modifica originalul sau una din Instante, modificarile facute vor fi transmise si originalului si la toate Instantele lui, deoarece, Simbolul cu toate instantele sunt de fapt un singur element.
- Sunt unele modificari ce pot fi facute separat unei instante, fara a afecta pe restul sau originalul. Aceste modificari sunt cele care se pot face direct in Scena principala de lucru, cu "Free Transform" si cele pt. efecte de culoare de la "Color Effect" din panoul Properties.
Daca este sters originalul, din Library, vor fi sterse toate instantele.

Utilizarea Simbolurilor si a panoului Library eficientizeaza munca, avand mereu la indemana desenele facute anterior, de asemenea, mentine dimensiunea fisierului Flash mica, deoarece Instantele sunt ca niste "imagini /reflexii" ale originalului si nu afecteaza marimea fisierului; oricate Instante s-ar crea, elementul respectiv e stocat si incarcat o singura data.
Un alt avantaj pe care-l dau Simbolurile este faptul ca lor pot fi aplicate unele optiuni si efecte ce nu pot fi aplicate obiectelor simple. De exemplu, unei imagini importate nu i-se poate da direct efecte de contrast, transparenta sau alte filtre, dar daca e transformata in Symbol (Movie Clip) i-se pot aplica.

Iata un exzemplu din care puteti invata cum se creaza concret si cum se foloseste un Symbol simplu (il puteti vedea si in prezentarea de mai jos, "Creare, utilizare Symbol"). Efectuati pasii urmatori:
1. Deschideti un document Flash nou si cu "Oval Tool" desenati un cerc si apoi, cu "Selection Tool" asigurati-va ca este tot selectat.
2. Click pe meniul Modify -> Convert to Symbol (sau tasta F8). Se va deschide o fereasta ca cea din imaginea urmatoare.
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3. Adaugati un nume la Name (de exemplu Cerc), la Type alegeti Movie Clip si dati OK. Acum elementul Symbol, "Cerc", e creat.
  - Desi Flash da automat nume consecutive pt. Symbol ("Symbol 1", "Symbol 2" ...), este indicat sa dati fiecaruia un nume logic, potrivit elementului respectiv, ca sa fie usor recunoscut in Library.
4. Deschideti panoul Library (Ctrl+L), observati ca Simbolul creat (Cerc) se afla si in panou. Daca dati click pe el apare deasupra imaginea a ce contine Simbolul.
  - Obiectul ramas in scena a devenit o Instanta a Simbolului din Library.
Adaugati in scena alte cateva Instante ale Simbolului, click pe numele Simbolului, "Cerc", din panou si trageti cu mouse-ul in scena. Creati 3 sau 4 Instante.
5. Acum se incearca editarea Simbolului parinte. In panoul Library dati dublu-click pe imaginea simbolului (sau click-dreapta si alegeti Edit, ori Ctrl+E). Astfel se intra in pagina /modul de editare a Simbolului, fapt indicat de numele simbolului (Cerc) care apare langa numele scenei (Scene 1), vedeti imaginea urmatoare (mod similar cu editarea Grupurilor). Alt indiciu poate fi aparitia unui mic semn "+" (plus) in zona de lucru, precum si suprafata complet alba, fara margini, doar cu Simbolul respectiv in ea.
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6. Schimbati culoarea cercului si iesiti din pagina de editare a Simbolului, prin click pe numele "Scene 1" sau dublu-click pe un loc gol. Reapare Scena principala de lucru, cu cercurile /instantele in ea. Disparand numele "Cerc" de langa "Scene 1" indica faptul sa s-a iesit din pagina de editare a Simbolului.
  - Observati ca modificarea facuta, schimbarea culori, a fost transferata la toate Instantele.
7. Acum se intentioneaza modificarea unei Instante. Efectuati dublu-click pe unul din cercurile din Scena. Observati ca apare din nou numele "Cerc" langa "Scene 1", indicand faptul ca pagina curenta de lucru este in mediul pt. editare element "Cerc", precum si semnul "+". Totusi, fata de modul de editare a Simbolului parinte, cand in pagina aparea doar acel Symbol, restul tot fiind alb, acum, in modul de editare a Instantei, se vad si celelalte obiectelor din Scena principala, mai sterse (ca in ceata), dar nu pot fi efectuate modificari la ele.
  - Acest mod de editare se numeste in Flash "Edit in Place"
In aceasta pagina modificati din nou culoarea cercului apoi selectati-l cu "Free Transform Tool" si transformati cercul intr-un oval.
  - Se observa direct din pagina de editarea a Instantei ca aceste modificari au fost efectuate si la celelalte Instante, chiar si la Simbolul parinte, din Library.
8. Reveniti la Scena principala, prin click pe "Scene 1" sau dublu-click intr-un loc gol pe suprafata alba (va dispare numele "Cerc" de langa cel al scenei).
In Scena principala de lucru selectati cu "Free Transform" una din instantele la "Cerc" (acum devenita o figura ovala), rotiti-o si modificati-i marimea.
  - De data aceasta modificarile nu au mai fost transferate si la celelalte Instante sau la original.
Modificarile facute Simbolului parinte (din Library) sau unei Instante in pagina ei proprie de editare sunt transferate si la celelalte instante. Dar modificarile ce se pot face unei Instante direct in Scena principala raman doar la ea.


9. Selectati iar una din Instante si stergeti-o (apasand tasta "Del", sau meniul Edit -> Clear).
  - Celelalte Instante raman in Scena
Stergeti si Simbolul parinte din panoul Library (click pe el si apoi tasta "Del", sau click-dreapta pe el si Delete).
  - De aceasta data dispar si instantele din Scena.
In continuare puteti vedea si prezentarea Flash a acestui exemplu.
- Creare, utilizare Symbol
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La fel pot fi create Symbols si din Grupuri sau Instante de Symbol, prin selectarea elementelor care dorim sa fie transformate intr-un Symbol si aplicarea optiunii "Convert to Symbol" (rapid, F8).
O alta modalitate de a crea Symbols este folosind optiunea New Symbol, ce se gaseste in meniul Insert si in optiunile panoului Library (sau Ctrl+F8).
- Cu aceasta metoda, dupa ce se defineste numele si tipul simbolului, se va intra direct in pagina de editare pt. acel Symbol, o zona de lucru alba cu un semn "+" in centru. Orice se creeaza in acea pagina va reprezenta Simbolul creat.

In panoul Library, cand se da click dreapta pe un Symbol (sau alte elemente stocate in el) apare o serie de optiuni ce pot fi aplicate. Dinre acestea, ar putea fi mai utile de cunoscut urmatoarele:
    - Rename - pt. schimbarea numelui.
    - Duplicate - pt. a crea o dublura, in caz ca se doreste efectuarea anumitor modificari si sa fie pastrata forma initiala, sau daca se doreste efectuarea unor schimbari intr-un Symbol, fara a afecta instantele din Scena (se foloseste dublura creata, care e de fapt un alt Symbol).
    - Properties - deschide fereastra prin care se pot modifica numele si tipul Simbolului (in general proprietatile elementelor).

Pentru editarea unei Instante sunt 3 optiuni "Edit", care pot fi alese cand se da click-dreapta pe Instanta respectiva:
· Edit - Deschide o pagina de editare complet alba, in care se vede doar Simbolul / Instanta.

· Edit in Place - Deschide o pagina in care, in afara de Instanta, se vad mai sterse (ca prin ceata) si celelalte obiecte din Scena. Nu pot fi editate, dar pot fi folosite ca referinte in timpul editarii.

· Edit in New Window - Va deschide pagina pt. editare intr-o noua fereastra. Astfel, se poate lucra alternativ si in Scena principala si in pagina de editare, vazand cum arata in context modificarile facute simbolului.

- Indiferent de metoda, rezultatul e acelasi.

- In tutorialele urmatoare va fi prezentat fiecare tip de Symbol in parte, precum si alte lucruri despre Instante.
Graphic Symbols si Instante

Graphic Symbols (Simboluri grafice) pot fi folosit pentru imagini statice si animatii care sunt in legatura /sincronizate cu linia principala de Timeline.
Spre deosebire de tipul de Symbol "Movie clip", o animatie continuta intr-un "Graphic Symbol" poate fi vazuta in linia principala de Timeline, dar sunete si ActionScript nu vor functiona in acesta.

Crearea unui "Graphic Symbol" e simpla:

1. Se selecteaza obiectul sau elementele ce trebuie convertite (poate fi orice element: linie, forma, imagine, instanta de simbol, etc.)

2. Se da click pe meniul Modify -> Convert to Symbol (sau tasta F8)

3. In fereastra care apare se poate da un nume (la Name) si la Type se alege optiunea Graphic, apoi se da OK.

- Simbolul Grafic creat va fi adaugat automat si in panoul Library.
- Este indicat sa dati fiecarui Symbol creat un nume logic, potrivit elementului respectiv, ca sa fie usor de recunoscut in Library si de asemenea pentru cazuri cand e folosit cu ActionScript.

O alta modalitate de a crea Symbols este cu optiunea New Symbol, ce se gaseste in meniul Insert si in optiunile panoului Library (sau Ctrl+F8). Acestea deschid fereastra pentru setarea numelui si tipul simbolului.
- Cu aceasta metoda, dupa ce se defineste numele si tipul (in acest caz, Graphic) si se da OK, se va intra direct in pagina de editare pt. acel Symbol, o zona de lucru alba cu un semn "+" in centru (vedeti imaginea de mai jos), unde se poate lucra ca si in Scena principala, cu instrumentele de lucru si imagini importate. Orice se creaza in acea pagina va reprezenta Simbolul nou creat.
- Langa numele scenei va apare si numele simbolului creat, indicand faptul ca zona curenta de lucru este in modul de editare a acelui Symbol.
- Creare Symbol - Pagina de editare
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- Dupa ce se termina de editat Simbolul Nou, se iese din pagina de editare a acestuia (prin click pe numele scenei, sau dublu-click pe un loc gol din pagina alba). Simbolul astfel creat va fi adaugat doar in Library, iar de aici se pot trage instante (copii ale lui) in zonele de lucru.
Instanta unui Symbol poate fi transformata intr-o simpla imagine editabila prin selectarea ei, apoi click pe meniul Modify -> Break Apart. Astfel nu mai are legatura cu Simbolul parinte sau celelalte copii.

- O alta modificare ce se poate face unei Instante, fara a afecta originalul sau alte Instante, este schimbarea Simbolului parinte cu alt Symbol, dar pastrand forma si efectele adaugate ei. Acest lucru se face cu proprietatea Swap.
1. Se selecteaza Instanta care sa fie modificata.

2. In panoul Properties se da click pe butonul Swap (sau click dreapta pe instanta si se alege optiunea Swap Symbol).

3. Din fereastra ce se deschide, in care e lista cu simboluri, se alege Symbolul care sa devina "parinte" pentru instanta respectiva si se da OK.

- Pentru a nu afecta noul Symbol parinte si instantele lui la o eventuala editare a Instantei care l-a ales, se poate da intai click pe butonul Duplicate Symbol si se alege ca parinte dublura creata (vedeti imaginea urmatoare).
- Swap Symbol
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Instanta unui Simbol Grafic are 3 optiuni principale, care pot fi alese din panoul Properties al Instantei, dupa cum se vede in imaginea urmatoare.
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· Loop - Determina repetarea continua a animatiei din Timeline-ul Simbolului.

· Play once - Deruleaza animatia din Timeline-ul Simbolului o singura data, apoi se opreste.

· Single Frame - Face instanta sa arate un singur Frame (cadru) din Timeline-ul Simbolului (cel cu numarul mentionat la optiunea First, din Properties).

Symbols sunt de obicei folosite in documentul in care au fost create, dar pot fi transferate si de la un document Flash la altul.
- Se deschid ambele documente Flash.
- In cel cu Simbolul, se da click-dreapta pe Symbol din Library si se alege optiunea Copy.
- In celalalt document, in Scena unde trebuie copiat Simbolul se da "Ctrl+V" (sau din meniul Edit -> Paste in Center). Simbolul va fi adaugat automat si in panoul Library al acelui document.

Movie Clip Symbols

Elementele Symbols de tip Movie Clip sunt recomandate a fi folosite pentru Symbols ce vor contine animatii sau pentru imagini importate la care se doreste aplicarea vreunui filtru, efect de culoare in Flash sau rotire 3D.
Timeline-ul din "Movie Clip" este independent de cel principal. Astfel, avand o animatie in Simbolul Movie Clip, aceasta este stocata si repetata intr-un singur Frame (cadru) din Timeline-ul principal, indiferent de cate cadre are animatia din simbolul "Movie Clip".
Instantele Movie Clip pot contine animatii /filme cu sunete si control prin ActionScript, precum si alte "Movie Clip".
- Spre deosebire de "Graphic Symbol", la Movie Clip se poate vedea doar primul Frame in Timeline-ul principal.

Crearea unui Symbol "Movie Clip" e simpla:

1. Se selecteaza obiectul sau elementele ce trebuie convertite (de obicei imagini sau obiecte /desene care trebuie animate)

2. Se da click pe meniul Modify -> Convert to Symbol (sau tasta F8)

3. In fereastra care apare se poate da un nume (la Name) si la Type se alege optiunea Movie Clip, apoi se da OK.

- Simbolul creat va fi adaugat automat si in panoul Library.

O alta modalitate de a crea Symbols (mai des folosita la "Movie Clip" decat pentru celelalte tipuri de Symbols) este cu optiunea New Symbol, ce se gaseste in meniul Insert si in optiunile panoului Library (sau Ctrl+F8). Acestea deschid fereastra (afisata in imaginea urmatoare) pentru setarea numelui si tipul simbolului.
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- Cu aceasta metoda, dupa ce se defineste numele si tipul (in acest caz, Movie Clip) si se da OK, se va intra direct in pagina de editare pt. acel Symbol, o zona de lucru alba cu un semn "+" in centru, unde se poate lucra ca si in Scena principala, cu instrumentele pt. desen, imagini si sunete importate, animatii, etc.. Orice se creaza in acea pagina va reprezenta Simbolul nou creat, care e adaugat automat in Library.

Editarea unui element Movie Clip se face la fel ca la celelalte tipuri de Symbol. Se alege Simbolul din panoul Library si se apasa "Ctrl+E" (sau dublu-click pe acel Symbol). Se va deschide pagina alba pentru editarea lui.
- Ca la toate tipurile de Symbols, si la "Movie Clip" modificarile facute vor fi transferate si Instantelor lui.
- Daca acesta contine o animatie, modificarile facute intr-un cadru (Frame) din Timeline-ul simbolului Movie Clip vor fi transpuse in toate celelalte cadre ale lui.

Instantele simbolului Movie Clip se creaza la fel ca la toate elementele Symbol, se trag cu mouse-ul din Library in Scena de lucru.
- Editarea unei Instante Movie Clip se face in acelasi mod ca la celelalte tipuri, prin dublu-clik pe Instanta, sau click-dreapta pe ea si se alege una din optiunile: Edit, Edit in Place sau Edit in New Window. Se va deschide pagina de editare.
- Ca si in cazul editarii Simbolului parinte, orice modificare facuta instantei in pagina ei de editare va fi transferata automat originalului (din Library) si la celelalte Instante.
- Modificarile ce se pot face unei Instante direct in Scena unde a fost trasa (cu "Free Transform Tool", sau filtre si efecte de culoare) nu vor afecta celelalte copii sau originalul; dar cand Instanta contine animatie /film, Flash va aplica schimbarile facute tuturor cadrelor din animatia continuta in Instanta Movie Clip. De exemplu, daca se roteste Instanta in Scena si i-se aplica un efectul de culoare, animatia din ea (cu toate cadrele ei) va avea aceeasi rotire si cu efectul de culoare aplicat.
- Si la Movie Clip, daca se sterge Simbolul parinte (din Library), vor fi sterse toate instantele lui.

Iata un exemplu de utilizare a simbolului Movie Clip. Se adauga unu filtru, rotire 3D si efect de culoare unei imagini importate. Efectuati urmatorii pasi (puteti vedea intai acest exemplu in prezentarea de mai jos "Movie Clip - Imagine"):
1. Deschideti un document Flash nou, cu scena alba, si alegeti meniul File -> Import -> Import to Stage (sau Ctrl+R) si adaugati o imagine in Scena.
Dupa ce imaginea a fost adaugata si e selectata, daca dati pe panoul Poroperties, observati ca nu sunt optiuni pentru efecte de culoare. Pot fi modificate doar dimensiunile si pozitia.
2. Alegeti instrumentul 3D Rodation Tool din bara cu uneltte pt. desen (sau tasta 'W'). Incercati sa faceti ceva cu acesta imaginii, dar rezultatul ..., nimic.
3. Cu imaginea selectata dati click pe meniul Modify -> Convert to Symbol si transformati imaginea in Symbol "Movie Clip" (in fereastra care apare alegeti la TypeMovie Clip si dati OK). Acum imaginea e transformata in "Movie Clip"
  - Daca verificati in Library veti gasi 2 elemente, imaginea importata si Simbolul parinte creat dupa ea.
4. In panoul Properties al imaginii din Scena au aparut optiuni noi.
La Filters dati click pe butonul Add filter (situat in stanga-jos, vedeti in imaginea urmatoare) si adaugati un efect, de exemplu Drop Shadow. Pentru a-l personaliza, modificati proprietatile lui, cum ar fi: la Color o culoare albastra (sau care vreti), la Distance 12 px si la Quality High.
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5. Acum alegeti din nou "3D Rotation Tool" si dati click pe imagine. Se observa ca e selectata si tragand cu mouseul puteti efectua rotirea ei in plan 3D.
6. Un ultim efect, in panoul properties, la Color Effect alegeti una din optiuni, de ex. Brightnes.

- Din acest exemplu (pe care-l puteti vedea in prezentarea urmatoare) se vede utilitatea folosirii simbolului Movie Clip.
- Movie Clip - Imagine
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 Creare Butoane Symbols

Elementele Button Symbols (Simboluri buton) se folosesc pentru a adauga interactivitate in continutul /animatia Flash.
Cu aceste Butoane utilizatorul poate efectua diferite actiuni, cum ar fi: oprirea sau pornirea unei animatii /film, saltul la anumite scene, incarcarea unei pagini web, si altele.
Crearea unui Buton in Flash se face simplu, ca si la celelalte tipuri de Symbols, prin una din cele 2 metode: convertirea unui obiect din scena in Buton sau prin utilizarea optiunii New Symbol.
- Pentru prima metoda se executa urmatorii pasi:

1. Se selecteaza obiectul ce trebuie transformat in Buton.

2. Se da click pe meniul Modify -> Convert to Symbol (sau tasta F8).

3. In fereastra care apare (cea afisata mai jos) se poate da un nume (la Name) si la Type se alege optiunea Button, apoi se da OK.
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Simbolul creat va fi adaugat automat si in panoul Library, de aici poate fi in continuare editat.

- Pentru a doua varianta, se apeleaza optiunea New Symbol, din meniul Insert sau din optiunile panoului Library (sau Ctrl+F8). Se va deschide o fereastra ca cea din imaginea de sus, pentru setarea numelui si tipul simbolului.
- Cu aceasta metoda, dupa ce se defineste numele si tipul (in acest caz, Button) si se da OK, se va intra direct in pagina de editare pt. acel Symbol, o zona de lucru alba cu un semn "+" in centru, unde se poate lucra ca si in Scena principala, cu instrumentele de desen, imagini si sunete importate, etc.. Orice se creaza in acea pagina va fi inclus in Butonul nou creat, care este adaugat automat in Library.

Simbolurile Buton au un Timeline specific, format din 4 cadre (Frames) denumite: Up, Over, Down si Hit; dupa cum se vede in imaginea urmatoare.
[image: image80.jpg]



Fiecare Frame are o functie specifica care ajuta la definirea si controlarea butonului in 4 stari /conditii diferite:

· Up - In acest cadru se defineste cum sa apara initial butonul in continutul Flash.

· Over - Aceasta stare e declansata cand utilizatorul pozitioneaza mouse-ul deasupra butonului. Aici se creaza butonul cum sa apara in aceasta conditie.

· Down - Aceasta stare apare in momentul cand este apasat butonul cu mouse-ul.

· Hit - In aceast Frame se defineste zona activa din buton, zona in care trebuie plasat mouse-ul pentru a actiona butonul. El este invizibil in afara paginii de editare.
Daca la acest cadru nu se face nimic (nu e folosit), suprafata activa a butonului va fi cea din ultimul Frame folosit.
- Acest Frame e util cand se doreste ca doar o anumita parte din buton sa fie activatoare (de exemplu o petala sau centrul unei flori).
- Cadrul "Hit" poate fi folosit si pentru a crea butoane invizibile, vedeti tutorialul Butoane invizibile.

Iata un exemplu de creare a unui buton simplu si testarea lui (il puteti vedea si in prezentarea de mai jos, "Creare Buton Flash"). Efectuati urmatorii pasi:
1. Deschideti un document Flash nou, cu scena alba, alegeti instrumentul pentru desen dreptunghi (Rectangle Tool) si desenati pe scena un dreptunghi.
2. Acesta fiind selectat, dati click pe meniul Modify -> Convert to Symbol (sau tasta 'F8'), se va deschide fereastra pt. covertire in Symbol.
3. In aceasta fereastra alegeti la Type optiunea Button (puteti da si un nume la Name) si dati OK.
  - Simbolul Buton e creat si adaugat in Library, iar dreptunghiul din Scena devine instanta a lui.
4. In panoul Library dati dublu-click pe Simbolul Buton (sau click pe el si apoi Ctrl+E). Se va intra in pagina de editare a butonului, lucru indicat si de numele butonului aparut langa cel al scenei (Scene 1).
  - Se observa in panoul Timeline cele 4 cadre speciale (Up, Over, Down si Hit), doar primul, "Up", avand continut in el, restul fiind goale.
5. Apasati click-dreapta pe Frame-ul "Over" si alegeti optiunea Insert Keyframe. Se va crea o copie a cadrului anterior (Up) in Frame-ul "Over".
6. In acest cadru alegeti instrumentul "Oval Tool" (din bara cu unelte pt. desen, sau rapid, tasta 'O'), schimbati culoarea de la "Fill Color" si desenati un cerc in dreptunghi.
7. Apasati click-dreapta pe Frame-ul "Down" si alegeti optiunea Insert Keyframe. Se va crea o copie a cadrului anterior (Over) in Frame-ul "Down".
8. Aici alegeti instrument-ul "Free Transform" (din bara cu instrumente pt. desen, sau rapid, tasta 'Q'). Dati un click pe un loc gol din pagina, pentru a deselecta obiectele selectate, apoi click pe cercul din dreptunghi pt. a selecta doar cercul".
9. Trageti cu mouse-ul de punctele de selectie, facand din cerc un oval, apoi schimbati-i culoarea, de la "Fill Color" (una diferita de cea a dreptunghiului).
Acum sunt definite cele 3 stari ale butonului. Reveniti la Scena principala de lucru (prin click pe numele "Scene 1" din coltul stanga-sus).
  - Se observa ca in Scena apare dreptunghiul (convertit in Buton) cu starea initiala (din cadru "Up"), celelalte stari (Over si Down) fiind ascunse.
10. Acum va fi testat butonul, ca sa se vada rezultatul obtinut. Pentru aceasta se da click pe meniul Control -> Test Movie -> in Flash Professional. Se va deschide o fereastra mai mica, cu butonul in ea. Pozitionati mouse-ul deasupra dreptunghiului si tineti putin apasat click.
Se va produce efectul asteptat, la pozitionarea mouse-ului pe buton acesta se scimba aparand starea lui din cadrul "Over", iar la click pe el apare cum e definit in cadrul Down.
11. Sa incercam si efectul cadrului "Hit" din Buton. Inchideti fereastra de test si dati dublu-click pe Simbolul Buton adaugat in Library. Se intra iar in pagina de editare a butonului.
12. Apasati click-dreapta pe Frame-ul "Hit" si alegeti optiunea Insert Blank Keyframe. Se va crea o pagina alba in cadrul "Hit".

"Insert Keyframe" creaza in cadrul respectiv o copie a celui precedent, iar "Insert Blank Keyframe" creaza o pagina goala in acel Frame.

13.In aceasta pagina alba a cadrului "Hit", in dreptul semnului "+", desenati un cerc mic (astfel incat sa fie cuprins in zona care stiti ca se afla dreptunghiul in celelalte cadre, in raport cu acel "+").
  - Semnul "+" este un indiciu de reper pentru a putea desena in pagna alba, tinand cont de cum este el pozitionat in raport cu desenele din celelalte cadre.
Acest cerculet va reprezenta zona activa a butonului.
14. Acum testam si rezultatul obtinut dupa editarea in Frame-ul "Hit". Dati iar click pe meniul Control -> Test Movie -> in Flash Professional. In fereastra de test butonul apare la fel, pozitionati mouse-ul pe diferite locuri din el, dati si click, observati ca efectul de schimbare de la starile "Over" si "Down" (pt. click) apare doar cand mouse-ul se afla in zona in care s-a desenat cerculetul in cadrul "Hit", dar acesta e invizibil.
  - In zona activa mouse-ul capata aspectul unei "manute cu deget indicator".
- Iata si prezentarea Flash a acestui exemplu.
- Creare Buton Flash
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Ca sa testati butonul direct in Scena de lucru, dati click pe meniul Control -> Enable Simple Buttons.
Cu aceasta optiune activata, butonul va afisa starea "over" cand mouse-ul este pozitionat deasupra lui in Scena, precum si starea "Down" la click pe el.
- Pentru a reveni la modul de lucru normal pt. Buton, dezactivati optiunea "Enable Simple Buttons" (dand iar click pe ea in meniul "Control").


Editarea unui element Buton se face la fel ca la celelalte tipuri de Symbol. Se alege Simbolul din panoul Library si se apasa "Ctrl+E" (sau dublu-click pe acel Symbol). Se va deschide pagina alba pentru editarea lui.
- Ca la toate tipurile de Symbols, si la "Button" modificarile facute vor fi transferate si Instantelor lui.

Instantele simbolului Buton se creaza la fel ca la "Graphic" si "Movie Clip", se trag cu mouse-ul din Library in Scena de lucru.
- Editarea unei Instante Button se face la fel ca la celelalte tipuri, prin dublu-clik pe Instanta, sau click-dreapta pe ea si se alege una din optiunile: Edit, Edit in Placesau Edit in New Window. Se va deschide pagina de editare.
- Ca si in cazul editarii Simbolului parinte, orice modificare facuta instantei in pagina ei de editare va fi transferata automat originalului (din Library) si la celelalte Instante.
- Modificarile ce se pot face unei Instante direct in Scena unde a fost trasa (cu "Free Transform Tool", sau filtre si efecte de culoare) nu vor afecta celelalte copii sau originalul; dar va aplica schimbarile facute si la celelalte stari (Over, Down, Hit).
- Daca se sterge Simbolul parinte (din Library), vor fi sterse toate instantele lui.
Puteti gasi cateva zeci de Template-uri de butoane gata facute in programul Flash. Alegeti meniul Window -> Common Libraries -> Buttons. Se va deschide un panou cu mai multe directoare pentru diferite tipuri de butoane. Directoarele pot fi deschise prin dublu-cklick, apoi butoanele pot fi trase in Scena (vor fi adaugate in Library).

Pentru ca un buton sa poata face ceva interactiv cand cineva da click pe el, trebuie folosit si cu ActionScript.

Import Imagini

Teoretic, se poate taia si copia elemente grafice din orice program si apoi adaugate in documentul Flash.
De exemplu, o imagine deschisa cu Microsoft Paint; se poate selecta o portiune (sau toata) cu "Ctrl+C" din imaginea aflata in Microsoft Paint, apoi, in Adobe Flash se alege Edit -> Paste in Center (sau "Ctrl+V"), copiind astfel imaginea din Paint in Scena Flash.
O ata metoda pentru a adauga imagini (din fisiere de tip: ai, bmp, gif, jpg, png, psd) in documentul Flash este utilizarea optiunii Import, din meniul File -> Import se alege Import to Stage (rapid, Ctrl+R) sau Import to Library.
- "Import to Stage" va adauga imaginea aleasa si in scena si in Panoul Library, iar "Import to Library" va adauga imaginea doar in Panoul Library.

- Import imagini
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Daca numele fisierului cu imaginea (poza) importata face parte dintr-o serie de fisiere cu nume secventiale (ex." img_02.jpg, img_03.jpg, img_04.jpg), Flash le poate importa pe toate odata (fiecare in cate un Frame in Scena). Recunoscand numele secventiale, Flash va afisa o fereastra (ca cea de jos) cu optiunile de a alege importarea tuturor acelor fisiere sau doar a celui ales.
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- Importul de imagini cu extensia ".ai" (facute cu Adobe Illustrator") si ".psd" (facute in Photoshop) se potriveste bine cu Adobe Flash CS5 deoarece aceste programe folosesc Layers (Straturi) similare cu cele din Flash, si astfel se poate alege care Layer sa fie importat, iar programul le converteste in Straturi Flash.
- In fereastra Preferences (ce se deschide din meniul Edit -> Preferences, sau Ctrl+U) pot fi setate diferite moduri in care sa fie importate fisierele ".ai" (la optiunile din AI File Importer) sau ".psd" (la optiunile din PSD File Importer).
De asemenea, Flash lucreaza bine si cu imaginile facute in programul Fireworks, acesta avand niste efecte speciale (numite "filters") ce pot fi aplicate imaginilor. Se pot copia multe din aceste efecte cu imaginile de la Fireworks la Flash si raman editabile in documentul Flash.
Fie prin copiere direct din alt program, fie prin "Import", imaginea adaugata in documentul Flash este adaugata si in Panoul Library.
- Daca imaginea adaugata in Flash este stearsa din Scena, aceasta ramane in Library si poate fi oricand folosita.
- Daca imaginea adaugata in Flash este stearsa din Panoul Library, aceasta va fi stearsa si din Scena.

Trebuie retinut ca adaugarea, importul de imagini din surse externe in Flash creste considerabil marimea documentului Flash si a fisierului SWF.
1. Modificarea imaginilor importate

Cea mai simpla modificare ce se poate aplica imaginilor copiate /importate este dimensionarea si rotirea lor, cu "Free Transform".
Desenele facute direct in Flash, in modul "Object Drawing" folosesc grafica prin Vector. Daca Adobe Flash recunoaste imaginea importata ca fiind o "imagine vector" (precum cele facute cu Adobe Illustrator) cu linii si forme distincte, aceasta poate fi editata in continuare in Flash cu instrumentele lui.
Daca imaginea e de tip "Bitmap", trebuie facute anumite ajustari, deoarece Flash recunoaste imaginile Bitmap ca o "pata" de pixeli nedefiniti. Adobe Flash are cateva optiuni pentru a lucra cu "bitmaps": le poate transforma intr-o "Forma" (ca o umplere facuta cu "Merge Drawing"), imparti in grafica vectoriala sau transforma in "Symbols".

      - Transformare Bitmap in Forma /Umplere
Aceasta transformare se face cu optiunea Break Apart. Se da click pe imaginea din scena si se alege meniul Modify -> Break Apart (sau Ctrl_B). Va transforma imaginea intr-o umplere editabila, la care se pot aplica instrumentele de selectie si desenare din bara cu unelte pt. desen.

      - Transformare Bitmap in Vectori
Se selecteaza imaginea si apoi se da click pe meniul Modify -> Bitmap -> Trace Bitmap.
Aceasta transformare depinde de complexitatea imaginii, a formelor si liniilor, precum si de numarul de culori din ea. In functie de acestea, Flash recunoaste formele si le transforma in grafica vectoriala sau poate transforma imaginea in mai multe parti de Forme (Shape).
Cu cat imaginea are mai putine culori si forme precis conturate, cu atat sunt mai bine recunoscute si transformate de Flash.

- Partile Shape (Forma) pot fi transformate in desene vectoriale din meniul Modify -> Combine Objects -> Union

      - Transformare Bitmap in Symbols
Nu se poate modifica stralucirea, contraxtul sau transparenta la o imagine direct importata, dar pot fi modificate la un obiect Symbol.
Daca se doreste aplicarea unuia din aceste filtre la o imagine, de exemplu pentru a se obtine un efect de transparenta ori luminozitate, se transforma intai imaginea in Symbol.
Se selecteaza imaginea, apoi se alege meniul Modify -> Convert to Symbol (sau tasta F8). In fereastra care apare, "Convert to Symbol", se alege de la Type tipulMovie Clip si click OK.
- Acum pot fi aplicate imaginii (devenita Symbol) Efecte de culoare si Filtre din Panoul Properties, la meniurile "Color Effect" si "Filters".
Daca nu se intentioneaza aplicare vreunui efect de culoare, ci obtinerea unui fisier de dimensiuni cat mai mici; la transformarea in Symbol, in loc de "Movie Clip" se alege tipul Graphic.

2. Optimizarea imaginilor importate

O metoda indicata pentru obtinerea unor fisiere Flash cat se poate de mici cand in ele au fost importate imagini, care cresc considerabil marimea fisierului, este optimizarea imaginilor importate, prin compresie.
- Pentru aceasta trebuie ca imaginea sa fie importata doar in panoul Library (de la File -> Import -> Import to Library), sau daca e adaugata si in Scena, sa fie stearsa din Scena fiindca imaginea ramane adaugata in Library.
- In panoul Library se da click dreapta pe imaginea importata si se alege Properties, se va deschide o fereastra cu diferite optiuni pt. compresie /optimizare (vedeti in imaginea urmatoare).

- Proprietati optimizare imagini importate
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· Allow Smoothing - Daca aceasta optiune e bifata, netezeste si uniformizeaza marginile imaginii. Utila cand imaginea respectiva trebuie rotita sau redimensionata, facand in acest caz pixelii imaginii sa fie mai bine aliniati cu pixelii ecranului. In rest, daca nu se intentioneaza rotirea sau redimensionarea, nu e necesar bifarea acestei optiuni, deoarece o face putin estompata (intensitatea culorilor mai slaba).

· Compression - Aici pot fi alese optiunile Photo (JPEG) si Lossless (PNG/GIF).
- "Photo (JPEG)" - este eficienta cand se doreste reducerea cat mai mult a marimii fisierului, pentru imagini fara transparenta si mai putin complexe artistic.
- "Lossless (PNG/GIF)" - este utila pentru imagini GIF si PNG (in general artistice, fotografii), realizand o compresie fara a pierde din calitatea imaginii, iar in cazul PNG pastreaza si transparenta; dar marimea va fi mai mare decat la compresia JPEG.

· Quality - Aceasta optiune se foloseste in cazul "Photo (JPEG)" si are modurile Use imported JPEG data si Custom
- "Use imported JPEG data" - Daca e lasat bifat, acesta mentine imaginea la compresia facuta de aplicatia Flash.
- "Custom" - Permite controlarea nivelului compresiei (valorile sunt intre 1 si 100). Cu cat valoarea e mai mica, compresia creste, dar scade din calitatea imaginii.

· Enable deblocking - Reduce din imagine structurile ce au o calitate slaba, sterse.

- Pentru a vedea efectul si rata de compresie obtinute dupa fiecare modificare a uneia din aceste optiuni, se apasa butonul Test.
- Butonul Update reincarca imaginea din locatia ei originala.
- Dupa ce s-a obtinut compresia dorita, se apasa OK. Astfel, in panoul Library imaginea ramane cu optimizarea facuta si poate fi folosita in Scena prin tragerea ei din Library.
Daca aceeasi imagine trebuie folosita de mai multe ori, in mai multe locuri in documentul Flash, este indicat tragerea ei de fiecare data din panoul Library, in loc de a folosi "Copy-Past". Deoarece, multiplicarea imaginii prin copiere (Copy-Past) mareste dimensiunile fisierului, pe cand, daca e luata din Library, va fi ca si cum este folosita o singura data.

Cand o imagine este importata in documentul Flash, pe langa faptul ca este adaugata in panoul Library, acea imagine este adaugata si in Paleta de Culori (pe randul cu efectele Gradient). Astfel, poate fi aleasa si folosita in desene ca orice culoare din Paleta de Culori (vedeti imaginea urmatoare).
- Import imagini - Paleta Culori
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In afara de poze si imagini, pot fi importate si adaugate in continutul Flash si alte tipuri de fisiere, in special multimedia, cum ar fi: AVI, EPS, FLV, MP3, MP4, PDF, SWF

Animatie - Introducere

Animatia in Flash este un capitol vast, fiind unul din principalele lucruri pentru care este folosit programul Adobe Flash. Sunt necesare mai multe lectii pentru a fi prezentate elementele de baza in crearea si utilizarea animatiei in Flash.
In aceasta lectie e prezentata partea introductiva si esentiala ce trebuie stiuta despre animatie. Pe parcurs, in lectiile din acest curs vor fi si tutoriale mai avansate, cu lucruri si exemple mai complexe, dar care au la baza cele aratate in aceasta lectie.

Animatia in Flash (si in general) se realizeaza prin derularea de mai multe cadre (Frames) cu imagini succesive, obtinundu-se "iluzia" de miscare.
Animatia poate fi creata cadru cu cadru (frame by frame), aceasta modalitate fiind mai rar folosita deoarece este ineficienta ca timp si lucru, obtinandu-se prin editare directa a fiecarui cadru, dar care e totusi baza animatiei si e necesar sa fie cunoscuta.

O alta metoda ce poate fi folosita este prin crearea primului si ultimului cadru dintr-o animatie, iar Flash face legatura intre ele, creand automat celelalte cadre; pentru aceasta Flash are 3 moduri: Classic Tween, Shape Tween si Motion Tween.

1. Cadre in Timeline

Instrumentul principal si de baza utilizat in Flash pentru animatie este Panoul Timeline, prezentat pe scurt in lectia Scena, Panouri si instrumente de lucru.
Acest panou contine initial o linie (un sir) cu mai multe celule, fiecare celula reprezentand un Cadru (Frame), iar fiecare cadru arata continutul unui moment specific din animatia creata in Scena.
In Timeline pot fi create mai multe astfel de linii, numite Straturi (Layers), fiecare avand propriul sir de cadre.
Cadrele sunt numerotate de la 1 (cu numerotarea afisata din 5 in 5) si pot fi de mai multe tipuri, vedeti in imaginea urmatoare, in care este reprezentat panoul Timeline si ale lui "Frames".
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· Keyframe - cu un mic cerc negru in celula, sunt cadrele cele mai importante. In ele se creaza (mai exact, in Scena, dar la acel frame) continutul direct sau de la care sa inceapa animatia. De asemenea, acestea marcheaza schimbari in animatie.

· Blank Keyframe - celula cu un mic cerc alb, e de fapt un keyframe gol la care Scena e goala, dar se afla ca un cadru gol in Timeline.

· Cadru simplu (Frame) - celula cu un dreptunghi alb in ea indica un cadru simplu, care apare la sfarsitul unui sir de cadre statice.

· Cadrul curent - Acesta este indicat printr-un dreptunghi rosu (denumit si Playhead) deasupra celulei acelui cadru (in bara de numerotare a lor) si reprezinta cadrul curent de lucru, al carui continut este afisat in Scena.

· Cadre Statice (Static Frames) - Sunt cadre ce adauga unitati de timp animatiei. Acestea nu au continut in scena, dar cu ele se mareste timpul animatiei, durata dupa care apar schimbarile facute intre doua cadre (Keyframe) sau timpul de afisare al ultimului Keyframe..

· Cadre ce nu sunt in animatie - Sunt celule care nu au definit un anume tip de Frame. O animatie dureaza pana la prima astfel de celula ce nu e in animatie.

Crearea unui Frame, indiferent de tip (Frame simplu, Keyframe sau Blank Frame) se face prin una din urmatoarele metode:
· Se da click dreapta pe celula din Timeline si se alege din optiunile: "Insert Frame", "Insert Keyframe" sau "Insert Blank Keyframe".

· Sau, click pe o celula in Timeline, apoi click pe meniul Insert -> Timeline si se alege una din optiunile: "Frame", "Keyframe" sau "Blank Keyframe".

· Cu shortcuts, se da click pe celula in Timeline si se apasa: "F5" (Frame simplu), "F6" (Keyframe) ori "F7" (Blank Keyframe).

- Cand este creat un Keyframe, in acesta se copie continutul din Kryframe-ul anterior, iar un "Blank Keyframe" creaza un cadru cu Scena goala.
- Daca un Keyframe (sau Blank Keyframe) este creat la cateva cadre distanta de alt Keyframe, intre ele se vor crea Cadre Statice.
- Cadrele pot fi trase cu mouseul si: Selectate, Mutate, Sterse, Copiate in alt loc din acel strat (Layer) sau in alte straturi. Aceste operatiuni pot fi efectuate cu optiunile: "Remove Frames", "Clear Freames", "Cut Frames", "Copy Frames" si "Paste Frames"; dupa ce se da click-dreapta pe cadru /cadre ( sau in meniul Edit -> Timeline).
- "Remove Frames" sterge complet cadrul (cadrele) din Timeline si continutul lor in Scena, pe cand, "Clear Frames" sterge doar continutul lor din scena si lasa cadrul (cadrele) gol in Timeline.
Pentru a selecta mai multe cadre continue, se da click pe cadrul de inceput, iar cu tasta "Shift" apasata se da click pe cel final, din cele care trebuie selectate.
Pentru a selecta mai multe cadre necontinue, se tine apasata tasta "Ctrl" si se da click pe cadrele respective.
Ca sa fie selectate toate cadrele dintr-un strat (Layer), se da click pe numele acelui Layer.
- Exista diferenta intre "Copy Frames"-"Paste Frames" si Copy-Paste normal. Prin "Copy Frames"-"Paste Frames" se copie si se adauga cadre in Timeline cu tot continutul lor din Scena, pe cand, cu "Copy-Paste" normal este copiat doar continutul din Scena al cadrelor.

2. Creare animatie cadru cu cadru

Crearea unei animatii cadru cu cadru (frame by frame) inseamna crearea manuala a fiecarui cadru din animatie. Se foloseste adesea in cazul animatiilor scurte.
- Cand se creaza o animatie Flash (indiferent de tip), intai trebuie avut in vedere numarul de cadre pe secunda care e setat in documentul Flash. Acest numar este initial definit in Adobe Flash la 24 FPS (Frames Per Second), se poate vedea si seta in marginea (bara) de jos a panoului Timeline (vedeti indicarea locului in imaginea de mai sus) sau in panoul Properties al Scenei, la optiunea FPS. Acesta reprezinta numarul de cadre ce sunt derulate pentru o secunda de animatie.
- Cu cat sunt cadrele Keyframe mai rare intre ele, sau FPS mai mic, cu atat animatia dureaza mai mult, dar scade acuratetea /efectul de miscare. Cu cat sunt cadrele mai dese, animatia si efectul vizual de miscare sunt mai rapide.

Iata un exemplu simplu de creare a unei animatii "cadru cu cadru", o minge care sare. (puteti vedea intai modelul prezentat mai jos, la "Animatie - Cadru cu Cadru"). Efectuati pasii urmatori:

1. Deschideti un document Flash nou, cu scena alba, alegeti instrumentul pentru desenat linii ("Line Tool", in Bara cu instrumente pt. desen) si desenati o linie in Scena.
2. Alegeti unealta pentru desenat forme rotunde (Oval Tool). Pentru ca figura ce va fi desenata (mingea) sa nu contina linie de contur, ci doar umplerea (ca sa fie mai apropiata de imaginea unei mingii), dati click pe butonul Stroke Color, apoi, in Paleta de culori, click pe butonul pt. "No Color" (in dreapta-sus).
3. Desenati pe linie un oval alungit orizontal, acesta fiind mingea.
4. In panoul Timeline dati click pe cadrul 5 si creati un Keyframe (rapid, cu tasta 'F6', sau click-dreapta pe acel cadru si alegeti optiunea Insert Keyframe). Desenele din Scena, din cadrul 1 (care e tot un Kayframe) sunt copiate in Scena la cadrul 5.
  - S-a creat Keyframe la cadrul 5, si nu la urmatorul (lasand libere cadrele 2, 3 si 4) pentru ca animatia sa nu fie prea rapida si scurta (avand in vedere rezultatul /animatia ce trebuie obtinuta).
  - Dupa crearea Keyfame-ului la cadru 5, cadrele 2, 3 si 4 sunt transformate in "Cadre Statice".
5. Alegeti instrumentul "Free Transform Tool" (pt. a modifica mingea). Intai dati click pe Scena goala ca sa fie deselectate obiectele din Scena, apoi click pe ovalul desenat ca sa-l selectati. Mariti putin ovalul pe verticala si mutati-l putin mai sus (cam jumatate din inaltimea lui). Acum animatia are 2 cadre desenate.
6. In panoul Timeline dati click pe cadrul 10 si creati un alt Keyframe (rapid, cu tasta 'F6', sau click-dreapta pe acel cadru si pe optiunea Insert Keyframe). Desenele in Scena, din Keyframe-ul anterior (cadru 5) sunt copiate in Scena la cadrul 10, iar 6, 7, 8 si 9 devin Statice.
7. Efectuati click pe Scena goala ca sa fie deselectate obiectele din Scena, apoi click pe ovalul desenat ca sa-l selectati. Mariti inca o data ovalul pe verticala (dar putin, sa nu ajunga cerc) si mutati-l putin mai sus (cam jumatate din inaltimea lui). Acum animatia are 3 cadre desenate direct, iar in total are 10.
8. Se repeta pasii 6 si 7. Dati click pe cadrul 15 din Timeline si creati un alt Keyframe. Efectuati click pe Scena goala ca sa fie deselectate obiectele din Scena, apoi click pe ovalul desenat. Mariti inca o data ovalul pe verticala (acum sa ajunga un cerc) si mutati-l putin mai sus (jumatate din inaltimea lui).
9. Efectuati click-dreapta pe cadrul 10 din Timeline si alegeti optiunea Copy Frames, apoi click-dreapta pe cadrul 20 si alegeti Paste Frames.
  - Astfel, cadru 10, cu tot continutul lui din Scena, este copiat si adaugat in cadrul 20, acesta devenind automat un Keyframe identic cu cel copiat.
10. Efectuati click-dreapta pe cadrul 5 in Timeline si alegeti optiunea Copy Frames, apoi click-dreapta pe cadrul 25 si Paste Frames.
  - Animatia are 5 cadre Keyframe create, si in total, cu cele Statice dintre ele are 25 (cam o secunda, daca FPS este 24).
11. Sa testam rezultatul obtinut. Dati click pe meniul Control -> Test Movie -> in Flash Professional. Se va deschide o fereastra in care sunt derulate cadrele din Timeline, si repetata continuu derularea. Efectul obtinut este o minge care sare pe o linie :).
  - Sunt si alte metode pentru a testa animatia facuta, vor fi prezentate mai jos.
- In prezentarea urmatoare puteti vedea acest exemplu.
- Animatie - Cadru cu Cadru
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Editarea unui Keyframe (a continutului din el) se face prin click pe celula cu acel cadru, iar in Scena apare continutul lui, care poate fi modificat.
- Marirea timpului unei animatii se poate face prin micsorarea numarului de la FPS, sau prin adaugarea de cadre simple, statice (Frames).

3. Moduri de testare a animatiei

Exista mai multe modalitati de a testa animatia creata in documentul Flash. Se poate testa intr-o fereastra separata, exact cum va fi vazuta de utilizator, sau direct in Scena de lucru. Iata in continuare diferitele moduri de testare a animatiei.

- Direct in Scena:

· Cea mai simpla metoda este prin apasarea tastei Enter (sau meniul Control -> Play), Flash va incepe derularea cadrelor in Timeline, incepand cu cel curent. Daca optiunea Control -> Loop Playback este bifata, derularea se repeta continuu, pentru a opri se apasa iar tasta Enter. Daca acea optiune nu e bifata, va derula cadrele o singura data, de la cel curent pana la ultimul.

· O alta modalitate este prin tinut apasat click pe Playhead (dreptunghiul rosu in Timeline, de deasupra celulei cadrului curent) si tragerea lui pe linia de numerotare a cadrelor.

· Se poate folosi si fereastra Controller [image: image88.jpg]CONTROLLER
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 ce poate fi deschisa din Window -> Toolbars -> Controller.


- In fereastra separata:
· Apasand tastele Ctrl+Enter (sau meniul Control -> Test Movie - in Flash Professional, ori Control -> Test Movie - Test). Se deschide o fereastra ce foloseste Flash Player, aratand animatia asa cum va putea fi vazuta de utilizator.

· O alta metoda este din meniul Control -> Test Scene, prin asta se testeaza animatia creata in scena curenta (un document Flsh poate avea mai multe Scene).

Classic Tween - Animatie

In Flash nu e necesar sa fie realizat manual fiecare Frame al unei animatii. Se poate face primul cadru si ultimul al animatiei, iar Flash va crea toate cadrele dintre ele. Acest lucru este numit "Tween". O miscare "Tween" conecteaza 2 Keyframes, fiecare cu diferite efecte si caracteristici, apoi treptat acestea sunt unite prin cadre create automat care fac gradual trecerea de la primul la ultimul Keyframe.

Classic Tween e o metoda de creare a animatiei in Flash folosita in versiunile mai vechi ale programului (inainte de Adobe Flash CS4), de la acesta a pornit noua metoda "Motion Tween", fiind oarecum asemanatoare, dar "Motion Tween" e mai usor si se pot face mai multe cu el. Prin urmare, Classic Tween va fi prezentat mai pe scurt.
- Classic Tween poate fi aplicat doar la instantele Symbols. Daca este aplicat unui desen sau text, il va transforma in "Graphic Symbol" si va fi adauga in Library cu denumirea "Tween 1", "Tween 2", etc..
- Permite scripturi in Frame.
- Se aplica unui singur element si permite animatia intre doua culori si forme diferite.
- Nu realizeaza animatie 3D.

1. Proprietati Cadre si proprietati Instante

Inainte de a trece la prezentarea modului de realizare a unei animatii Classic Tween, e necesar de fi cunoscut faptul ca exista o diferenta intre proprietatile unui cadru si proprietatile elementelor din Scena. Acestea apar in panoul Properties cand sunt selectate.
De exemplu, pentru a schimba culoarea unui desen, acesta e selectat in Scena si proprietatile care pot fi aplicate lui (cum e si pt. culoarea) apar in panoul Properties. Dar in cazul animatiei de tip Tween (care creaza automat cadrele necesare dintre 2 Keyframe) exista si optiuni ce pot fi aplicate animatiei sau cadrelor din ea, aceste optiuni, cum ar fi adaugarea unui sunet sau rotirea cadrului, apar ca proprietati in panoul Properties.
In imaginea urmatoare puteti vedea Panoul Properties pentru instanta unui Symbol si cel pentru proprietatile unui Frame dintr-o animatie Classic Tween.

- Panouri proprietati Instanta Symbol si Frame
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- Optiunile si efectele din proprietatile Frame-ului vor fi aplicate animatiei (cadrelor), pe cand cele ale unui obiect din Scena, vor fi transmise doar lui.
2. Creare animatie cu Classic Tween

Crearea unei animatii simple cu Classic Tween se face usor. In principiu se efectueaza urmatorii pasi:

1. Se creaza primul Keyframe cu elementul ce trebuie animat.

2. Se face ultimul Keyframe al animatiei, cu acelasi element si proprietatile (dimensiune, pozitie, culoare).

3. Ultimul pas, se selecteaza elementul din primul cadru si apoi click pe meniul Insert -> Classic Tween.

- Numai dupa crearea animatiei se pot efectua modificari obiectului animat (forma, culoare) si cadrelor din Timeline pentru a se obtine diferite efecte.
Ca sa invatati, incercati urmatorul exemplu, in care se realizeaza efectul animat de ridicare si disparitie a unui balon.
1. Deschideti un document Flash nou, alegeti instrumentul pentru desenat figuri ovale (Oval Tool).
2. Desenati in partea de jos-stanga a Scenei un oval, apoi alegeti si instrumentul pt. desenat cu creionul (Pencil Tool) si desenati ovalului o codita (acesta reprezinta balonul).
3. Selectati cadrul 40 din Timeline si transformati-l in Keyframe (click pe el si apasati tasta 'F6', sau click-dreapta pe cadru si optiunea Insert Keyframe). In acest Frame este copiata Scena de la primul Frame, cu desenele din ea.
  - FPS fiind setat 24, daca animatia e de la cadrul 1 la 40, va dura aproape 2 secunde.
4. La cadrul 40 mutati balonul si codita lui, asa cum sunt, in partea dreapta-sus a scenei (prin selectarea uneltei Select Tool si tragerea desenelor cu mouse-ul, fiind impreuna selectate).
5. Acum se va crea efectul de miscare dintre cele 2 cadre. Dati click pe primul cadru si apoi pe meniul Insert -> Classic Tween.
Observati ca in Timeline, a aparut o sageata de la primul cadru la 40. Aceasta indica faptul ca intre ele este o animatie "Classic Tween".
  - Daca verificati in panoul Library veti gasi adaugate 2 Graphic Symbols, create de Flash pentru elementele animatiei din primul si ultimul Keyframe, transformand desenele cu balonul din scena in instante ale acestor 2 Symbols.
6. Acum animatia este facuta. Ca sa o testati rapid, apasati tasta Enter.
7. Pentru a adauga si efectul de disparitie al balonului, pe langa cel de miscare, selectati balonul de la ultimul cadru (40) si din Panoul Properties, la Color Effects, laStyle alegeti optiunea Alpha (pentru transparenta) si dati-i o valoare cat mai mica (de ex. 1 sau 2). Balonul a devenit complet transparent.
Testati efectul obtinut apasand tasta "Enter".
8. Sa testam si adaugarea unui efect animatiei, prin modificarea proprietatilor cadrelor. Dati click pe un cadru dintre primul si ultimul, sau selectati toate cadrele pana la penultimul [39] (prin dublu-click pe primul Frame, sau click pe el si cu "Shift" apasat dati click pe cadrul 39 (nu 40)). In panoul Properties vor apare proprietatile pentru cadre. La Tweening, la proprietatea Rotate alegeti optiunea CCW (rotire in sens invers acelor de ceasornic).
Apasati inca o data "Enter" ca sa vedeti efectul obtinut.

- Animatie - Classic Tween
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3. Ajustare proprietati Classic Tween

In exemplul de mai sus e folosita una din proprietatile ce apartin cadrelor, si anume "Rotation". Mai sunt si altele, acestea apar in panoul Properties cand e selectat un cadru dintr-o animatie "Tween"; le puteti vedea in imaginea de la inceputul lectiei. Iata pe scurt ce fac acestea:

· Ease - Incetineste sau accelereaza animatia pe parcursul derularii ei, de la primul la ultimul Keyframe.
- Daca valoarea e pozitiva, cu cat este mai mare cu atat viteza de miscare a animatiei e mai mare la inceput si scade in timp ce se apropie de ultimul Frame. Si invers, daca valoarea e negativa viteza creste accelerat spre ultimul cadru.
- Butonul "Edit Easing", din dreptul optiunii, permite personalizarea modului de accelerare a miscarii.

· Rotate - Determina rotirea obiectului animat: CW (in sensul orelor de ceas), CCW (in sens invers orelor de ceas) . De la valoarea numerica din dreptul ei se seteaza numarul de rotiri.

· Snap - Verifica sa fixeze punctul de inregistrare a obiectului la o miscare cu "motion guide".

· Sync - Sincronizeaza animatia continuta in cadrul unui Symbol cu Timeline-ul ce o contine.

· Orient to Path - Se foloseste cand e aplicat un Strat (Layer) cu "motion guide". Aceasta pastreaza obiectul paralel cu "motion guide", relativ la punctul lui central.

· Scale - Se bifeaza cand sunt animate schimbari de dimensiune si forma.

Copiere animatie Tween

O Animatie Tween poate fi copiata la un alt Symbol ne-animat, cu toate proprietatile ei si ale obiectului animat. Acesta trebuie sa se afle pe acelasi strat, dar intr-un Keyframe din afara animatiei.
Copierea se realizeaza astfel:

· Se selecteaza animatia ce trebuie copiata (cadrele ei din Timeline).

· Se da click pe meniul Edit -> Timeline -> Copy Motion.

· Selectati Simbolul la care trebuie adaugata animatia si apelati meniul Edit -> Timeline -> Paste Motion.

- Pentru a alege proprietatile din animatia copiata care sa fie transferate Simbolului, in loc de "Paste motion" se alege Paste Motion Special.
La "Classic Tween" se poate inversa doar animatia intreaga (cu toate cadrele). Acest lucru se realizeaza prin selectarea tuturor cadrelor animatiei (click pe numele acelui strat [Layer]) si se da click pe Modify -> Timeline -> Reverse Frames.
- Cadrele din animatiile "Tween", care au fost create automat de Flash, pot fi convertite in Keyframe (sau Blank Keyframe). Se selecteaza cadrele ce trebuie convertite si se alege meniulModify -Timeline -> Convert to Keyframes (sau "Convert to Blank Keyframes").
- Pentru a sterge /anula o animatie Tween, se da click pe un Frame al ei, apoi click pe meniul Insert -> Remove Tween.

Motion Tween - Animatie

Motion Tween permite realizarea unor efecte de miscare si transformare fluenta, precum: dimensiuni, pozitie, rotatie, culoare; care se aplica doar Instantelor de Symbol (Movie Clip, Graphic si Button).
Produce fisierul cu cele mai mici dimensiuni dintre toate metodele de animatie Flash.
Reguli pentru Motion Tween:
- Nu permite scripturi in Frame.
- Nu transforma textul in Symbol.
- Aplica un singur efect de culoare pt. fiecare "Tween".
- Foloseste numai o singura Instanta pe parcursul tuturor cadrelor animatiei respective.
- Permite un singur obiect (Instanta) in Keyframe-ul la care se aplica Motion Tween.
- Permite animatie 3D.
- Transforma tipurile de obiecte nepermise lui (forme, imagini, grupuri) in Simboluri Movie Clip.
- Lungimea unei animatii, cadrele din ea, sunt tratate ca un singur obiect care poate fi redimensionat, dar in acele cadre, in Scena, nu mai pot fi create alte elemente.

1. Creare animatie cu motion Tween

Primul pas in crearea unei animatii cu Motion Tween este convertirea elementului asupra caruia se face animatia in Symbol.
Apoi, cu acesta selectat, se da click pe meniul Insert -> Motion Tween. Flash va crea automat in panoul Timeline un numar de cadre egal cu cel setat la FPS pentru animatia Motion Tween. Aceste cadre sunt considerate ca un obiect ce poate fi extins si micsorat prin tragere cu mouse-ul, marind sau scazand astfel numarul de cadre din animatie.
Dupa acest pas, Flash muta Scena de lucru la ultimul Frame. Aici se definesc proprietatile elementului (pozitie, dimensiuni, culoare), dupa cum doriti sa arate la finalul animatiei. Dupa ce e mutat, in Scena apare o linie cu puncte reprezentand traictoria de miscare. Aceasta poate fi mutata si modificata liber, folosind mouse-ul si diferite tehnici (aratate mai jos), obtinandu-se o traictorie de miscare dupa forma acelei linii. 
- Fiecare punct de pe traictorie reprezinta un Frame din animatie.
Iata un exemplu din care puteti invata cum se creaza o animatie motion simpla.

1. Deschideti un document Flash nou, cu scena alba, alegeti instrumentul pentru desenat forme ovale (Oval Tool) si desenati un oval in partea stanga in Scena.
2. Cu desenul selectat click pe meniul Modify -> Convert to Symbol, la Type alegeti Movie Clip (poate fi ales si alt tip de Symbol) si dati OK.
3. Desenul (acum Instanta Symbol) fiind in continuare selectat, dati click pe Insert -> Motion Tween. Flash va crea in Timeline cadrele de animatie Tween pt. desen (primele 24, dupa numarul de la FPS)
Observati ca Playhead (dreptunghiul rosu de deasupra cadrelor, indicand cadrul curent de lucru) este pe ultimul Frame (24).
4. Pozitionati mouseul pe linia de margine a ultimului cadru Tween (cand acesta capata aspectul unei sageti duble) si trageti linia pana la celula 40. Astfel se mareste numarul de cadre (si timpul) din animatie.
5. Alegeti instrumentul pt. selectare (Selection Tool) si cu acesta mutati /trageti ovalul in partea dreapta a scenei.
Observati linia punctata care apare intre pozitia initiala si cea in care se afla acum ovalul. Aceasta arata traictoria de miscare.
6. Cu ovalul selectat, adaugati-i un efect de culoare, de exemplu "Tint" (din panoul Properties -> Color Effect -> Style)
7. Acum sa modificam traictoria. Dati click pe un loc gol din Scena (pt. a deselecta tot) si pozitionati mouse-ul pe linie (cand langa sageata apare un arc de cerc), apoi tineti apasat click si trageti punctul liniei, formand o traictorie curba.
  - Puteti apasa Enter pt. a vedea efectul obtinut.
8. Dati click pe traictorie pt. a o selecta (va apare putin mai ingrosata). Apoi tineti iar apasat click pe ea si mutati mouse-ul. Astfel se muta traictoria cu totul in Scena.
9. Alegeti instrumentul "Free Transform Tool" si apasati click pe traictorie. Fiind selectata cu "Free Transform", o puteti roti si redimensiona.
  - Modificati cu "Free Transform" si ovalul, separat, si testati animatia.
- In prezentarea urmatoare puteti vedea cum se face acest exemplu.
- Animatie Motion Tween
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 - Pana aici, Motion Tween pare la fel cu "Classic Tween", dar "Motion Tween" are cateva optiuni prin care se pot realiza mai multe efecte animatiei, in special legat de traictorie. Cele mai folosite din accestea sunt prezentate mai jos.
2. Editare animatie Motion Tween

1. Editare traictorie miscare
  - Traictoria (calea) de miscare a obiectului (forma ei) se modifica prin tragere cu mouse-ul a unui punct de pe ea (fiind deselectata), sau prin schimarea valorilor Xsi Y ale obiectului animat, din panoul Properties; ori tragerea lui cu mouse-ul in Scena.
  - Prin tragerea liniei cu mouse-ul aceasta se curbeaza. Dar daca se doreste obtinerea unei traictorii cu unghi, se aplica urmatorii pasi:
· Se da click pe cadrul din Timeline unde trebuie format unghiul traictoriei

· Se selecteaza obiectul in Scena si se muta cu mouseul, ori se modifica valoarea lui 'Y' (sau 'X', daca linia nu e orizontala) din Properties

- Se va obtine o traictorie in forma de unghi (dupa cum e si in imaginea urmatoare), iar cadrul respectiv din Timeline va fi transformat in Keyframe.
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2. Mutare cale de miscare
  - Pentru a muta cu totul calea de miscare, se alege instrumentul Selection Tool, se da o data click intr-un loc pe traictorie, cand aceasta va apare selectata (putin mai ingrosata) se tine apasat click pe ea si se trage cu mouse-ul.

3. Creare Keyframe:
  - Prin adaugarea unui Keyframe se creaza in interiorul animatiei un cadru (un punct de control) de la care obiectul sau traictoria pot fi modificae in Scena.
  - Sectorul animatiei (cadrele ei din Timeline) fiind considerat ca un singur obiect, nu se pot adauga cadre sau Keyframe prin metoda "Insert". Pentru Motion Tween exista alte metode de a face un keyframe in interiorul animatie. Metoda cea mai usoara de a crea un keyframe in sectorul animatiei este urmatoarea:
· Se da click pe pozitia acelui Frame in Timeline (dreptunghiul rosu sa apara deasupra lui)

· Cu obiectul selectat in Scena, se fac modificarile dorite, sau o mica schimbare a pozitiei lui, dupa care se poate reveni la loc (keyframe-ul fiind creat).

  - Dupa prima modificare a uneia din proprietatile obiectului (oricat de mica), in acel loc din Timeline apare un mic romb, indicand ca acolo este un keyframe.

4. Adaugare curbe la traictorie
  - Curbele pe calea de miscare se fac prin tragere cu mouse-ul (cu Selection Tool) a unuia din punctele de pe traictorie, cand aceasta e deselectata, in dreptul sagetii cursorului apare un arc de cerc (daca e selectata va fi mutata cu totul).
  - O curba se poate crea intre un keyframe si ultimul cadru sau intre 2 keyframe. De exemplu, pentru ca traictoria sa aiba o forma de "S" (doua curbe, cum apare in imaginea urmatoare) trebuie adaugat un keyframe intre primul si ultimul (in locul in care se schimba curbele).
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5. Adaugare traictorie facuta separat
  - In Motion Tween se poate crea o traictorie de miscare ce a fost facuta /desenata separat (in afara animatiei) cu un instrument de desen (creion, stilou, linie). Metoda e urmatoarea:
· Se deseneaza cu creionul (stiloul sau linie), intr-un cadru din afara animatiei, o linie continua cu orice forma pt. traictoriei.

· Cu Selection Tool se selecteaza desenul facut si se copie (Ctrl+C sau meniul Edit -> Copy)

· Se da click pe un cadru din Motion Tween si se apasa "Ctrl+V" (sau Edit -> Paste in Center)

- Traictoria initiala va fi inlocuita cu desenul facut si copiat, dupa cum se vede si in imaginea urmatoare.
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6. Selectare si copiere cadre
  - Pentru a selecta o portiune (o anumita zona) din lungimea animatiei, se tin apasate tasta "Ctrl" si mouseul pe primul cadru din sirul ce trebuie selectat si asa se trage cadrul pana la ultimul care sa fie selectat (acele cadre vor capata o culoare mai inchisa).
  - Ca sa fie copiata portiunea selectata, se da click-dreapta pe ea si se alege Copy Frames. Iar la cadrul unde trebuie adaugat ce s-a copiat (trebuie sa fie o celula din afara animatiei, prima de la sfarsitul ei), se da click-dreapta si Paste Frames. Astfel, va fi creata inca o animatie Motion Tween, dupa prima, si cu zona selectata din ea.

7. Copiere proprietati de la un Keyframe la alt Frame.
  - Iata cum pot fi copiate proprietatile de la un Keyframe la un alt cadru din animatie:
· Se selecteaza keyframe-ul cu proprietatile ce trebuie copiate (Ctrl+click pe cadru), se da click-dreapta pe el si se alege Copy Properties
· Se selecteaza Cadrul la care trebuie adaugate (Ctrl+click pe cadru), se da click-dreapta pe el si se alege Paste Properties
- Vor fi copiate proprietatile: Position, Rotation, Scale, Skew, Color Effects si Filtres. Pentru a copia dor anumite proprietati din acestea, in loc de "Paste Properties" alegeti Paste Properties Special (se va deschide o fereastra cu proprietatile ce pot fi selectate).

8. Inversare animatie
- Inversarea se aplica intregii animatii. Se da click-dreapta pe un Frame din ea si se alege Reverse Frames. Primul Keyframe si cel de la sfarsit vor schimba locurile intre ei.

• Ca si la "Classic Tween" (vedeti lectia anterioara), cand e selectat in Timeline un cadru al animatiei, in panoul Properties apar proprietatile cu diferite efecte ce pot fi aplicate animatiei (acestea fiind diferite de proprietatile obiectului, cand e selectat), acestea sunt:
· Ease - Incetineste sau accelereaza animatia pe parcursul derularii ei, de la primul la ultimul Keyframe.
- Daca valoarea e pozitiva, cu cat este mai mare cu atat viteza de miscare a animatiei e mai mare la inceput si scade in timp ce se apropie de ultimul Frame. Si invers, daca valoarea e negativa viteza creste accelerat spre ultimul cadru.

· Rotate - Determina rotirea obiectului animat: CW (in sensul orelor de ceas), CCW (in sens invers orelor de ceas).
- De la valoarea numerica (time(s)) din dreptul ei se seteaza numarul de rotiri, si alaturi, la semnul "+" se defineste unghiul de rotatie.

· Option -> Sync graphic symbols - Sincronizeaza animatia continuta in cadrul unui Symbol cu Timeline-ul ce o contine.

· Path - Se definesc dimensiunile si pozitia traictoriei.

In Adobe Flash exista un panou special pentru lucrul cu "Motion Tween". Este denumit Motion Editor, se gaseste de obicei langa Timeline sau poate fi deschis din meniul Window -> Motion Editor. In acest panou se gasesc grupate proprietatile si efectele ce pot fi aplicate unei animatii Motion Tween si obiectului din ea, precum: adaugare /stergere cadru, adaugare efecte culoare, pozitionare.

Pentru a anima un Symbol, acela trebuie sa fie singurul Symbol in animatia Tween creata.
Daca se doreste doua Simboluri animate in acelasi timp in document, se creaza inca un Strat (Layer) si in acela se pune al doilea Symbol si animatia lui Tween.

Shape Tween - Animatie

Scopul animatiei Shape Tween este sa transforme prin miscari treptate forma geometrica a unui obiect in alta forma. Cum ar fi de exemplu un dreptunghi intr-un cerc.
Pe langa schimbarea formei se pot anima si alte schimbari, cum sunt: pozitia, dimensiunea si efecte de culoare.
Reguli pentru aplicare Shape Tween
  - Spre deosebire de "Motion Tween", Shape Tween se aplica elementelor a caror forma poate fi editata in Scena: obiecte si forme.
  - Nu se aplica grupurilor si nici elementelor din Grup.
  - Pentru a aplica Shape tweening unui Symbol, trebuie intai sa se intre in pagina de editare a lui si acolo sa fie adaugat Shape Tween.
  - Shape Tween permite crearea de noi elemente in Keyframe-uri din sectorul animatiei.
  - Pot fi animate mai multe obiecte in acelasi Tween.
  - Pentru a adauga Shape Tween la un text, trebuie intai "rupt" textul cu "Break Apart" (din Modify -> Break Apart).

1. Creare animatie Shape Tween

Animatia Shape Tween este cel mai simplu de facut dintre tipurile de animatie Flash, pasii sunt urmatorii:
1. Se creaza primul si ultimul Keyframe.
2. Pe un Frame dintre ele se da click-dreapta si se alege Create Shape Tween (sau din meniul Insert -> Shape Tween).
- Flash va crea animatia si cadrele de imbinare /transformare "Shape" intre obiectele din primul si ultimul Keyframe, iar ca indicator va adauga in Timeline o sageata intre cele 2 Keyframe.
- In comparatie cu "Motion Tween", animatia Shape Tween pare mai spectaculoasa ca efect, dar fisierele produse cu ea au dimensiuni mai mari.

Iata un exemplu de creare a unei animatii simple Shape Tween. Se efectueaza urmatorii pasi.

1. Deschideti un document Flash nou, alegeti instrumentul pentru desen "Rectangle Tool" si desenati un dreptunghi in partea stanga in Scena.
2. Dati click dreapta pe un cadru mai departat din Timeline (de ex. 41) si alegeti Insert Blank Keyframe.
La acel Frame va fi creata o Scena goala, si intre el si primul Flash adauga Cadre Statice.
3. Alegeti instrumentul pentru desenat figuri ovale (Oval Tool), schimbati culoarea de umplere (de la Fill Color) si in Scena de la acest Keyframe (41) desenati cate un cerc in colturile din dreapta (sus si jos). La al doilea cerc schimbati-i culoarea, de la "Fill Color" din Properties.
4. Dati click-dreapta pe un cadru oarecare dintre primul si cel creat (41) si alegeti Create Shape Tween.
Acum animatia este creata, observati sageata adaugata in Timeline, intre primul si ultimul Keyframe.
-   Cadrul curent devine cel pe care s-a dat click-dreapta, iar in Scena apare cum arata animatia la momentul acelui Frame.
5. Apasati tasta Enter (sau meniul Control -> Test Movie -> in Flash Professional) pentru a vedea aceasta animatie.

- In prezentarea urmatoare puteti vedea cum se face acest exemplu.
- Animatie Shape Tween
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Dupa ce animatia este facuta, pot fi create Keyframe-uri intre primul si ultimul, prin click-dreapta pe cadru si apoi Convert to Keyframe (sau Insert Keyframe).
La fiecare Keyframe elementele din Scena devin editabile si pot fi adaugate diferite efecte si modificari obiectelor, din proprietatile lor cand sunt selectate (schimbare dimensiuni, forma si rotatie cu "Free Transform", pozitie si culoare).

Deoarece "Shape tweening" se aplica formelor editabile, nu pot fi adaugate efecte de culoare "Filters" (care pot fi adaugate Instantelor Symbol), doar cele de la "Color Effects"

Animatiei, sau unei portiuni de cadre selectate din ea, pot fi modificate proprietatile Ease si Blend (care apar in panoul Properties cand acestea sun selectate).
· Ease - Incetineste sau accelereaza animatia pe parcursul derularii ei, de la primul la ultimul Keyframe.
- Daca valoarea e pozitiva, cu cat este mai mare cu atat viteza de miscare a animatiei e mai mare la inceput si scade in timp ce se apropie de ultimul Frame. Si invers, daca valoarea e negativa viteza creste accelerat spre ultimul cadru.

· Blend - Are 2 optiuni:

· Distributive - creaza o transformare lina a formei si colturilor in timpul animatiei.

· Angular - face transformarea colturilor de la forma initiala pana la ultima selectata mai unghilare in procesul animatiei.

- Pentru a anula un Keyframe din Spape Tween, se da click-dreapta pe acel keyframe din Timeline si se alege Clear Frames.
- Pentru a adauga alte cadre statice in animatie, se da click-dreapta pe un Frame din ea si apoi Insert Frame.
- Cadrele se sterg complet din animatie cu optiunea Remove Frames.
2. Shape Hints

Cu cat formele animate sunt mai simple cu atat efectul de transformare este mai clar si frumos. Cand formele sunt complexe (cum ar fi text sau desen cu multe elemente si colturi), animatia dintre primul si ultimul Keyframe devine mai putin coerenta, ceva amestecat; Flash neputand crea o schimbare animata clara. Pentru aceasta se foloseste "Shape Hints", (sugestii /indicii pt. forma) prin care se poate exercita un control mai mare asupra procesului de transformare.
Shape Hints determina /ghideaza Flash cum sa deseneze cadrele interne, dandu-i indicatii care zone din forma primara sa fie transformate in alte zone precizate in forma finala. Ideea de baza este sa se indice un loc din forma initiala a obiectului si in urmatorul keyframe sa fie precizata (cu acelasi tip de indicator) locatia din obiect ce trebuie sa corespunda ca transformare pentru locul indicat la inceput.
Pasii pentru adaugare Shape Hints sunt urmatorii:

1. Se da click pe Keyframe-ul initial, unde trebuie create Shape Hints ("Playhead", adica dreptunghiul rosu sa apara deasupra lui).

2. Click pe meniul Modify -> Shape -> Add Shape Hint.
- Va apare in centrul desenului un mic cerc rosu cu litera "a" in el ("Shape Hints" apar in ordine alfabetica, "a", "b", "c" ...).

3. Se tine apasat click pe cerculet si se muta in locul /zona din desen care va fi controlata prin el (vedeti imaginea de mai jos).

4. Click pe Keyframe-ul final, la care va fi setata locatia de transformare pt. zona indicata de cerculetul rosu.
Si in centrul desenului aflat in Scena de la acest cadru va apare un mic cerc rosu cu litera "a". Acesta este corespondentul celui creat la forma initiala.

5. Se muta cu mouse-ul acest cerculet in locatia din obiectul final, unde se doreste sa corespunda la transformare cu cea controlata de primul cerculet.

6. Se alege iar primul Keyframe si se repeta pasii 2, 3, 4 si 5 pentru creare si adaugare Shape Hint.
Se adauga cate sunt nevoie, in functie de cate zone trebuie controlate, tinandu-se cont ca "a" initial corespunde cu "a" final, "b" cu "b", si tot asa.
- Se apasa Enter pentru testare animatie
- Creare Shape Hint
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- Shape Hint se creaza mereu de la primul cadru al animatiei.
- In imaginea urmatoare se poate vedea diferenta de transformare dintre cadre, la aceeasi animatie cu si fara Shape Hint.
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- Pentru a sterge un Cerculet Shape Hint, se da click-dreapta pe el, apoi Remove Hint.
- Pentru a sterge toate Shape Hints, se da click dreapta pe unul din ele si se alege Remove All Hints (sau din meniul Modify -> Shape -> Remove All Hints).
Se recomanda plasarea cerculetelor Shape Hints consecutive, in sensul, sau invers orelor de ceas; altfel, Flash ar putea da rezultate neasteptate.
Este indicat sa se evite Motion Tween cu forme create cu instrumente "Primitive".
- Pentru a vedea toate controalele Shape Hints adaugate, se da click pe meniul View -> Show Shape Hints.

 Creare multiframe Symbols

De cele mai multe ori se creaza obiecte Symbol din elemente aflate in Scena, in afara de aceasta, se pot face Simboluri care sa contina cadre de animatie. De exemplu, se poate crea Symbol din cadrele selectate ale unei animatii Motion Tween si se obtine un Multiframe Symbol , adica un element Symbol adaugat in Library si care va contine animatia selectata.
Avantajul este atunci cand acea portiune de animatie trebuie folosita de mai multe ori, iar ca Symbol poate fi usor adaugata prin Instantele lui, si in plus, fisierul rezultat va avea dimensiuni mai mici decat prin direct Copy-Paste (copiere si adaugare) cadre.
Procedeul pentru crearea unui multiframe Symbol e urmatorul:

1. Se selecteaza in Timeline cadrele din animatie care vor fi adaugate in Symbol. Selectarea unui sir continuu se face tinand apasata tasta Ctrl si cu mouse-ul se tine apasat pe primul cadru ce trebuie selectat si se trage pana la ultimul.
  - Procedeul se foloseste direct doar pentru animatii Motion Tween, la celelalte tipuri de animatie (classic, shape) cadrele selectate trebuie mai intai convertite in Keyframe (prin click-dreapta pe ele si apoi Convert to Keyframes).
2. Se copie aceste cadre, prin click pe meniul Edit -> Timeline -> Copy Frames (sau click-dreapta pe ele si Copy Frames).

3. Click pe meniul Insert -> New Symbol, se va deschide fereastra pentru Simboluri noi. Aici poate fi specificat un nume si se alege tipul simbolului (pt. multiframe in general se foloseste "Movie Clip" sau "Graphic"), apoi se apasa OK.

4. In Scena apare pagina (goala) de editare a simbolului creat.

· Daca s-a ales tipul "Movie Clip", se apasa click-dreapta pe primul Frame si se alege Paste Frames.

· Daca s-a ales "Graphic", intai trebuie selectate un numar de cadre egal sau mai mare decat cele copiate din animatie, apoi, click-dreapta pe ele si se alege Paste Frames.
  - In cazul tipului Graphic, daca se face "Paste Frames" pe un numar de cadre mai mic decat cele copiate, vor fi adaugate atatea cadre cate reprezinta numarul celor selectate din Timeline-ul Graphic Symbol.
In Library va apare imaginea in care se vede continutul Symbolului, aceasta are in coltul din dreapta sus un buton mic (triunghi) pt. Play (dupa cum puteti observa in imaginea de mai jos); prin apasarea lui poate fi vazuta animatia din Symbol.
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5. Dupa adaugarea cadrelor cu animatia copiata, Simbolul Multiframe este creat. Se iese din pagina de editare a lui, prin click pe numele Scenei (sau din meniul Edit -> Edit Document).

Creare Instanta Multiframe Symbol

O Instanta a unui Symbol multiframe se creaza la fel ca si Instantele obisnuite, adica prin tragerea lor din Library in Scena, dar la Multiframe trebuie avute in vedere cadrele din Timeline.
Procedeul e urmatorul:

1. Se selecteaza Keyframe-ul la care va fi adaugata Instanta.
  - Daca se incearca plasarea intr-un Frame simplu, Flash va adauga Simbolul in primul Keyframe anterior aceluia.
Daca Simbolul e de tip Graphic, trebuie ca numarul de Frames (normale sau blank keyframe) dupa acel Keyframe (inclusiv el) sa fie egal cu cel din animatia Multiframe Symbol. Daca e mai mic, vor fi adaugate cate cadre din animatie incap; iar daca e mai mare, va repeta animatia de cate ori poate pana ajunge la ultimul.

2. Keyframe-ul fiind selectat, se tine apasat click pe Simbolul din Library si se trage in Scena.

- In cazul cand Simbolul multiframe e de tip "Movie Clip", animatia din el e adaugata in Keyframe-ul ales, nu mai e nevoie de alte cadre dupa el si nici sa se tina cont de numarul cadrelor animatiei din el; de aceea e de preferat tipul Movie Clip.

Editarea si stergerea unui Multiframe Symbol se face la fel ca la celelalte tipuri, din panoul Library (dublu-click pe Symbol pt. editare, iar pentru stergere, click pe el si apoi tasta "Del"[vor fi sterse toate instantele lui]).

Adaugare sunete si efecte audio in Flash

Pe langa imagini, sau animatie, sunetele creaza efecte audio care atrag mereu atentia.
In Flash, sunetele se adauga in cadrele din Timeline, dupa ce fisierul audio a fost adaugat /importat in panoul Library.
Pot fi folosite sunete din Libraria de Sunete integrata in aplicatia Adobe Flash sau pot fi importate din directoarele dv. personale din calculator (prin meniul File -> Import -> Import to Library). Sunt recunoscute tipurile de fisiere audio: MP3, WAV, AU, ASND (obtinut cu Adobe's Soundbooth).
Sunetele pot fi utilizate in doua moduri: event si stream.
  - Cu Event, sunetele trebuie incarcate complet inainte de a incepe transmiterea lor.
  - Un sunet cu Stream incepe imediat ce au fost incarcate primele cadre.
Sunetele adaugate in documentul Flash (importate sau luate din Libraria de sunete a programului) sunt incluse in document si in fisierele ".swf" exportate. Daca in continutul Flash este adaugat de exemplu un fisier audio ".mp3", cand acesta este exportat in format SWF (care poate fi inclus in pagini web), fisierul ".swf" rezultat va contine si pe cel ".mp3". Partea buna e ca totul va fi inclus si simplu de transmis intr-un singur fisier, dar si marimea acestuia va creste.

Dupa ce sunetele sunt incluse in Library, e un lucru simplu sa fie adaugate in Timeline, prin panoul Properties al cadrelor (vedeti imaginea de mai jos). Se da click pe cadrul unde trebuie inclus sunetul, apoi, in Properties, la Sound, la optiunea Name se alege sunetul respectiv.
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- Dupa cum puteti observa, mai sunt si alte optiuni; acestea se folosesc pentru un anumit control al sunetului in continutul Flash. Iata ce fac fiecare:

- La Name apare o lista cu sunetele incluse in Library si poate fi ales oricare din ele.
- La Synk
· Event - Da sunetului propriul Timeline. Adica, flash transmite sunetul pana ascesta ajunge la sfarsit, chiar daca animatia s-a terminat sau mai este executat inca o data. Daca se repeta efectul care a generat sunetul, acesta va fi trsansmis peste cel curent, care continua pana se termina.

· Start - Similar cu "Event", dar nu transmite aceasi sunet daca animatia se repeta si primul nu a terminat; nu suprapune acelasi efect audio.

· Stop - Spune aplicatiei Flash sa opreasca sunetul.

· Stream - Syncronizeaza /Potriveste animatia si sunetul pe cat posibil in momentul derularii lor, sa fie ambele in acelasi timp (Timeline). De exemplu, daca datorita performantei calculatorului, animatia este rulata mai incet iar sunetul transmis normal, pentru ca animatia sa nu ramana in urma, Flash va sari peste cadre din ea ca sa fie la acelasi cadru din Timeline la care a ajuns sunetul.


- La Effect
· Left channed - Transmite sunetul mono, pe boxa stanga.

· Right channed - Transmite sunetul mono, pe boxa dreapta.

· Fade Left to Right - Sunetul e transmis la inceput in boxa stanga, iar de la mijloc in dreapta.

· Fade Right to Left - Sunetul e transmis la inceput in boxa dreapta, iar de la mijloc in stanga.

· Fate in - Incepe sunetul incet si pe parcurs isi mareste volumul.

· Fate out - Incepe sunetul la volum mare si pe parcurs il incetineste.

· Custom - Deschide o fereastra in care efectul poate fi definit liber (vedeti mai jos imaginea de la "Fereastra efecte sunet").

- La Repeat se defineste numarul de repetari (initial 1), iar Loop determina repetarea continua pana la oprirea intentionata.

Iata pas cu pas un exemplu cat mai simplu prin care puteti invata cum se adauga sunet in continutul Flash, care poate fi auzit de utilizator (va fi folosit un sunet din libraria programului Flash.).
1. Deschideti un document Flash nou. Intai sa adaugam in panoul Library sunetul din Libraria Flash. Deschideti panoul Library (Ctrl+L), apoi click pe meniul Window -> Common Libraries -> Sounds si din fereastra ce se deschide (precum cea din imaginea urmatoare) trageti cu mouse-ul un sunet in Library (de ex. "Underwater Water Ambience Fish Aquarium Filter Bubbles 01.mp3").
  - Sau puteti Importa un fisier audio din calculatorul dv., apasand "Ctrl+R" (sau din meniul File -> Import -> Import to Library).
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  - Puteti testa sunetele prin click pe ele si pe butonul "Play" (triunghiul din dreapta-sus).
2. Acum se adauga acel sunet in primul cadru (chiar daca Scena e goala, nu conteaza, mai ales pentru teste). Click pe acel cadru, in panoul Properties (daca nu e deschis apasati "Ctrl+F3") apar optiunile lui (precum in imaginea de sus, de la inceput). La Sound dati click pe lista de optiuni de la Name si alegeti sunetul adaugat.
- Apasati "Ctrl+Enter" ca sa vedeti (auziti) rezultatul obtinut.
3. Modificati proprietatile de la Effect, la Repeat puneti 3, incercati si Loop, asa invatati rolul lor.

- Similar, sunetele pot fi adaugate in cadre din animatii sau la butoane (Button Symblos), vedeti si tutorialul Adaugare Sunete in Butoane.
- Pentru a opri sunetul se efectueaza urmatorii 2 pasi:
1. Se da click pe cadrul unde trebuie oprit sunetul. Daca este o celula goala sau un Frame Static simplu, se transforma in "Blank Keyframe" (prin click-dreapta pe el si Insert Blank Keyframe).

2. In panoul Properties pentru acel cadru, la Sound -> Name se alege sunetul care trebuie oprit, iar la Sync se pune optiunea Stop.

Adaugare sunet la animatia Motion Tween

Cadrele din animatia "Motion Tween" nu au in Properties optiunea de adaugare sunet. Pentru a adauga sunete in animatia "Motion Tween" trebuie creat inca un "Layer" si se adauga sunetele in cadrele acelui Strat, paralel cu animatia. Pasii ce trebuie efectuati sunt urmatorii:
1. Se creaza un Strat nou - click pe meniul Insert -> Timeline -> Layer (noul Strat va fi adaugat deasupra).

2. In acest Strat se alege Cadrul de la care sa inceapa animatia si se face "Blank Keyframe" (Keyframe gol) - prin click-dreapta pe el si "Insert Blank Keyframe".

3. In panoul Roperties al acelui cadru se adauga sunetul.

- Astfel, sunetul va fi transmis incepand de la acel Keyframe gol, paralel cu animatia. In Timeline va apare similar cu imaginea de mai jos.
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- In imagine, pe "Layer 1" e animatia Motion Tween, pe "Layer 2" este sunetul adaugat la cadrul 11.
Editare efecte

In panoul Properties al cadrului cu sunet adaugat, la "Effect", daca se alege Custom (sau se da click pe butonul cu un creion pe el) se deschide o fereastra in care efectele din acea lista de optiuni (Fade In, Fade Out, ...) pot fi aplicate liber. Fereastra este precum cea din imaginea urmatoare.

- Fereastra efecte sunet
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- Se incepe cu un effect audio ales din lista de la Effect, apoi, prin click cu mouse-ul se creaza puncte de control a graficii efectului, putand modifica diferit volumul pe parcursul lui.

Comprimare sunet

Flash are cateva optiuni prin care fisierul audio adaugat poate fi comprimat pentru a mai scadea din marimea fisierului Flash exportat.
In panoul Library se da dublu-click pe sunet (sau click-dreapta si "Properties"), se va deschide o fereastra cu proprietatile fisierului audio adaugat, precum cea din imaginea urmatoare.

- Comprimare sunet
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- Prin schimbarea compresiei se modifica si calitatea sunetului, nu o poate face mai buna decat este in fisierul audio original (Adobe Flash ne fiind un editor audio), dar o poate scadea cand se reduc valorile de la "Bit Rate" si "Quality". Sub aceste optiuni apar datele despre sunetul respectiv in Flash, marimea (in imagine "175.2 KB") si compresia obtinuta (in imagine "12.5%" din original).
- Compresia cea mai indicata pt. raport calitate/marime este MP3.
- De la butonul "Update" se reincarca sunetul din locatia initiala. "Test" si "Stop" sunt pentru testare audio a sunetului.
Cand se adauga sunet intr-o animatie, trebuie tinut cont de durata sunetului pentru a fi incadrat corect in cadrele animatiei. De exemplu, daca un sunet dureaza 4 secunde, iar FPS-ul din Timeline e 24, sunetul va avea nevoie de 4x24 Frames, adica 96 cadre.

Utilizare Bone Tool

Din versiunea Adobe Flash CS4 este adaugat Bone Tool ("bone" inseamna "os" sau "schelet") care da animatorilor un mod automat de calculare Inverse Kinematics (IK). Inverse Kinematics (Cinematica inversa) inseamna calculele (algoritmul) pentru cum se misca obiecte unite.
Bone tool se foloseste pentru a crea unirea obiectelor, iar de IK se ocupa aplicatia Flash, pentru a se obtine un schelet cu parti distincte, dar unite, care pot fi miscate separat, insa pastrand legatura creata si o miscare cat mai naturala; cum ar fi zalele unui lant sau structura unui brat.
Instrumentul pentru "Bone Tool" se afla in bara cu unelte pentru desen (butonul cu imaginea unui os), cu acesta se pot conecta mai multe obiecte Symbol impreuna pentru a crea o structura mobila, un lant de efecte conectate.
- Sunt 2 tipuri diferite de legaturi care se fac cu "Bone Tool":

· Cu Symbols - care leaga mai multe elemente Symbol, formand legaturi externe.

· Cu Forme - "bones" se aplica in interiorul formelor, alcatuind un schelet intern.

- Cand se creaza legaturi cu Bones, Flash adauga un nou Layer (Strat) in Timeline pentru fiecare serie de legaturi, cu denumirea "Armature". Fiecare astfel de strat poate contine o singura serie de "bones", pe scurt, acea serie se numeste "armature".
- Fiecare "bone" are un cap si o coada. Primul "bone" dintr-o "armature" este "root bone" (osul radacina) si este identificat cu un cerc la cap.
1. Aplicare Bone Tool in interiorul formelor

Bone Tool poate fi aplicat in interiorul oricarui tip de element din Scena: obiecte, forme, linii, desene cu pensula, simboluri.
Ca sa intelegeti mai bine cum se adauga "bones" intr-o forma si ce fac acestea, efectuati urmatorul exemplu:

1. Deschideti un document Flash nou, alegeti instrumentul pentru desenat figuri ovale (Oval Tool) si desenati un oval galben, lung si subtire (ca o rama) (galben ca sa se distinga mai bine legaturile ce vor fi create).
2. Selectati Bone Tool din bara cu instrumente pentru desen. Click in marginea din stanga din oval, tineti apasat si trageti cursorul spre dreapta cativa centimetri pentru a crea primul "bone".
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3. Din acelasi loc in care ati eliberat click-ul pt. a forma primul "bone", apasati iar click si trageti cativa centimetri. Asa se creaza al doilea "bone", legat de primul.
Continuati astfel pana ajungeti in capatul din dreapta al ovalului, creand o serie de "bones".
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  - Pentru a functiona cum trebuie, ca oasele sa fie unite, inceputul fiecarui segment nou trebuie facut exact din capatul celui precedent. Ca indiciu, osul care apare langa cursor se face alb in acel punct de unire. Daca segmentul nu se formeaza din acel punct, se va incepe o serie noua de legaturi.
4. Alegeti instrumentul "Selection Tool", tineti apasat pe un "bone" si miscati in diferite sensuri; testati la fel si cu celelalte segmente si vedeti cum s-ar putea misca aceasta creatie.

- In prezentarea urmatoare este aratat modul de efectuare al acestui exemplu.
- Exemplu Bones cu Forma
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 - Trebuie avut in vedere faptul ca atunci cand forma cu "bones" este miscata in jurul ei si se lasa suprapusa, intersectia suprapunerii apare ca o zona goala, cum se poate observa in imaginea urmatoare.
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- Pentru a evita asta, ori ne asiguram ca forma nu se va suprapune pe ea insasi in contextul in care va fi folosita, ori se foloseste o legatura cu "bones" formata din Simboluri Movie Clip separate. In capitolul urmator puteti invata legatura "bones" cu Simboluri.
2. Utilizare Bone Tool cu Symbols

Pentru conectarea mai multor forme /obiecte intre ele cu Bone Tool, acestea trebuie sa fie instante de Symbol (indicat, tipul "Movie Clip").
Toate Simbolurile care vor fi conectate trebuie sa fie pe acelasi strat (Layer).
- In urmatorul exemplu este aratat modul de legare cu "Bones" a mai multor instante de Symbol si cum functioneaza rezultatul creat. Efectuati urmatorii pasi:

1. Deschideti un document Flash nou, alegeti instrumentul pentru desenat figuri ovale (Oval Tool) si desenati un cerc.
2. Transformati cercul in Movie Clip (din meniul Modify -> Convert to Symbol, si la Type: Movie Clip).
3. Din paoul Library trageti mai multe instante ale acestui Symbol si aranjati-le sa arate ca o forma umana, cum e in imaginea urmatoare.
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4.Alegeti Bone Tool din bara cu instrumente pt. desen si incepand cu capul figurii trasati "bones" conectand toate cercurile, dupa cum se observa in imaginea urmatoare.
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Metoda e urmatoarea, din centrul cercului de la cap se traseaza un "bone" pana in centrul cercului de sub el. De aici, din coada acestui prim "bone" se traseaza 3 leagaturi, spre brate si trunchi, din cel de la trunchi se fac 2 legaturi spre picioare.
  - Observati ca in Timeline este adaugat un nou strat, Armature_1, in el sunt stocate toate instantele simbolului, care formeaza figura creata cu "bones".
5. Acum jucati-va cu desenul creat, alegeti Selection Tool si miscati figura tragand de legaturi. Dati dublu-click pe o instanta (un cerc) pentru a intra in pagina de editare a Simbolului, iar cu Free Transform Tool faceti-l oval.
Reveniti la Scena principala de lucru pentru a vedea rezultatul.
Alegeti Selection Tool si cu el trageti de un oval, observati ca poate fi rotit individual in jurul cozii legaturii din el.
  - Instantele Symbol pot fi modificate si individual, direct in Scena (fara a afecta pe celelalte), cu "Free Transform Tool" si efecte de culori din panoul Properties.
- Desi aici, pentru exemplu, structura de legaturi cu "bones" a inceput de la cap, este indicat ca primul "bone" (root bone) sa fie in centrul figurii, deoarece acesta este ca un punct central de la care (sau in jurul caruia) se misca celelalte.
In prezentarea urmatoare puteti urmari realizarea pasilor 4 si 5 (crearea legaturilor, miscarea figurii, modificarea cercului in oval si rotirea individuala a unui Symbol in jurul legaturii din el).
- Exemplu Bones cu Symbol
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Se pot lega in aceeasi structura de "bones" instante a mai multor simboluri (Movie Clip si Buton), cu structuri si proprietati diferite.
- Diferenta majora intre Bones in Forme si Bones cu Symbols este faptul ca Simbolurile raman intacte, forma lor nu se modifica la efectuarea miscarii, dar la legaturile dintr-o forma miscarea este mai "organica".


- Se pot adauga oricand noi legaturi sau "oase" la o structura deja creata. Se da click pe Stratul "Armature" respectiv si se alege unealta "Bone Tool", apoi se poate adauga normal alte "bones" la cele existente.
- Pentru a sterge un "bone", se da click cu "Selection Tool" pe el si cand si-a schimbat culoarea se apasa tasta Del (Delete). Daca de acel Bone sunt si altele legate, vor fi sterse si acelea. Daca se sterge "root bone" (primul os, de inceput), va fi stearsa intreaga structura de "bones".
Animare structura cu Bones - Armature

Una din principalele facilitati date de (IK), Inverse Kinematics (Cinematica inversa), este usurinta de a anima miscarile unei structuri de "Bones", numita pe scurt Armature.
Stratul "Armature" (din Timeline) poate urmari o serie de pozitii si sa efectueze calculele necesare pentru a misca de la o pozitie (pose) la alta.
Stratul Armature are cateva optiuni specifice in panoul Properties. Daca dati click pe un Layer (Strat) Armature, veti putea accesa optiunile lui din Properties, care apare ca in imaginea urmatoare.
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· Ease -> Strength - Controleza modul in care animatia accelereaza sau incetineste pe timpul derularii ei.
- Daca valoarea e pozitiva, cu cat este mai mare cu atat viteza de miscare a animatiei e mai mare la inceput si scade in timp ce se apropie de sfarsit. Si invers, daca valoarea e negativa viteza creste accelerat spre final.

· Ease -> Type - Aici este un meniu cu mai multe tipuri de optiuni pentru "Ease": Simple (Slow) ["Simplu (incet)"], Simple (Medium) ["Simplu (Mediu)"], si altele. Denumirea lor, in engleza, este destul de sugestiva pentru rolul fiecaruia.

· Options -> Type - Aici sunt 2 optiuni:

· Authoritme - Este varianta aleasa initial. Cu aceasta, cand se creaza mai multe pozitii, Flash face animatia dintre ele.

· Runtime - Permite utilizatorului, sau unui ActionScript, sa miste structura creata. Puteti testa setand aceasta optiune pe unul din exemplele din lectia precedenta, apoi apasati "Ctrl+Enter".
· Options -> Style - Schimba aspectul legaturilor /oaselor (bones). Nu afecteaza nimic, doar modifica aspectul.

· Springs - Activeaza / Dezactiveaza posibilitatea folosirii proprietatii "Spring" care se gaseste in panoul Properties al fiecarui "bone" (prezentat la sfarsitul lectiei).

1. Creare Pose Frame si animatie la o Armature

Crearea unei animatii la o structura de legaturi cu "bones" (pe scurt, la o Armature) e mai mult arta decat stiinta. Sunt o multime de detalii ale miscarii unei Armature, cum ar fi: viteza de miscare in momente diferite, elasticitatea miscarii, aspectul de continuitate si naturalete al ei, etc.
Adobe Flash are optiuni pentru realizarea si controlul acestor proprietati si se pot realiza prin modificarea legaturilor (lungime, pozitie, rotatie) in cadrele de pozitie (Pose Frame) care se creaza in Stratul Armature (numit si "Pose Layer" [Strat de pozitie]). Acest tip de Strat are figura unei persoane in stanga numelui.
- Pose Frame este un cadru similar cu Keyframe (folosit in animatia "Motion Tween"), cadrele din animatia unei Armature pot fi manipulate asemanator cu cele din "Motion Tween" (vedeti in lectiile anterioare despre animatia Motion Tween).
- Pose Frame marcheaza un punct in Timeline unde este definita exact pozitia obiectului pozitionat.
- Intre doua "Pose Frame" Flash realizeaza singur animatia, miscarile de trecere de la unul la celalalt.

Diferenta majora dintre un "Pose Frame" si un Keyframe este aceea ca la un Pose Frame poate fi setata (modificata) doar pozitia Simbolului sau Formei cu "bones", nu se pot efectua efecte de culori sau alte proprietati.
- Solutia pentru a adauga efecte de culori la animatia unei Armature este, dupa ce a fost creata, sa fie transformata in Simbol Movie Clip.


Iata un exemplu simplu de creare animatie la o Armature, se foloseste "Exemplu Bones cu Symbol" din lectia precedenta; efectuati urmatorii pasi:
  [image: image112.jpg]PRoreRTEs
E St L El K Armature
m
T
Strength: 0.0

e Type: | none v

ﬁ 7 OPTIONS
e L =

o

¥ Enable.

Figura, modificata
Ia Cadrul 25

Optiuni i proprietati
pentru Stratul Armature

QU Layert

Pose Frame adaugat la Cadru 25
i
1) @G W25 2400fe 10s

ol





Animatia rezultata va fi ceva asemanator cu aceasta:

- Ca si la Motion Tween, se poate aplica Ease Stratului Armature, se pot adauga oricate "Pose Frame" sunt necesare animatiei, pentru a crea o mai mare varietate de miscari.
- In Timeline se pot copia, lipi, sterge si goli cadre din animatie prin optiunile ce apar la click-dreapta pe Frame-ul respectiv.
Daca se apasa click pe un Frame din animatie, vor fi selectate toate cadrele ei; iar daca acestea fiind selectate, se da click-dreapta pe ele si se alege "Insert Frame", va fi adaugata inca o serie intreaga de cadre simple, cat e numarul celor selectate.
- Pentru a selecta un singur Frame, se tine apasata tasta Ctrl si se da click pe el.

- Daca se misca pozitia figurii in Scena, la un Cadru care nu este "Pose Frame", la cea mai mica modificare a pozitiei, acel cadru va fi transformat in Pose Frame.
- Pentru a retine un anumit timp o pozitie fixa (a "ingheta" miscarea pt. un interval) in cadrul animatiei Armature, se copie de mai multe ori acelasi Pose Frame in Cadrele din jurul lui; prin click-dreapta pe acel "Pose Frame", se alege Copy Pose, apoi, click-dreapta pe cadrele simple de langa el si se da Paste Pose.
- Stergerea unui cadru se face cu Remove Frame, dupa ce se da click-dreapta pe el. Clear Pose sterge continutul din Scena de la acel cadru, dar el ramane in animatie.
2. Proprietati pentru Bones

Pe langa proprietatile specifice stratului Armature, acest tip de animatie poate fi editata si prin proprietatile fiecarui "Bone" (os), prin care se pot realiza diferite setari fiecarei legaturi in parte, ajutand la un control sporit in modificarea figurii.
Cand se apasa click pe un "bone" si acesta este selectat, in panoul Properties apar proprietatile lui, ca in imaginea urmatoare.
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· Cu sagetile /butoanele din partea de sus se schimba legatura (bone) selectata.

· Location - Arata pozitia X, Y a osului (in raport cu coltul stanga-sus a Scenei), lungimea si unghiul lui de rotatie.

· Speed - Se defineste viteza de miscare a legaturii (in animatie) in raport cu celelalte "bones".

· Joint: Rotation
· Enable - Activeaza / Dezactiveaza posibilitatea de rotire a legaturii

· Constrain - Daca e bifat, restrange unghiul de rotire la valorile date cu Min si Max

· Joint: X Translation - Daca Enable e bifat, permite tragerea legaturii pe orizontala din structura de "bones", tragand (intinzand) pe cel de care e legata.
- Constrain (cu Min si Max) seteaza /restrange limita de deplasare pe orizontala.

· Joint: Y Translation - Daca Enable e bifat, permite tragerea legaturii pe verticala din structura de "bones", tragand (intinzand) pe cel de care e legata.
- Constrain (cu Min si Max) seteaza /restrange limita de deplasare pe verticala.

· Spring - Setari pentru elasticitatea miscarii.
- Cu cat valoarea de la Strength e mai mare, cu atat miscarea e mai rigida.
- Cu cat valoarea de la Damping e mai mare cu atat miscarea elastica se diminueaza mai rapid.

- Un Bone poate fi lungit prin mutarea Simbolului pe care-l leaga (din coada lui). Acesta se poate muta cu "Free Transform Tool".
Pentru a misca un bone (si pe cele legate de el) fara a misca legatura parinte (de care acela e legat), se tine apasata tasta Shift si se misca osul (bone) cu "Selection Tool".

Bind Tool si Control Points

In bara de instrumente pentru desen, la butonul "Bone Tool" se afla inca un instrument pentru lucru cu legaturi "bones", si anume Bind Tool.
Bind Tool poate fi utilizat doar la structuri in care legaturile cu "Bone Tool" sunt adaugate in interiorul unei Forme (vedeti lectia Utilizare Bone Tool).
In mod initial, miscarea unei legaturi dintr-un sir de "bones" este influentata de legaturile atasate ei, de care este unita direct. Cu "Bind Tool" se poate influenta ca un Bone sa fie controlat de oricare alt Bone din structura. Acest lucru se face prin niste puncte numite Control Points (Puncte de control), care sunt create de Flash in jurul conturului Formei (pe marginea ei) si sunt vizibile dupa ce se da click cu "Bind Tool" pe acea forma (dupa cum este indicat in imaginea urmatoare).
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- Punctele sunt clar vizibile cand imaginea din Scena este marita, de la Zoom (in dreapta-sus) sau cu Lupa.
Cand se da click cu Bind Tool pe un Bone, punctele de control conectate la el apar colorate in galben.
- Punctele de control in forma de patrat sunt conectate la un singur Bone, cele triunghiulare sunt conectate cu mai multe "Bones".
Cand forma este miscata, punctele de control din acea zona care se misca trag la randul lor de legaturile la care sunt conectate.


- Conectare Control Point la un Bone
· Cu "Bind Tool" se da click pe figura ca sa apara punctele de control. Se tine apasat click pe punctul de control respectiv si se trage cu mouse-ul spre osul la care sa fie conectat, pe care-l va controla. Va apare o linie galbena (ca in imaginea de mai sus) care poate fi considerata ca un tendon de legatura inre Control Point si Bone.
- Prin aceasta metoda, se sterge conectarea pe care acel punct o avea cu alt Bone.
Pentru ca punctul de control respectiv sa ramna conectat si la celalalt Bone, se foloseste urmatoarea metoda:
    - Se da click cu Bind Tool pe osul ce trebuie conectat, apoi, cu tasta Shift apasata, se da click pe Control Point.

- Deconectare Control Point
· Se foloseste Bind Tool pentru a selecta un Bone, apoi, cu tasta "Ctrl" apasata se da click pe punctul de control galben ce trebuie deconectat; acesta va deveni albastru, indicand ca nu mai este conectat cu acel Bone.

- Conectare Bone la un Control Point
· Se foloseste Bind Tool pentru a selecta un Bone, apoi, cu tasta "Ctrl" apasata se da click pe punctul de control albastru ce trebuie conectat; acesta va deveni galben, indicand ca este conectat cu acel Bone.

- Stergere Control Point
· Se alege "Delete Anchor Point Tool" din bara cu instrumente pt. desen, unde e butonul "Pen Tool" (sau rapid, tasta minus "-"), cu acesta se apasa click pe structura; dupa ce apar punctele de control, se da click pe cel care trebui sters.

- Adaugare Control Point
· Se alege "Add Anchor Point Tool" din bara cu instrumente pt. desen, unde e butonul "Pen Tool" (sau rapid, tasta cu semnul egal "="), cu acesta se apasa click pe structura; dupa ce apar punctele de control, se da click exact pe linia de margine a Formei, unde trebuie adaugat un Control Point.

Cu "Subselection Tool" se poate modifica marginea (conturul) formei, respectiv, se va schimba si pozitia punctelor de control.
Se da click cu Subselection Tool pe Forma (sau pe linia ei de margine) pana apar punctele de control, apoi se trage cu mouse-ul de ele.

Utilizare Masks

Se pot crea Mask Layers (Straturi masti sau Straturi de mascare /ascundere) pentru a arata si ascunde parti din continutul Flash.
O Msca in Flash functioneaza ca o fereastra prin care se poate vedea continutul Flash, acoperind totul in afara acelei ferestre. Controleaza partea vizibila dintr-unul sau mai multe Layers.
Orice Forma, Symbol sau element Text pot fi utilizate ca o masca. Forma desenata intr-un Strat Mask defineste suprafata (fereastra) prin care va fi vizibil continut din Straturile, definite ca "Masked" (Mascate), de sub acel "Mask Layer".
Aceasta tehnica creaza un efect deosebit, mai ales ca o Masca poate fi animata; si este utila in a evidentia si controla forma zonei vizibile dintr-o prezentare Flash.
- Cand se creaza un Strat Masca, este important sa nu se amestece elemente diferite in el; de exemplu, sa nu se foloseasca o Forma si un Grup in acelasi Strat.

Creare Masks

Pentru a realiza acest efect, denumit Mask, trebuie creat in Timeline un Mask Layer si alt Strat (sau mai multe) care sa fie legate de el (pozitionate imediat sub el).
Orice Strat poate fi utilizat (transformat) in "Mask Layer", prin click-dreapta pe numele lui, in Timeline, si se alege optiunea Mask.
- Cu aceasta metoda, Stratul de sub el va fi automat legat de el, transformat intr-un "Masked Layer" (Strat Mascat), si ambele inchise, dupa cum se vede in imaginea urmatoare.
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O alta metoda de creare Strat Masca e urmatoarea:
  - Se da click-dreapta pe numele stratului si se alege optiunea Properties (sau din meniul Modify -> Layer Properties), iar in fereastra care se deschide (cea din imaginea urmatoare) se bifeaza optiunea Mask.
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- Stratul respectiv va deveni Mask Layer, fara sa mai fie blocat, iar cel de sub el ramane normal. Pentru a-l lega pe acesta la cel transformat in Mask, se da click-dreapta pe cel normal, si deschizand aceeasi fereastra de la "Properties" se bifeaza optiunea Masked.
- Un Mask Layer afecteaza doar straturile legate de el, si pot fi incluse oricate astfel de "Straturi Mascate", prin tragerea lor cu mouse-ul sub el.

Iata un exemplu de creare si utilizare a unui Mask Layer animat. Efectuati urmatorii pasi (puteti urmari nmai intai prezentarea de mai jos "Exemplu utilizare Mask"):

1. Deschideti un document Flash nou si adaugati in scena o poza (prin meniul File -> Import -> Import to Stage, sau "Ctrl+R").
2. Adaugati inca un Strat in Timeline (prin click pe butonul "New Layer" din bara de jos, sau meniul Insert -> Timeline -> Layer) si transformati-l in "Mask" (prin click-dreapta -> Properties, in fereastra ce se deschide bifati Mask si apasati OK).
3. In acest Mask Layer desenati un oval (cu "Oval Tool") in partea stanga a pozei. Acest oval va fi zona (fereastra) de vizualizare.
Convertiti ovalul in Symbol Movie Clip (cu tasta "F8" sau Modify -> Convert to Symbol). Pentru a putea fi animat cu Movie Tween.
4. Click-dreapta pe Cadrul 40 din Layer 1 si alegeti Insert Keyframe.
  - Cu aceasta, prezentarea Flash va avea 40 de Cadre in care va fi afisata mereu poza.
5.Acum se face animatia la figura folosita ca vizualizare pt. Mask (ovalul Movie Clip din Layer 2), o animatie continua stanga-dreapta, cu modificarea formei, si aceeasi lungime de 40 Cadre.
Click-dreapta pe Cadru 40 din Layer 2 (cel facut Mask) si alegeti Insert Frame, apoi click pe meniul Insert -> Motion Tween.
6. Inca o data click-dreapta pe Frame 40 din "Layer 2" si alegeti Insert Keyframe, apoi click simplu pe Cadru 20 din acelasi Strat.
7. La acest Cadru, mutati ovalul in dreapta pozei si mariti-i dimensiunile (cu "Free Transform Tool").
Click si pe Frame 40, mariti si aici dimensiunile ovalului din Scena.
8. Click-dreapta pe numele "Layer 1" din Timeline, apoi Properties, in fereastra ce se deschide bifati Masked si apasati OK.
  - Astfel, acest Strat devine legat de cel de deasupra (transformat in Mask Layer) si "Masca" creata in acela are efect asupra lui.
Apasati "Ctrl+Enter" ca sa vedeti rezultatul obtinut. Va apare o prezentare similara cu aceasta:

- In prezentarea urmatoare puteti vedea cum se face acest exemplu.
- Exemplu utilizare Mask
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 Obiectele din stratul Masca (aici fereastra oval) pot fi editate normal (pozitie, forma, etc.), miscarea de asemenea poate fi modificata ca orice animatie Motion Tween, sa se obtina diferite forme ale traseului miscarii si zonei de vizualizare.
- Se poate folosi orice tip de animatie in Stratul Masca (frame-by-frame, Shape Tween, ...), dupa cum permit obiectele din el.
O alta idee ce poate crea un efect deosebit e ca Fereastra sa ramana fixa si miscarea /animatia sa fie facuta la poza (dupa ce e transformata in Symbol Movie Clip).
- De stiut ca prea multe Mask Layers pot afecta performantele in Flash Player.


- Pentru a anula un "Mask Layer", sa redevina Strat Normal, se bifeaza optiunea Normal din fereastra care se deschide de la optiunea "Properties" (dupa ce se apasa click-dreapta pe numele lui).
- Similar, ca sa fie scos un "Masked Layer" din legatura cu un "Strat Masca", se bifeaza optiunea Normal din fereastra care se deschide de la optiunea lui "Properties".
- Pentru a sterge un "Strat Masca" se da click-dreapta pe numele lui si se alege Delete Layer.
Obiecte in plan 3D

In plan 3D se folosesc 3 directii, sau axe: X (pt. orizontala), Y (pt. verticala) si Z (pt. adancime sau perspectiva). Prin setarea si modificarea acestora, in special a axei Z, se obtin obiecte 3D si miscarea lor.
Pentru a facilita lucrul cu obiecte in plan 3D, Adobe Flash are doua instrumente speciale "3D Rotation Tool" si "3D Translation Tool".
      - Cu 3D Rotation Tool se face rotirea in jurul axelor X, Y, Z.
      - Cu 3D Translation Tool se misca obiectul Movie Clip (sau Text) dea lungul celor 3 axe. Miscarea in spatiu 3D se numeste translation(translatie).
- Important: Numai elementele Text si Symbol Movie Clip pot fi folosite pentru efecte si animatii 3D.
Flash furnizeaza doua spatii 3D diferite: global si local. Acestea pot fi activate /dezactivate din butonul Global Tronsform, situat in zona cu optiuni din bara cu unelte pt. desen (vedeti in imaginea urmatoare), care apare cand este ales unul din instrumentele "3D Rotation" sau "3D Translation". Implicit (Default), acest buton este activat, setat Global.
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      - Spatiu 3D Global este spatiul Scenei.
      - Local 3D este spatiul "Movie Clip-ului".
Cand un Movie Clip este rotit sau miscat in axa Z, acesta devine un 3D Movie Clip si apar cele 3 axe, in culori diferite: axa X este rosie, axa Y e verde si axa Z albastra. Cand este ales "3D Rotation Tool" aceste axe apar in cadrul unui cerc portocaliu, iar cand este selectat "3D Translation", acestea sunt niste sageti (dupa cum se observa in imaginea urmatoare).
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- Pentru a roti obiectul doar pe unul din axe, se tine apasat click pe linia axei respective (in dreptul cursorului mouse-ului va apare litera ei) si se misca mouse-ul in directia dorita. Rotatia se face in jurul unui cerculet mic din centru (acesta poate fi mutat cu mouse-ul). Pentru ca rotatia (cu 3D Rotation) sa se faca in jurul celor 3 axe in acelasi timp, se foloseste linia de cerc portocalie (la ea nu apare nici o litera).
- Miscarea obiectului in plan 3D se face cu "3D Translation", prin tragere cu mouse-ul de sagetile axelor. Cand este setat pe modul "Loca" (butonul "Global Transform" neactivat) miscarea apare in perspectiva, creand perceptia de apropiere si departare a obiectului.

Lucrul cu obiecte in plan 3D se invata mai bine prin practica. Efectuati urmatorul exemplu:

1. Deschideti un document Flash nou si desenati in Scena un dreptunghi (cu "Rectangle Tool" si de preferat cu o culoare galbena sau portocaliu deschis pentru a se distinge bine axele), apoi, transformati-l in Movie Clip (de la meniul Modify -> Convert to Symbol, iar la Type puneti Movie Clip si apasati OK).
2. Alegeti instrumentul "3D Rotation Tool" si exersati diferite rotiri ale dreptunghiului, cu fiecare din axele de control, tragand cu mouse-ul de ele.
  - Puteti sa mutati si cerculetul din centru mai in margine si sa rotiti iar.
3. Alegeti "3D Translation Tool" si trageti de fiecare din sagetile care apar la obiect.
4. Dezactivati butonul "Global Transform" (se trece in modul Local) si trageti din nou de sageti. Se observa miscarea in perspectiva.


Cand se creaza un Movie Clip si e selectat, in panoul Properties apare proprietatea 3D Position and View cu optiuni pentru a misca si aseza mai precis obiectul in planul 3D si perspectiva.
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- Perspectiva este precum lentila unei camere foto, care face obiectul mai indepartat sau mai apropiat (cand valoarea din dreptul ei se mareste), implicit e setata la 55. Se pot da valori intre 1 si 180 grade
- Punctul de disparitie este cel din adancime, in distanta, unde liniile laturilor se strang (cum este prezentat in imaginea de mai jos), poate fi modificat din valorile X si Y asociate lui.
- Butonul Reset muta punctul de disparitie la pozitia initiala, in centrul Scenei.
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Cand sunt selectate mai multe obiecte "Movie Clip", rotirea si miscarea se face la toate deodata, ca si cum ar fi un singur obiect, in aceeasi directie.
- In afara de elementul Symbol Movie Clip, si Textul poate fi pozitionat in plan 3D. Metoda este aceeasi, se selecteaza si se modifica pozitia textului cu "3D Rotation Tool" si "3D Translation Tool".

Video in Flash - Adobe Media Encoder

Pentru a lucra cu fisiere video in Flash, acestea trebuie importate. Fisierele video sunt de mai multe tipuri, diferite in functie de codare (coding) si extensie. Filmele cu format FLV, F4V, MP4, M4V, AVC, MOV, QT, 3GP, 3GP2, 3G (recunoscute dupa aceste extensii) pot fi importate si folosite in Flash direct, ca si o imagine sau sunet, din meniul File -> Import -> Import Video.
- Pentru formatul FLV se poate folosi optiunea "Import to Library", deoarece FLV este nativ Flash si nu necesita codare; fisierul va fi stocat in panoul Library.
Fisierele video de tip AVI, MPEG, WMV trebuie mai intai codate, transformate in unul din cele enumerate mai sus. Adobe Flash contine o aplicatie speciala pentru realizarea acestei transformari, aplicatie denumita "Adobe Media Encoder".
- In aceasta lectie este prezentat modul de codare si convertire a fisierelor video AVI, MPEG, ... in format FLV /F4V, utilizand "Adobe Media Encoder CS5" (care este instalat impreuna cu "Adobe Flash CS5"). In lectia urmatoare este aratat modul de import si folosire a filmelor FLV in documentul Flash si pagini web.

Utilizare Adobe Media Encoder

Adobe Media Encoder nu este un progam special pentru editare video, el poate coda si transforma filmele, clipurile video, din format AVI, MPEG, ASF, WMV, DV ... in FLV, F4V sau MP4, ca sa poata fi utilizate in documente FLASH.
Nu poate imbunatati calitatea filmului, dar are cateva optiuni pentru codare, redimensionare, selectare portiune din film, anulare sunet, si alte cateva.
- Filmele care vor fi codate e indicat sa fie de calitate buna si necomprimate.

Din urmatorul exemplu se poate invata cum se foloseste acest program pentru a obtine fisiere video F4V (sau FLV). Efectuati urmatorii pasi:

1. Deschideti un document Flash nou si dati click pe meniul File -> Import -> Import Video. Se va deschide o fereastra ca cea din imaginea urmatoare.
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2. Apasati butonul "Launch Adobe Media Encoder". Daca apare o fereastra pentru salvare document Flash curent, puteti da "Save" sau "Cancel" (nu este important pentru acest exemplu).
Se va deschide aplicatia "Adobe Media Encoder" (cum se vede in imaginea urmatoare).
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  - Puteti deschide direct acest program, fara a mai deschide inainte Adobe Flash, din butonul Start de la Windows, apoi All Programs si in acele meniuri puteti gasi si "Adobe Media Encoder" (daca a fost instalat si cu scurtatura in "All Programs")
3. Click pe butonul Add (din partea dreapta a aplicatiei) si in fereastra care se deschide alegeti un fisier video din calculatorul dv. (de tip AVI, MPEG, WMV sau MP4).
  - Daca apare o fereastra Alert cu mesajul "Could not read from source. Please ..." inseamna ca filmul respectiv e comprimat. Se intampla la AVI. In acest caz alegeti altul..
4. Dupa ce filmul / video clipul este adaugat in aplicatie, se poate alege tipul formatului (de la Format, [FLV | F4V sau H.264]) in care va fi codat si salvat fisierul video pentru Flash, una din mai multe setari predefinite pentru formatul ales (de la Preset), precum si calea /numele pt. acest fisier (la Output File).
- Pentru inceput lasati la "Format" si "Preset" asa cum e.
  - Daca doriti sa folositi clipul video /filmul in site-uri web, e potrivit ca dimensiune /calitate sa alegeti la "Format" - FLV \F4V si la "Preset" - F4V - Match Source Attributes (Medium Quality) sau FLV - Web Medium (Flash 8 and Higer).
5. Click pe butonul Start Queue pentru a incepe conversia in formatul ales.
- In zona de jos din fereastra programului va apare date despre fisierului video rezultat, un mic preview si o bara in care se poate vedea timpul procesului de transformare.
  - In functie de marimea si calitatea filmului, finalizarea conversiei poate dura destul de mult.

- Dupa ce a fost astfel creat fisierul video FLV (sau F4V), poate fi importat in documentul Flash, Dupa cum este aratat in urmatoarea lectie.
Formatul F4V are o calitate mai buna si fisierul rezultat e mai mic decat la FLV, dar functioneaza pe Flash Player 9 si mai noi.
Daca la Format se alege H.264, fisierul rezultat va fi de tip MP4. Si acesta poate fi inclus direct in document /prezsentare Flash.

Setari in Adobe Media Encoder

Mai sus a fost aratata metoda de creare directa a unui fisier video FLV sau F4V cu "Adobe Media Encoder". Acest program are si posibilitatea de efectuare a catorva Setari pentru fisierul video rezultat dupa codare, cum ar fi: anulare sunet, obtinerea doar a unei parti din filmul original, redimensionare sau selectarea unei portiuni mai mici din imagine, si altele.
- Pentru a efectua aceste setari, se da click pe butonul Settings. Se va deschide o fereastra ca cea din imaginea urmatoare.
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In imaginea de sus sunt indicate cateva din optiunile mai importante din cele care pot fi setate.
      - Dupa cum se vede, si aici pot fi alese (in partea dreapta) Formatul, Preset-ul de codare si numele /calea pt. fisierul ce va fi creat.
      - Butonul de la "Crop output video" se foloseste pentru a selecta doar o portiune din imaginea filmului. Se da click pe el, apoi in imaginea previzualizata de sub el se defineste chenarul cu suprafata care va fi inregistrata in fisierul codat.
      - Butoanele "Set In Point" si "Set Out Point" se folosesc pentru a extrage doar o portiune din lungimea filmului. Se alege pe linia galbena de dedesupt (sau prin numarul pt. timp de deasupra) punctul de unde incepe portiunea care trebuie extrasa si se da click pe butonul "Set In Point", apoi, se alege si punctul de sfarsit si se apasa pe "Set Out Point". Va apare linia galbena doar intre cele doua puncte marcate, ceea ce reprezinta portiunea din film care va fi extrasa si codata in formatul ales.
      - Daca butonul "Export Audio" este debifat, va scoate sunetul din film.
- Celelalte optiuni din aceasta fereastra de setari tin de lucruri mai avansate, cand pozitionati cursorul de la mouse pe ele programul afiseaza explicatii in legatura cu rolul lor. De exemplu, la meniul Video este optiunea Rezize Video, pentru redimensionare.
In partea dreapta sunt date si detalii tehnice, atat legate de fisierul original cat si cel "output" (care va fi realizat), iar in dreapta-jos arata marimea fisierului rezultat. Aceste date pot fi utile, ca reper, cand se testeaza diferite setari.

Import Video in Flash

Pentru a importa filme, clipuri video intr-un document Flash, acestea trebuie sa aiba unul din urmatoarele formate: FLV, F4V, MP4, M4V, AVC, MOV, QT, 3GP, 3GP2, 3G. In general se folosesc FLV, F4V sau MP4.
Importul fisierelor video se face la fel de simplu ca si importul unei imagini sau sunet. Fereastra pt. "Video Import Wizard" (Fereastra "Expertul de import video") ghideaza usor prin procesul de adaugare video in Flash.
Sunt mai multe feluri de a folosi /include un video intr-o prezentare Flash.
- Filmul /clipul video poate fi stocat direct in documentul Flash, metoda cunoscuta ca "Embed", mai putin folosita deoarece fisierele video au dimensiuni mari si aceasta se va adauga la fisierul SWF rezultat.
- Filmul poate fi preluat si redat dintr-o locatie externa, printr-un Player inclus in Flash. Aceasta fiind metoda recomandata si cea mai utilizata.

Iata practic cum se adauga un video intr-un document Flash, prin redarea lui dintr-o locatie externa.

- Trebuie sa aveti pregatit un fisier video in format FLV, F4V sau MP4. Daca aveti in alte formate, vedeti lectia anterioara Video in Flash - Adobe Media Encoder.
1. Deschideti un document Flash nou si dati click pe meniul File -> Import -> Import Video. Se va deschide o fereastra ca cea din imaginea urmatoare.
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  - Aici sunt optiunile pt. alegerea fisierului video si a modalitatii de import.

· Browse - De la acest buton se deschide fereastra prin care va fi ales fisierul video.

· Load external video with playback ... - Cu aceasta optiune, filmul va fi redat din locatia lui externa.

· Embed FLV in SWF and play in timeline - Fisierul video (doar FLV) va fi stocat in document si in SWF-ul rezultat. Fiecare cadru din video va deveni un cadru in Timeline.

· Import as mobile device video ... - Este similar cu Embed. Stocheaza filmul intr-un document Flash Lite, pentru folosire cu dispozitive (telefoane) mobile.

· Already deployed to a web server ... - Foloseste fisiere video aflate pe un server special de streaming (emitere controlata).

2. Dati click pe butonul Browse si in fereastra care se deschide alegeti din calculatorul dv. un video FLV, F4V sau MP4.
- Asigurati-va ca este bifata optiunea "Load external video with playback".
3. Apasati pe butonul Next, se va deschide o fereastra ca cea din imaginea urmatoare.
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  - De la Skin se alege tipul (aspectul) player-ului pe care Adobe Flash il va include in document. Acesta va prelua si afisa filmul /clipul video.
  - De la Color se alege o culoare pentru zona cu butoanele de control.
4. Click pe Next, se va deschide o fereastra cu indicatii despre importul video realizat. Apasati pe butonul Finish.
  - Flash va adauga in document, in panoul Library, SWF-ul cu player-ul care va fi atasat la prezentarea creata, iar in Scena pune o instanta a acestuia, in care e afisat primul cadru din video; precum in imaginea urmatoare.
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  - Se poate testa direct in scena filmul si butoanele de control din Player, sau apasand "Ctrl+Enter".
Adaugare prezentare Flash cu Player Video in pagina web

Pentru a utiliza intr-o pagina web o prezentare Flash cu video (redat din locatie externa), se executa urmatorii pasi:

1. Se efectueaza importul video dupa cum este aratat mai sus.

2. Se da click, cu "Selection Tool" pe instanta de player din Scena, apoi se apeleaza panoul Properties. La meniul "Component Parameters" sunt mai multe optiuni pentru player-ul din scena (dupa cum se vede in imaginea urmatoare).
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    align - Determina alinierea imaginii video in Player, cand optiunea "scaleMode" nu e setata la "exactFit".
    autoPlay - Daca e selectat, filmul va incepe automat.
    isLive - Pentru cazul cand e folosit un server de streaming, filmul e redat in direct.
    scaleMode - Aici sunt 3 optiuni: noScale (sunt folosite dimensiunile filmului din fisier), maintainAspectRatio (imaginea video isi regleaza automat dimensiunile) si exactFit (forteaza imaginea la dimensiunile Player-ului).
    skin - Se poate selecta /schimba aspectul player-ului.
    skinAutoHide - Daca e selectat, zona cu butoanele de control apare cand mouse-ul e pe imaginea video.
    skinBackgroundAlpha - Face zona cu butoanele de control transparenta, in functie de valoarea data, intre 0 si 1 (0 e complet transparent).
    skinBackgroundColor - Culoarea pt. zona butoanelor de control.
    source - Calea si numele fisierului video.
    volume - Volumul sunetului redat, o valoare intre 0 si 1 (0 e fara sunet).

3. Partea importanta ce trebuie avuta in vedere pentru a folosi prezentarea cu video intr-o pagina web este locatia filmului care o va avea pe server in raport cu fisierul SWF al player-ului. Pentru a fi mai simplu vor fi stocate in acelasi director.
- La optiunea source se da click pe numele fisierului (sau "creionul" din dreptul lui), iar in fereasra care se deschide (precum cea din imaginea de mai jos) se lasa doar numele si extensia fisierului video.
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- Aici se trece locatia (si numele) fisierului video unde va fi stocat pe server, in raport cu SWF-ul player.

4. Se da click pe meniul File -> Export -> Export Movie.
- Astfel este creata prezentarea Flash (fisierul SWF), si impreuna cu ea, in acelasi director, Adobe Flash va adauga inca un SWF cu player-ul pt. film. Acesta va avea denumirea aleasa la "Skin". De exempu, daca la "skin" este "SkinOverAll.swf", acelasi nume il va avea si fisierul pt. Player.

5. Acum se urca pe server (in directorul in care se afla pagina in care va fi inclusa prezentarea) trei fisiere: fisierul SWF cu prezentarea Flash (realizata cu Export), cel cu Playerul si fisierul video.

6. In codul HTML al paginii web se adauga urmatorul cod:

<object type="application/x-shockwave-flash" data="nume_prezentare.swf" width="480" height="300">
    <param name="src" value="nume_prezentare.swf" />
    <param name="bgcolor" value="#ededfe" />
</object>

Aceasta metoda de includere video in pagini web, folosind Flash, e mai mult penstru studiu de invatare, sau in cazul cand sunt prezentate cateva filme /video clipuri. La site-uri create pentru vizualizare video, cu multe filme stocate, este indicat folosirea unui Video Player web. La o cautare pe net dupa cuvintele "Flash Player web" se gasesc destule, inclusiv gratuite.
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